Prostick Not Working With Piaware


#1

Hi all,

I went ahead and bought the new prostick along with the filter. Upon hooking it up to my model B pi it does not appear to be working, piaware is working and connected to flightaware however when I look at the logs on the site I see what I pasted below. I know the stick works as I went ahead and tried it with windows and picked up A/C no problem. As soon as I hook my rtl blog receiver everything goes back to normal and works fine. Any ideas would be great.

[2016-05-03 19:31 EDT] no ADS-B data program is serving on port 30005, not starting multilateration client yet
[2016-05-03 19:31 EDT] no ADS-B data program seen listening on port 30005 for 131 seconds, next check in 60s
[2016-05-03 19:32 EDT] no ADS-B data program is serving on port 30005, not starting multilateration client yet
[2016-05-03 19:32 EDT] no ADS-B data program seen listening on port 30005 for 191 seconds, next check in 60s
[2016-05-03 19:33 EDT] no ADS-B data program is serving on port 30005, not starting multilateration client yet
[2016-05-03 19:33 EDT] no ADS-B data program seen listening on port 30005 for 251 seconds, next check in 60s
[2016-05-03 19:34 EDT] no ADS-B data program is serving on port 30005, not starting multilateration client yet
[2016-05-03 19:34 EDT] no ADS-B data program seen listening on port 30005 for 311 seconds, next check in 60s
[2016-05-03 19:35 EDT] 0 msgs recv’d from the ADS-B data program (0 in last 5m); 0 msgs sent to FlightAware
[2016-05-03 19:35 EDT] no ADS-B data program is serving on port 30005, not starting multilateration client yet


#2

Problem Solved, It appears to have been a power issue. After removing my usb wifi adapter it seems to be working.


#3

Never mind, keeps randomly stopping working. So far as much as I hate to say it this new stick seems to be junk, yes it increases my range but its pointless if it stops working randomly… I normally have my pie powered via poe however I have tried multiple adapters to no avail. If this stick needs more then a 2.5a wall wart to work then that is crazy!! I have not had an issue with my rtl blog receivers. Does anyone have any idea how to fix this?


#4

The Pi is very sensitive to power problems, so that’s the most likely explanation.

A bad USB contact is another possibility (the prostick case encroaches on the USB connector which is a problem with some connections)

If “dmesg” output shows dongle disconnects/reconnects then it is a USB or power problem.


#5

I will tell you that I had my Pi powered by a POE breakout for a while, but I always ended up having power issues. It worked just barely with my Pi and SDR dongle but anything else would start causing issues. I’ve since moved to a dedicated power supply for the Pi and I have had zero issues since then.

I suspect you’re having power issues after swapping in the pro-stick because IIRC, they draw more power.


#6

Which B model? 1,2 or 3?
I am not sure a 1B would handle the power too well.
raspberrypi.org/help/faqs/#topPower

Have you tried adding usb_max_current=1 to /boot/config.txt

raspberrypi.org/forums/view … b8#p949351


#7

2 Model B and yes that was actually uncommented by default on mine apparently. I am going on a little over 12 hours of no issues so I am not really sure what to make of it.


#8

I’d still put money on power issues.