My Pi is dead

I’ve tried different power cords and nothing seems to work.

So looking to replace the Pi, don’t need all the other items, so can I just use the same SD card in the new Pi3?

If it is running Jessie made after Janaury or a piaware sd image made in the last 10 days.
Otherwise you will need to re-image the card.

Note: the rpi1 uses a larger sd card. The rpi2/3 use the same type of sd card

Do you know its the Pi and not the SD card?

Don’t honestly know. It just won’t send a signal any longer. I’ve been out of town for 2 weeks and it’s been down for that time as I didn’t have time to fix it before I left. Changed the power cord, unplugged it and tried to get it to start up again. Red light comes on but where it’s at I cannot see if it’s working so by the time I get to a computer it is not sending a signal so I just figured it’s time for a new one.

I’m using a micro sd card at the moment. This is the same as the Pi3? Guess I can download the newest image and try that before I order a new Pi

SD cards have a much higher failure rate than Pi’s.
I always keep a working copy of my cards in case something goes wrong.

Hmmmm… Thinking

What do the lights on the RPI display when you try to power it up?
Have you tried plugging the HDMI into a TV/Monitor to see what it displays?

Not yet. Been out of town for the past two weeks.

Gonna try working on it this week. Will swap out the pi I use for my Stratux if I have too.

Ok, so I’ve had a chance to take the Pi out of it’s location and put it in my hands.

The red and the green lights stay lit.

Is this what I am supposed to have?

Been a year since I built this thing and I’ve forgotten all I didn’t know.

I had the same issue after about a year of continuous running. Plugged it into an HDMI output and was able to see the boot sequence. Came up with a disk error and had me run a disk check command. It fixed the dozen disk errors and was able to boot up and continue working… for a few days. Now I’m in the process of starting from a new card with Jessie.

The first thing I’d do is try a new SD card. On this and various other always-on RPi projects I find they burn out anywhere from 3-16 months. I’ve only been doing this since january but I already have one card that no longer runs stable even after being re-imaged. (granted, I had tried some modifications that ended up hammering the filesystem)

All the USB ports on my Pi2b stopped working! Seems they no longer get power. It only lasted 3 months. :imp:

This is somewhat of a hail mary pass, but have you tried unplugging it and letting it sit unpowered for a while, and making sure there’s no debris or anything stuck in the ports? I know the Pi 2’s usb ports have a Polyfuse that could have blown - I don’t know how long it would take to reset. Could be a couple of days.

Especially if like, a shard of tinfoil got into one of the ports, shorted it and blew the fuse. If it’s still in there, it’ will just keep blowing (Yes, I did see specifically this once, and no, I don’t know how the tinfoil got in there)

Thanks, I don’t see any bits in the ports, and it was running fine untouched until it suddenly lost its wifi connection. That’s when I realized the usb ports were dead. Ethernet and the rest of the board works fine still.

I read about this problem on the Pi B+, which has polyfuses for usb ports. As far as I can tell the Pi2 only has one main polyfuse, so it seems unlikely that blew if everything else on the board is working. I let it sit unplugged for 2 days anyway, but no luck.

Thankfully the eBay seller I bought it from said he would honor his warranty, which is great since I’d have no recourse if he didn’t (too late for a chargeback or negative feedback). So I am sending it back.

I think it has found a new life. I unplugged the sd card and reinstalled it, possibly there was some corrosion on it due to the wet season but it’s been working great for the past week.

Better lucky than good some times.

If you are running Rasbian Jessie update your OS using the following commands just in case God forbid you need to transfer the SD card to a RPi3. By fully updating your Raspbian OS it wont matter if you are using a Jessie release before RPi 3 support was added being the updates will add support for it.

sudo apt-get update
sudo apt-get dist-upgrade