FlightAware Discussions

My Flightradar24 feeder keeps stopping

I recently moved from Tenn to NY. I am feeding FlightAware and Flightradar24. My feeder was working quite well in Tenn. until about a week before I moved. Now that I have my feeder installed in the new location Flightradar24 intermittently stops sending data. The only way I know to get it going again is to reboot the Pi. I finally had some time where I could capture some of the log from FlightAware. It looks to me like FlightAware continues sending data ok but Flightradar24 does not. Can anyone provide some insight? I can post the log if that would be of any help. I am at a loss as to what is happening…

Can you login (SSH) to the device and run the following command:

tail -n100 /var/log/piaware.log

and paste it back here or on pastebin, please.

pi@raspberrypi:~ $ tail -n100 /var/log/piaware.log
Sep 9 07:12:04 raspberrypi piaware[569]: 106497 msgs recv’d from dump1090-fa (639 in last 5m); 106407 msgs sent to FlightAware
Sep 9 07:17:04 raspberrypi piaware[569]: 107246 msgs recv’d from dump1090-fa (749 in last 5m); 107156 msgs sent to FlightAware
Sep 9 07:22:04 raspberrypi piaware[569]: 107942 msgs recv’d from dump1090-fa (696 in last 5m); 107852 msgs sent to FlightAware
Sep 9 07:23:24 raspberrypi piaware[569]: mlat-client(1035): Receiver status: connected
Sep 9 07:23:24 raspberrypi piaware[569]: mlat-client(1035): Server status: synchronized with 179 nearby receivers
Sep 9 07:23:24 raspberrypi piaware[569]: mlat-client(1035): Receiver: 146.2 msg/s received 70.1 msg/s processed (48%)
Sep 9 07:23:24 raspberrypi piaware[569]: mlat-client(1035): Server: 0.0 kB/s from server 0.0kB/s TCP to server 0.9kB/s UDP to server
Sep 9 07:23:24 raspberrypi piaware[569]: mlat-client(1035): Aircraft: 4 of 4 Mode S, 26 of 26 ADS-B used
Sep 9 07:27:04 raspberrypi piaware[569]: 108567 msgs recv’d from dump1090-fa (625 in last 5m); 108477 msgs sent to FlightAware
Sep 9 07:32:04 raspberrypi piaware[569]: 109150 msgs recv’d from dump1090-fa (583 in last 5m); 109060 msgs sent to FlightAware
Sep 9 07:32:41 raspberrypi piaware[569]: manual update (user-initiated via their flightaware control page) requested by adept server
Sep 9 07:32:41 raspberrypi piaware[569]: performing manual update, action: reboot
Sep 9 07:32:41 raspberrypi piaware[569]: creating pidfile /run/piaware/upgrader.pid
Sep 9 07:32:41 raspberrypi piaware[569]: rebooting…
Sep 9 07:32:41 raspberrypi piaware[569]: removing pidfile /run/piaware/upgrader.pid
Sep 9 07:32:41 raspberrypi piaware[569]: update request complete
Sep 9 07:32:42 raspberrypi piaware[569]: piaware (process 569) is shutting down because it received a shutdown signal (SIGTERM) from the system…
Sep 9 07:34:22 raspberrypi piaware[536]: creating pidfile /run/piaware/piaware.pid
Sep 9 07:34:22 raspberrypi piaware[536]: ****************************************************
Sep 9 07:34:22 raspberrypi piaware[536]: piaware version 3.8.1 is running, process ID 536
Sep 9 07:34:22 raspberrypi piaware[536]: your system info is: Linux raspberrypi 4.19.97-v7+ #1294 SMP Thu Jan 30 13:15:58 GMT 2020 armv7l GNU/Linux
Sep 9 07:34:24 raspberrypi piaware[536]: Connecting to FlightAware adept server at piaware.flightaware.com/1200
Sep 9 07:34:24 raspberrypi piaware[536]: Connection to adept server at piaware.flightaware.com/1200 failed: couldn’t open socket: Temporary failure in name resolution
Sep 9 07:34:24 raspberrypi piaware[536]: reconnecting in 6 seconds…
Sep 9 07:34:26 raspberrypi piaware[536]: ADS-B data program ‘dump1090-fa’ is listening on port 30005, so far so good
Sep 9 07:34:26 raspberrypi piaware[536]: Starting faup1090: /usr/lib/piaware/helpers/faup1090 --net-bo-ipaddr localhost --net-bo-port 30005 --stdout --lat 43.051 --lon -78.865
Sep 9 07:34:26 raspberrypi piaware[536]: Started faup1090 (pid 745) to connect to dump1090-fa
Sep 9 07:34:26 raspberrypi piaware[536]: UAT support disabled by local configuration setting: uat-receiver-type
Sep 9 07:34:26 raspberrypi piaware[536]: piaware received a message from dump1090-fa!
Sep 9 07:34:30 raspberrypi piaware[536]: Connecting to FlightAware adept server at piaware.flightaware.com/1200
Sep 9 07:34:30 raspberrypi piaware[536]: Connection with adept server at piaware.flightaware.com/1200 established
Sep 9 07:34:30 raspberrypi piaware[536]: TLS handshake with adept server at piaware.flightaware.com/1200 completed
Sep 9 07:34:30 raspberrypi piaware[536]: FlightAware server certificate validated
Sep 9 07:34:30 raspberrypi piaware[536]: encrypted session established with FlightAware
Sep 9 07:34:31 raspberrypi piaware[536]: adept reported location: 43.05136, -78.86525, 594ft AMSL
Sep 9 07:34:31 raspberrypi piaware[536]: logged in to FlightAware as user verdi
Sep 9 07:34:31 raspberrypi piaware[536]: my feeder ID is 59ff222e-fa4c-4db9-8126-a546002c4438
Sep 9 07:34:31 raspberrypi piaware[536]: site statistics URL: https://flightaware.com/adsb/stats/user/verdi#stats-123421
Sep 9 07:34:31 raspberrypi piaware[536]: multilateration data requested
Sep 9 07:34:31 raspberrypi piaware[536]: Starting multilateration client: /usr/lib/piaware/helpers/fa-mlat-client --input-connect localhost:30005 --input-type dump1090 --results beast,connect,localhost:30104 --results beast,listen,30105 --results ext_basestation,listen,30106 --udp-transport 70.42.6.224:12004:1725960772
Sep 9 07:34:32 raspberrypi piaware[536]: mlat-client(911): fa-mlat-client 0.2.11 starting up
Sep 9 07:34:32 raspberrypi piaware[536]: mlat-client(911): Using UDP transport to 70.42.6.224 port 12004
Sep 9 07:34:32 raspberrypi piaware[536]: mlat-client(911): Listening for Beast-format results connection on port 30105
Sep 9 07:34:32 raspberrypi piaware[536]: mlat-client(911): Listening for Extended Basestation-format results connection on port 30106
Sep 9 07:34:32 raspberrypi piaware[536]: mlat-client(911): Route MTU changed to 1500
Sep 9 07:34:32 raspberrypi piaware[536]: mlat-client(911): Input connected to localhost:30005
Sep 9 07:34:32 raspberrypi piaware[536]: mlat-client(911): Input format changed to BEAST, 12MHz clock
Sep 9 07:34:32 raspberrypi piaware[536]: mlat-client(911): Beast-format results connection with ::1:30104: connection established
Sep 9 07:34:33 raspberrypi piaware[536]: piaware has successfully sent several msgs to FlightAware!
Sep 9 07:35:12 raspberrypi piaware[536]: 121 msgs recv’d from dump1090-fa; 45 msgs sent to FlightAware
Sep 9 07:35:43 raspberrypi piaware[536]: timed out waiting for alive message from FlightAware, reconnecting…
Sep 9 07:35:43 raspberrypi piaware[536]: multilateration data no longer required, disabling mlat client
Sep 9 07:35:44 raspberrypi piaware[536]: fa-mlat-client exited normally
Sep 9 07:35:44 raspberrypi piaware[536]: reconnecting in 5 seconds…
Sep 9 07:35:44 raspberrypi piaware[536]: mlat-client(911): Disconnecting from localhost:30005: Lost connection to multilateration server, no need for input data
Sep 9 07:35:44 raspberrypi piaware[536]: mlat-client(911): Exiting on connection loss
Sep 9 07:35:49 raspberrypi piaware[536]: Connecting to FlightAware adept server at piaware.flightaware.com/1200
Sep 9 07:35:49 raspberrypi piaware[536]: Connection with adept server at piaware.flightaware.com/1200 established
Sep 9 07:35:49 raspberrypi piaware[536]: TLS handshake with adept server at piaware.flightaware.com/1200 completed
Sep 9 07:35:49 raspberrypi piaware[536]: FlightAware server certificate validated
Sep 9 07:35:49 raspberrypi piaware[536]: encrypted session established with FlightAware
Sep 9 07:35:50 raspberrypi piaware[536]: logged in to FlightAware as user verdi
Sep 9 07:35:50 raspberrypi piaware[536]: my feeder ID is 59ff222e-fa4c-4db9-8126-a546002c4438
Sep 9 07:35:50 raspberrypi piaware[536]: site statistics URL: https://flightaware.com/adsb/stats/user/verdi#stats-123421
Sep 9 07:35:50 raspberrypi piaware[536]: multilateration data requested
Sep 9 07:35:50 raspberrypi piaware[536]: Starting multilateration client: /usr/lib/piaware/helpers/fa-mlat-client --input-connect localhost:30005 --input-type dump1090 --results beast,connect,localhost:30104 --results beast,listen,30105 --results ext_basestation,listen,30106 --udp-transport 70.42.6.232:11087:3617018401
Sep 9 07:35:50 raspberrypi piaware[536]: mlat-client(980): fa-mlat-client 0.2.11 starting up
Sep 9 07:35:50 raspberrypi piaware[536]: mlat-client(980): Using UDP transport to 70.42.6.232 port 11087
Sep 9 07:35:50 raspberrypi piaware[536]: mlat-client(980): Listening for Beast-format results connection on port 30105
Sep 9 07:35:50 raspberrypi piaware[536]: mlat-client(980): Listening for Extended Basestation-format results connection on port 30106
Sep 9 07:35:50 raspberrypi piaware[536]: mlat-client(980): Route MTU changed to 1500
Sep 9 07:35:50 raspberrypi piaware[536]: mlat-client(980): Input connected to localhost:30005
Sep 9 07:35:50 raspberrypi piaware[536]: mlat-client(980): Input format changed to BEAST, 12MHz clock
Sep 9 07:35:51 raspberrypi piaware[536]: mlat-client(980): Beast-format results connection with ::1:30104: connection established
Sep 9 07:39:57 raspberrypi piaware[536]: 792 msgs recv’d from dump1090-fa (671 in last 5m); 709 msgs sent to FlightAware
Sep 9 07:44:57 raspberrypi piaware[536]: 1458 msgs recv’d from dump1090-fa (666 in last 5m); 1375 msgs sent to FlightAware
Sep 9 07:49:57 raspberrypi piaware[536]: 2068 msgs recv’d from dump1090-fa (610 in last 5m); 1985 msgs sent to FlightAware
Sep 9 07:50:51 raspberrypi piaware[536]: mlat-client(980): Receiver status: connected
Sep 9 07:50:51 raspberrypi piaware[536]: mlat-client(980): Server status: synchronized with 206 nearby receivers
Sep 9 07:50:51 raspberrypi piaware[536]: mlat-client(980): Receiver: 225.0 msg/s received 99.6 msg/s processed (44%)
Sep 9 07:50:51 raspberrypi piaware[536]: mlat-client(980): Server: 0.0 kB/s from server 0.0kB/s TCP to server 1.3kB/s UDP to server
Sep 9 07:50:51 raspberrypi piaware[536]: mlat-client(980): Aircraft: 5 of 5 Mode S, 32 of 32 ADS-B used
Sep 9 07:54:57 raspberrypi piaware[536]: 2684 msgs recv’d from dump1090-fa (616 in last 5m); 2601 msgs sent to FlightAware
Sep 9 07:59:57 raspberrypi piaware[536]: 3186 msgs recv’d from dump1090-fa (502 in last 5m); 3103 msgs sent to FlightAware
Sep 9 08:04:57 raspberrypi piaware[536]: 3684 msgs recv’d from dump1090-fa (498 in last 5m); 3601 msgs sent to FlightAware
Sep 9 08:05:51 raspberrypi piaware[536]: mlat-client(980): Receiver status: connected
Sep 9 08:05:51 raspberrypi piaware[536]: mlat-client(980): Server status: synchronized with 201 nearby receivers
Sep 9 08:05:51 raspberrypi piaware[536]: mlat-client(980): Receiver: 175.2 msg/s received 80.5 msg/s processed (46%)
Sep 9 08:05:51 raspberrypi piaware[536]: mlat-client(980): Server: 0.0 kB/s from server 0.0kB/s TCP to server 1.1kB/s UDP to server
Sep 9 08:05:51 raspberrypi piaware[536]: mlat-client(980): Aircraft: 8 of 8 Mode S, 26 of 26 ADS-B used
Sep 9 08:09:57 raspberrypi piaware[536]: 4246 msgs recv’d from dump1090-fa (562 in last 5m); 4163 msgs sent to FlightAware
Sep 9 08:14:57 raspberrypi piaware[536]: 4755 msgs recv’d from dump1090-fa (509 in last 5m); 4672 msgs sent to FlightAware
Sep 9 08:19:57 raspberrypi piaware[536]: 5308 msgs recv’d from dump1090-fa (553 in last 5m); 5225 msgs sent to FlightAware
Sep 9 08:20:51 raspberrypi piaware[536]: mlat-client(980): Receiver status: connected
Sep 9 08:20:51 raspberrypi piaware[536]: mlat-client(980): Server status: synchronized with 206 nearby receivers
Sep 9 08:20:51 raspberrypi piaware[536]: mlat-client(980): Receiver: 185.1 msg/s received 87.2 msg/s processed (47%)
Sep 9 08:20:51 raspberrypi piaware[536]: mlat-client(980): Server: 0.0 kB/s from server 0.0kB/s TCP to server 1.2kB/s UDP to server
Sep 9 08:20:51 raspberrypi piaware[536]: mlat-client(980): Results: 4.1 positions/minute
Sep 9 08:20:51 raspberrypi piaware[536]: mlat-client(980): Aircraft: 5 of 5 Mode S, 28 of 29 ADS-B used
Sep 9 08:24:57 raspberrypi piaware[536]: 5880 msgs recv’d from dump1090-fa (572 in last 5m); 5797 msgs sent to FlightAware

Have you set the new location in your FR24 stats page? If not, then go to flightradar24.com and login to your account, then do this:
https://www.flightradar24.com/account/data-sharing >> Click on “My Data Sharing” tab >> Click “Show Statistics” >> In the field “COORDINATES”, click on the “eye” symbol at far-right, and set new coordinates (see screenshot below)

Thank you for the suggesting… Yes I have updated the coordinates.

What is the output of this command?

fr24feed-status

 

pi@raspberrypi:~ $ fr24feed-status
[ ok ] FR24 Feeder/Decoder Process: running.
[ ok ] FR24 Stats Timestamp: 2020-09-10 01:11:08.
[ ok ] FR24 Link: connected [UDP].
[ ok ] FR24 Radar: T-KIAG4.
[ ok ] FR24 Tracked AC: 25.
[ ok ] Receiver: connected (2130658 MSGS/0 SYNC).
[ ok ] FR24 MLAT: ok [UDP].
[ ok ] FR24 MLAT AC seen: 21.

This is perfect. What makes you think it keeps stopping?

Anyway, if it is a connection to fr24 server issue, following workaround may help in maintaining connection of fr24 feeder and fr24 server:

(1) Open file fr24feed.ini
sudo nano fr24feed.ini
sudo nano /etc/fr24feed.ini

(2) Copy-paste following line below last line in above file:

use-http=yes  
http-timeout=20  

(3) Save file (Ctrl+O) and close file (Ctrl+x)

(4) Restart fr24feed
sudo systemctl restart fr24feed

It makes me think it keeps stopping bcz I get email from FR24 alerting me that it is down. And I also see this…

When I do… sudo nano fr24feed.ini I get the following…

Is that right ? I was expecting to see lines of code. Please confirm…

Looks like the network connection to FR24 is intermittent, probably routing issues or something.
Seems it was fine last Friday.

The file is /etc/fr24feed.ini not fr24feed.ini, without the path it checks the current directory where the file is not.

Anyhow … enable some sensible logging for fr24feed and check the log for disconnects after some time has passed.
https://github.com/wiedehopf/adsb-wiki/wiki/fr24feed-settings#enabling-sensible-logging-for-fr24feed

Install traceroute:

sudo apt install traceroute

When the connection issue happens, check the following command:

traceroute 185.218.24.1 

Thank you! I think I correctly installed your sensible logging.
This is the result of the log:
pi@raspberrypi:~ journalctl -u fr24feed --no-pager -- Logs begin at Wed 2020-09-09 17:04:16 EDT, end at Thu 2020-09-10 07:30:41 EDT. -- Sep 09 17:04:21 raspberrypi systemd[1]: Starting Flightradar24 Decoder & Feeder... Sep 09 17:04:21 raspberrypi systemd[1]: Started Flightradar24 Decoder & Feeder. Sep 10 07:12:07 raspberrypi systemd[1]: fr24feed.service: Current command vanished from the unit file, execution of the command list won't be resumed. Sep 10 07:15:28 raspberrypi systemd[1]: Stopping Flightradar24 Decoder & Feeder... Sep 10 07:15:33 raspberrypi systemd[1]: fr24feed.service: State 'stop-sigterm' timed out. Killing. Sep 10 07:15:33 raspberrypi systemd[1]: fr24feed.service: Killing process 451 (fr24feed) with signal SIGKILL. Sep 10 07:15:33 raspberrypi systemd[1]: fr24feed.service: Main process exited, code=killed, status=9/KILL Sep 10 07:15:33 raspberrypi systemd[1]: fr24feed.service: Failed with result 'timeout'. Sep 10 07:15:33 raspberrypi systemd[1]: Stopped Flightradar24 Decoder & Feeder. Sep 10 07:15:33 raspberrypi systemd[1]: Starting Flightradar24 Decoder & Feeder... Sep 10 07:15:33 raspberrypi fr24feed[4798]: rmmod: ERROR: Module dvb_usb_rtl28xxu is not currently loaded Sep 10 07:15:33 raspberrypi fr24feed[4798]: rmmod: ERROR: Module rtl2832 is not currently loaded Sep 10 07:15:33 raspberrypi fr24feed[4798]: rmmod: ERROR: Module e4000 is not currently loaded Sep 10 07:15:33 raspberrypi systemd[1]: Started Flightradar24 Decoder & Feeder. Sep 10 07:15:33 raspberrypi fr24feed[4806]: error | Local time: 2020-09-10 07:15:33 -0400 Sep 10 07:15:33 raspberrypi fr24feed[4806]: error | GMT+0 time: 2020-09-10 12:15:33 -0400 Sep 10 07:15:33 raspberrypi fr24feed[4806]: error | Your machine should be set as GMT+0 time zone! Sep 10 07:15:33 raspberrypi fr24feed[4806]: [main][i]FR24 Feeder/Decoder Sep 10 07:15:33 raspberrypi fr24feed[4806]: [main][i]Version: 1.0.25-3/generic Sep 10 07:15:33 raspberrypi fr24feed[4806]: [main][i]Built on Apr 8 2020 07:06:55 (HEAD-5e8ef0c.git/Linux/static_armel) Sep 10 07:15:33 raspberrypi fr24feed[4806]: [main][i]Running on: raspbian10 Sep 10 07:15:33 raspberrypi fr24feed[4806]: [main][i]Local IP(s): 192.168.0.6 Sep 10 07:15:33 raspberrypi fr24feed[4806]: [main][i]Copyright 2012-2020 Flightradar24 AB Sep 10 07:15:33 raspberrypi fr24feed[4806]: [main][i]https://www.flightradar24.com Sep 10 07:15:33 raspberrypi fr24feed[4806]: [main][i]DNS mode: PING Sep 10 07:15:34 raspberrypi fr24feed[4806]: [main][i]Automatic updates are ENABLED Sep 10 07:15:34 raspberrypi fr24feed[4806]: info | [httpd]Server started, listening on 0.0.0.0:8754 Sep 10 07:15:34 raspberrypi fr24feed[4806]: [d]TLSConnection::ctor(): Enable verify_peer in production code! Sep 10 07:15:34 raspberrypi fr24feed[4806]: [main][i]Reader thread started Sep 10 07:15:34 raspberrypi fr24feed[4806]: [main][i]MLAT data feed started Sep 10 07:15:34 raspberrypi fr24feed[4806]: [reader][i]Initializing reader Sep 10 07:15:34 raspberrypi fr24feed[4806]: [reader][i]Connecting to unknown receiver via (tcp://127.0.0.1:30005) Sep 10 07:15:34 raspberrypi fr24feed[4806]: [reader][i]Connected to the receiver, configuring Sep 10 07:15:34 raspberrypi fr24feed[4806]: [reader][i]Configured, processing messages Sep 10 07:15:35 raspberrypi fr24feed[4806]: [reader][i]Timestamp source changed from UNKNOWN to SYSTEM-UNCERTAIN Sep 10 07:15:36 raspberrypi fr24feed[4806]: [main][i]Feed Network client started Sep 10 07:15:36 raspberrypi fr24feed[4806]: [reader][i]Timestamp source changed from SYSTEM-UNCERTAIN to SYSTEM-VALIDATED Sep 10 07:15:36 raspberrypi fr24feed[4806]: info | Stopping ReceiverACSender threads for feed Sep 10 07:15:36 raspberrypi fr24feed[4806]: info | Configured ReceiverACSender: 185.218.24.22:8099,185.218.24.23:8099,185.218.24.24:8099, feed: KIAG4, send_interval: 5s, max age: 15s, send metadata: true, mode: 1, filtering: true Sep 10 07:15:36 raspberrypi fr24feed[4806]: info | Network thread connecting to 185.218.24.22:8099 for feed KIAG4 Sep 10 07:15:36 raspberrypi fr24feed[4806]: [feed][n]connecting Sep 10 07:15:36 raspberrypi fr24feed[4806]: info | [stats]Stats thread started Sep 10 07:15:36 raspberrypi fr24feed[4806]: [mlat][i]Configuring UDP connection udp://usa-2.fr24.com:19788 Sep 10 07:15:36 raspberrypi fr24feed[4806]: [feed][n]connected via UDP (fd 30) Sep 10 07:15:36 raspberrypi fr24feed[4806]: [feed][i]Feed connected Sep 10 07:15:54 raspberrypi fr24feed[4806]: [mlat][e]Received MLAT timestamp error: 0 seconds! Sep 10 07:15:54 raspberrypi fr24feed[4806]: [mlat][i]Stats 687289/687289 Sep 10 07:25:37 raspberrypi fr24feed[4806]: info | [stats]sent 9057 bytes pi@raspberrypi:~

Then I ran a traceroute when it seems to be running correctly:
pi@raspberrypi:~ $ traceroute 185.218.24.1
traceroute to 185.218.24.1 (185.218.24.1), 30 hops max, 60 byte packets
1 192.168.0.1 (192.168.0.1) 3.809 ms 15.975 ms 16.436 ms
2 142.254.215.1 (142.254.215.1) 16.605 ms 16.753 ms 16.577 ms
3 agg62.ntnwny1702h.northeast.rr.com (24.58.216.213) 38.765 ms 39.513 ms 39.558 ms
4 agg37.lncsnycd02r.northeast.rr.com (24.58.38.106) 19.825 ms 22.262 ms 22.653 ms
5 be29.rochnyei01r.northeast.rr.com (24.58.32.62) 28.121 ms 23.927 ms 32.749 ms
6 bu-ether13.tustca4200w-bcr00.tbone.rr.com (66.109.6.2) 40.182 ms 27.326 ms bu-ether15.chcgildt87w-bcr00.tbone.rr.com (66.109.6.72) 33.575 ms
7 66.109.5.137 (66.109.5.137) 32.705 ms bu-ether11.chctilwc00w-bcr00.tbone.rr.com (66.109.6.21) 40.255 ms 66.109.5.137 (66.109.5.137) 40.280 ms
8 ae-13.edge2.Chicago10.Level3.net (4.68.37.137) 40.019 ms 38.231 ms 39.668 ms
9 ae-2-2.bar1.Oslo2.Level3.net (4.69.137.53) 156.497 ms 156.635 ms 156.692 ms
10 IP-ONLY-TEL.bar1.Oslo2.Level3.net (62.140.27.66) 157.337 ms 150.730 ms 150.728 ms
11 213.80.87.151 (213.80.87.151) 152.256 ms 152.425 ms 152.457 ms
12 * * *
13 * * *
14 * * *
15 * * *
16 * * *
17 * * *
18 * * *
19 * * *
20 * * *
21 * * *
22 * * *
23 * * *
24 * * *
25 * * *
26 * * *
27 * * *
28 * * *
29 * * *
30 * * *

I will do a traceroute if/when it craps out…

I’d recommend https://pastebin.com/ for the logs.

But yeah the log and the traceroute will be more interesting once it stops working.

Oops, my mistake. I missed the path to file in the command.

The command should be sudo nano /etc/fr24feed.ini , and not sudo nano fr24feed.ini.

I will now corrected my post. Sorry for the incovinience caused by my mistake.

The FR24 feed stopped… this is the traceroute…

It appears that FA is still running and feeding data to FA…
It appears that the route to FR24 has been interrupted. The only way I know to reestablish FR24 is to restart the Pi…

pi@raspberrypi:~ traceroute 185.218.24.1 traceroute to 185.218.24.1 (185.218.24.1), 30 hops max, 60 byte packets 1 * * * 2 * * * 3 * * * 4 * * * 5 * * * 6 * * * 7 * * * 8 * * * 9 * * * 10 * * * 11 * * * 12 * * * 13 * * * 14 * * * 15 * * * 16 * * * 17 * * * 18 * * * 19 * * * 20 * * * 21 * * * 22 * * * 23 * * * 24 * * * 25 * * * 26 * * * 27 * * * 28 * * * 29 * * * 30 * * * pi@raspberrypi:~

Did you add following lines to file /etc/fr24feed.ini , saved file, then restarted fr24feed?

use-http=yes  
http-timeout=20

OK I did now. Thank you I had not done that. Can you please explain what effect that should/will have?

It will change nothing, the option did something in an old version of the feed client i believe, they since changed the feed client.

@abcd567 without a network route the settings really don’t matter :confused:
(i would say that’s obvious but i guess that would be rude :slight_smile: )

If restarting the pi fixes it, then your network configuration is bad.

Are you using the piaware image and static ips?
Then post the piaware-config.txt or the output for sudo piaware-config

I’m not sure what you mean by piaware image but I think so. I am using static IP.
Here is the result of sudo piaware-config…
allow-auto-updates yes # value set at /etc/piaware.conf:7
allow-manual-updates yes # value set at /etc/piaware.conf:8

The image you wrote to the sd-card.
The other option would be default Raspbian Lite then installing piaware.

No matter your network configuration is likely screwed up.
So however you configured that, post how you configured it.