RaspPi3 and piaware suddenly stops updating


#1

Just got everything installed and running on 17-Jul-2016. It runs fine for a while and then just stops sending its feed. I check on port 8080 and it appears to still be running but flightaware indicates that it has not received updates Any ideas what I should look for? Currently connected via wifi.

Thanks

Tom


#2

Have you checked the logs?
/tmp/piaware.out
/var/log/dump1090


#3

Logs

File /var/log/dump1090 does not exist

/tmp/piaware.out

07/24/2016 00:02:17 5781 msgs recv’d from dump1090 (54 in last 5m); 5780 msgs sent to FlightAware
07/24/2016 00:06:58 mlat(846): Receiver status: connected
07/24/2016 00:06:58 mlat(846): Server status: synchronized with 2 nearby receivers
07/24/2016 00:06:58 mlat(846): Receiver: 6.1 msg/s received 0.1kB/s from receiver
07/24/2016 00:06:58 mlat(846): Server: 0.0 kB/s from server 0.0kB/s TCP to server 0.1kB/s UDP to server
07/24/2016 00:06:58 mlat(846): Results: 2.2 positions/minute
07/24/2016 00:06:58 mlat(846): Aircraft: 3 of 4 Mode S, 3 of 3 ADS-B used
07/24/2016 00:07:17 5837 msgs recv’d from dump1090 (56 in last 5m); 5836 msgs sent to FlightAware

07/24/2016 03:22:02 mlat(846): Receiver status: connected
07/24/2016 03:22:02 mlat(846): Server status: synchronized with 3 nearby receivers
07/24/2016 03:22:02 mlat(846): Receiver: 12.3 msg/s received 0.2kB/s from receiver
07/24/2016 03:22:02 mlat(846): Server: 0.0 kB/s from server 0.0kB/s TCP to server 0.1kB/s UDP to server
07/24/2016 03:22:02 mlat(846): Results: 18.0 positions/minute
07/24/2016 03:22:02 mlat(846): Aircraft: 2 of 7 Mode S, 2 of 4 ADS-B used
07/24/2016 03:22:17 12282 msgs recv’d from dump1090 (83 in last 5m); 12281 msgs sent to FlightAware
07/24/2016 03:27:17 12384 msgs recv’d from dump1090 (102 in last 5m); 12383 msgs sent to FlightAware
07/24/2016 03:30:18 NOTICE from adept server: 12% of multilateration messages (UDP) are not reaching the server - check your network?
07/24/2016 03:31:18 NOTICE from adept server: 17% of multilateration messages (UDP) are not reaching the server - check your network?
07/24/2016 03:32:17 12515 msgs recv’d from dump1090 (131 in last 5m); 12514 msgs sent to FlightAware
07/24/2016 03:32:19 NOTICE from adept server: 10% of multilateration messages (UDP) are not reaching the server - check your network?

07/24/2016 06:07:06 mlat(846): Receiver status: connected
07/24/2016 06:07:06 mlat(846): Server status: not synchronized with any nearby receivers
07/24/2016 06:07:06 mlat(846): Receiver: 5.9 msg/s received 0.1kB/s from receiver
07/24/2016 06:07:06 mlat(846): Server: 0.0 kB/s from server 0.0kB/s TCP to server 0.1kB/s UDP to server
07/24/2016 06:07:06 mlat(846): Results: 9.9 positions/minute
07/24/2016 06:07:06 mlat(846): Aircraft: 3 of 3 Mode S, 0 of 0 ADS-B used
07/24/2016 06:07:17 15139 msgs recv’d from dump1090 (14 in last 5m); 15138 msgs sent to FlightAware
07/24/2016 06:12:17 15141 msgs recv’d from dump1090 (2 in last 5m); 15140 msgs sent to FlightAware
07/24/2016 06:17:17 15154 msgs recv’d from dump1090 (13 in last 5m); 15153 msgs sent to FlightAware
07/24/2016 06:22:03 mlat(846): Beast-format results connection with localhost:30104: connection lost
07/24/2016 06:22:03 mlat(846): Lost connection to localhost:30005
07/24/2016 06:22:03 mlat(846): Reconnecting in 30.0 seconds
07/24/2016 06:22:03 lost connection to dump1090 via faup1090
07/24/2016 06:22:03 reconnecting to dump1090
07/24/2016 06:22:03 no ADS-B data program seen listening on port 30005 for 0 seconds, next check in 60s
07/24/2016 06:22:07 mlat(846): Receiver status: disconnected
07/24/2016 06:22:07 mlat(846): Server status: synchronized with 2 nearby receivers
07/24/2016 06:22:07 mlat(846): Receiver: 0.4 msg/s received 0.0kB/s from receiver
07/24/2016 06:22:07 mlat(846): Server: 0.0 kB/s from server 0.0kB/s TCP to server 0.0kB/s UDP to server
07/24/2016 06:22:07 mlat(846): Results: 5.7 positions/minute
07/24/2016 06:22:07 mlat(846): Aircraft: 0 of 0 Mode S, 0 of 0 ADS-B used
07/24/2016 06:22:17 15165 msgs recv’d from dump1090 (11 in last 5m); 15164 msgs sent to FlightAware
07/24/2016 06:22:33 mlat(846): Connection to localhost:30005 lost: [Errno 111] Connection refused
07/24/2016 06:22:33 mlat(846): Reconnecting in 30.0 seconds
07/24/2016 06:22:33 mlat(846): Beast-format results connection with localhost:30104: [Errno 111] Connection refused
07/24/2016 06:23:03 no ADS-B data program seen listening on port 30005 for 60 seconds, next check in 60s
07/24/2016 06:23:03 mlat(846): Connection to localhost:30005 lost: [Errno 111] Connection refused
07/24/2016 06:23:03 mlat(846): Reconnecting in 30.0 seconds


#4

That looks like dump1090 is crashing. Check power, check that you’re not exposing port 8080 to the internet at large.