Data Feed stopped working

So, yesterday I got an email from FlightAware that my Pi stopped sending flight data to their servers - which seems to be true. Apparently the last time they got data from me was:

Data Feed: 27-Jul-2016 - 2 days ago

Alas I can’t find anything wrong with my Pi. /tmp/piaware.out keeps telling me that it does send data, though:

07/29/2016 15:30:42 27041 msgs recv'd from dump1090-mutabi (105 in last 5m); 27041 msgs sent to FlightAware

Where else could I look for errors?

Have you checked the logs?

You had an unfortunate MAC address collision with a new FlightFeeder; all your data was being attributed to the FF, not your device.
(Yeah, Pi MACs really aren’t unique … working on alternatives)

I’ve disabled that FlightFeeder (we’ll put a new Pi in it) so hopefully you should be back up and running shortly.

That’s… interesting. Thanks for the info.

I have a similar problem - although, I am fairly certain the report email I got is exaggerated. The email I got says: " Your receiver last connected to FlightAware on 30-Jun-2016 08:44AM " Regardless, I checked my status page & it shows I am not getting my data across. However, PP seems to be having no issues (Sharing Complete & my Sharecode is correct, even tried to re-register to no avail - PP up to date & no changes have been done recently… I swore I just checked this a week ago or so & everything was fine.

It’s unlikely to be the same problem - we’ve had a total of two Pi MAC collisions ever. If you’re feeding via Planeplotter, it’s definitely not the same problem.

OK, thanks - I’ll start a new thread!

I have essentially the same thing happen. My piware is working since virtual radar shows data coming from it. Flight aware says last contact was last Saturday. Seems to be working but not feeding Flightware.


Have you checked the logs?
/tmp/piaware.out or /var/log/piaware.log for version 3.X
/var/log/dump1090.log or /var/log/dump1090-fa.log

Dump1090 can be up, feeding VRS, but piaware/faup1090 etc could be down.

1 Like

I am not sure how to read /tmp/piaware.out I have found but not sure how to access it.?

cat /tmp/piaware.out

ah hah! incorrect password or username…

I have reset both my user name and password and then restart piaware. Still not working. I will post cat /tmp/piaware.out

pi@piaware:~ $ cat /tmp/piaware.out
09/26/2016 21:55:57 ****************************************************09/26/2016 21:55:57 piaware version 2.1-5 is running, process ID 546
09/26/2016 21:55:57 your system info is: Linux piaware 4.1.19-v7+ #858 SMP Tue Mar 15 15:56:00 GMT 2016 armv7l GNU/Linux
09/26/2016 21:55:57 Connecting to FlightAware adept server at
09/26/2016 21:55:57 ADS-B data program ‘dump1090’ is listening on port 30005, so far so good
09/26/2016 21:55:57 Starting faup1090: /usr/lib/piaware/helpers/faup1090 --net-bo-ipaddr localhost --net-bo-port 30005 --stdout --lat 42.195 --lon -85.566
09/26/2016 21:55:57 Started faup1090 (pid 761) to connect to dump1090
09/26/2016 21:55:57 Connection with adept server at established
09/26/2016 21:55:57 FlightAware server SSL certificate validated
09/26/2016 21:55:57 encrypted session established with FlightAware
09/26/2016 21:55:57 autoUpdate in adept config is enabled, allowing update
09/26/2016 21:55:57 manualUpdate in adept config is enabled, allowing update
09/26/2016 21:55:57 multilateration support enabled (use piaware-config to disable)
09/26/2016 21:55:58 *******************************************
09/26/2016 21:55:58 LOGIN FAILED: status ‘error’: reason ‘incorrect username or password’
09/26/2016 21:55:58 please correct this, possibly using piaware-config
09/26/2016 21:55:58 to set valid Flightaware user name and password.
09/26/2016 21:55:58 piaware will now exit.
09/26/2016 21:55:58 You can start it up again using ‘sudo /etc/init.d/piaware start’
09/26/2016 21:55:58 TLS alert: close notify
pi@piaware:~ $

I am beginning to think it may be my firewall. Though it is a puzzle why all of a sudden ti would start being an issue after all these months.

Flightaware is back working. Check with cat /tmp/piaware.out shows messages successfully sent. I had to shut my pi down and unplug it. After re powering back up it is now working. Rebooting was not enough to correct it. It had to be powered down.