Mutability... Still relevant?


#1

Getting close to my 3 year anniversary and also found that I need to update my trackers after completely forgetting about them for the last year and a half (or so). Just curious if Mutability is still relevant, or if everyone is using the stock image these days?

Cheers!
LitterBUg


#2

Still using mutability ver1.15~dev


#3

abcd567,
Good to see you are still in here! OK, I’ll dig through the forums to see how it’s done now.

Cheers!
LitterBug


#4

.

Manual Install: Bake a Pi
Automated Install: ADS-B Receiver Project Setup Scripts
Workarounds (if using Raspbian Stretch img): When is STRETCH coming to PiAware SD card image version


#5

@adbcd567,
Awesome! Thanks for the info. I set up a test rig last night with the stock image. I’ll start it over again tonight. Had almost hit 1000 day streak with my primary, but forgot to check on it when I got an outage report. Turned out my wireless bridge to the basement had gone out, and streak was done by the time I figured it out. My Dad actually tipped me off that his feeder was out, and that’s when I realized that both were down. The pi hardware and samsung SD cards I’ve been using have been rock solid.
Cheers!
LitterBug


#6

I use the June 8, 2016 commit of Dump1090-Mutability. This was before he removed Google Maps support.


#7

Thanks so much for the break-through tip “June 8, 2016 commit”.

Tonight I cloned source code, then issued command git reset --hard dfe3d7af12 to reset git to tree dfe3d7af12 (Merge pull request #126, June 8, 2016 commit), then build the package and installed it.

Step-By-Step Method for Installing June 8, 2016 version of dump1090-mutability v1.15~dev (The last version which had Google Map).

$ sudo apt-get update
$ sudo apt-get install librtlsdr-dev libusb-1.0-0-dev pkg-config debhelper
$ sudo apt-get install lighttpd 

$ sudo apt-get install git
$ git clone https://github.com/mutability/dump1090.git
$ cd dump1090
$ git reset --hard dfe3d7af12
HEAD is now at dfe3d7a Merge pull request #126 from rxseger/osx

$ sudo dpkg-buildpackage -b

$ cd ../
$ sudo dpkg --install dump1090-mutability_1.15~dev_armhf.deb
$ sudo lighty-enable-mod dump1090
$ sudo /etc/init.d/lighttpd force-reload

$ sudo dpkg-reconfigure dump1090-mutability
$ sudo systemctl restart dump1090-mutability
$ sudo reboot

.


#8

Can anyone give reason/solution of the strange behaviour detailed below?
Clearing cache (Ctrl+Shift+Delete) and Reloading browser (Ctrl+F5) does not change following behaviour:

After installing the dump1090-mutability ver1.15~dev (commit June 8, 2016), I noticed strange behaviour of Google Map as follows:

  1. Linux Raspbian Pixel x86 on Desktop (Intel Core 2 Duo CPU)
    Firefox Browser: Google Map shows OK
    Chromium Browser: Google Map shows OK

  2. Linux Ubuntu 16.04 amd64 on Desktop (Intel Core 2 Duo CPU)
    Firefox Browser: Google Map is BLANK (see screenshot below)
    Google Chrome Browser: Google Map shows OK (see screenshot below)

  3. Windows 8.1 on Desktop (Intel Core 2 Duo CPU)
    Firefox Browser: Google Map is BLANK
    Google Chrome Browser: Google Map is BLANK

.

.


#9

Hi abcd,
I’ve just installed Virtual Radar Server on a Pi Zero connected wirelessly and got the following with Firefox Quantum 57.0.2 (64-bit). I assumed the Zero was struggling.

I tried with IE11. and it works fine.

[Edit] Tracking Protection. Switched it off and the map appeared in Firefox.


#10

@triggers:
Thanks for the tip.

I now tried IE 11 on Windows 8.1, and the Google Map shows.
However only a blank map with planes is shown when I use Firefox 57 or Google Chrome 63.

Here is screenshot for dump1090-mutability v1.15~dev (June 8, 2016 Commit) on Internet Explorer 11


#11

My laptop is Windows 10.

If I switch off Tracking Protection in IE11 the browser hangs when opening http://192.168.1.200:8080/VirtualRadar/desktop.html# once the right hand column of the flight details have come up.


#12

@triggers

Tried in FF all settings of Tracking Protection, did not solve the problem.

Then Main Menue >> File >> New Private Window, and typed ip-of-pi/dump1090/gmap.html, and the map is there.

FF thinks Google Map is a Pornographic stuff, and opens it only in a private window :slight_smile:


#13

If you use the older version, you will need to sign up and add in the Google API key into the gmap.html.


#14

Well it gets me excited :rofl:


#15

Thanks @N456TS
Can you please tell how to add Google API key into gmap.html?
I tried adding it inside <head></head> part of gmap.html as shown below, but no success.
The map did not show, and even the planes and plane table disappeared :frowning:

<head>
... ... ...
... ... ...
<script async defer src="https://maps.googleapis.com/maps/api/js?key=YOUR_API_KEY&callback=initMap" type="text/javascript"></script>
... ... ...
... ... ...
</head>

#NOTE: used actual Google key in place of YOUR_API_KEY in above code
.

#16

my favorite is still dump1090-mutability v1.15~dev with google maps … :point_up_2:

<< raspberry pi 2, display on PC: WIN7, firefox >>