Map not showing circles


#1

I have used the Joe Procazkha’s script to install 1090-mutability and 978. It all seemed to go fine, it asked me which receiver to be on 1090 and which on 978… because I have two of them.
I had made all the changed to the scrip previously to correct for the new 3.5.1 and other versions. I have changed the error in metric=“false;”

The page from /dump1090.php shows correctly the planes. It is the Skyview one.
However, the dump978.php shows only the Open map, the weather, but no rings or planes. This map is the two clock one. Toggling the “Site position and range rings” doesn’t do anything.

Any hints?

PS: This is confusing me… that’s is where the /dump978 folder should be?


#2

There are two files you need to edit for the distance rings.

/usr/share/dump1090-mutability/html/config.js
/var/www/html/dump978/config.js

Look for the following and change the array to the distances you want.


// In nautical miles or km (depending settings value 'Metric')
SiteCirclesDistances = new Array(100,150,200);

Source: post187816.html#p187816

NOTE: Make sure “Show Site” is set true in dump978’s config.js. If the receiver location is not shown, the circles (whose center is receiver location) will not show.


#3

I have changed the “Show Site” set on true in both places. Rebooted.
The rings appeared in the default position in Europe, didn’t get the location values from 1090. Well, I have to move them manually.
Thanks!

PS: I just saw my first plane on 978!


#4

Clear Browser cache (Alt+Ctl+Delete), then hard reload the browser(Ctl+F5).

You can try editing the files
/usr/share/dump1090-mutability/html/config.js
AND
/usr/share/dump978/html/config.js

and setting the default center there. Usually a cookie is set by the dump1090-mutability/dump978 map page with the last position you had which is then used to center the map on each subsequent visit. This is why it is normally not necessary to bother with this setting. But since that appears to not be working for you look for this and make your changes there:

// Default center of the map.
DefaultCenterLat = 45.0;
DefaultCenterLon = 9.0;


#5

Yeah, that’s what I needed to change, but only on the 978 side.
Thanks!

PS: I hard-refresh the browser with Shift + F5. Works in IE and Chrome.