Any help with this?


#1

Hi,

although not a FA version, I know there are a lot of people here that have other systems. I am using Joe’s v2.6.1/adsb-receiver_2.6.1_dump1090-fa_raspbian-stretch-lite image. Now I am not sure if there is a problem with that image although freshly downloaded and installed sucessfully, however I am coming up with this sceario, the Piaware skyview 1090 map (attached) with the heywhatsthat rings showing, the FA table of currently tracked planes showing, but no planes showing on the map ??? Ideas and Happy Easter to those who celebrate.

Jeff


#2

I might add, Flightaware has not picked up automatically this new station claim, I have sent an email re this to FA. Is that the problem??


#3

Further, the Planefinder app is working off that install and showing planes on their map.


#4

I can’t suggest why but I noticed the table is not showing anything in the distance column so it appears that it does not know where the aircraft are located hence not placing them on the map.

S


#5

Wrong or No entries for Latitude & Longitude of the antenna/receiver is a possibility

sudo nano /etc/default/dump1090-fa

RECEIVER_OPTIONS="–device-index 0 --gain -10 –lat xx.xxxx --lon yy.yyyy --ppm 0 --net-bo-port 30005"


#6

Hey ABCD, thanks for your advice. Your typing in the reply has 1 - next to lat but 2-- next to lon. This is what I added, the lat and lon weren’t there but still the same result:

RECEIVER_OPTIONS="–device-index 0 --gain -10 --lat -31.109735 --lon 150.899631 --ppm 0 --net-bo-port 30005"

Still have the range circles sitting over Toronto … lol


#7

Your range circles were attracted by me and moved to Toronto… lol

After adding lat/lon did you:

  1. Restart dump1090-fa
  2. Try “clear browser cache” and “reload browser”

#8

Yes tried all those
Still no good


#9

Last resort: try reboot.
If this fails, re-image.


#10

Already done too. I believe it is the image where the problem lies and Joe has gone deep again. Unless someone else downloads the latest FA 1090 image and gets it to work, that is my best guest.


#11

Ok, I did it and burned a spare microSD card with freshly downloaded “adsb-receiver_2.6.1_dump1090-fa_raspbian-stretch-lite.img”,

Slipped the microSD card into Pi Model2 (the most modern Pi I have :slight_smile:).
Powered up
Configured my feeder-id in piaware-config (see below).
Everything, including rings, is ok (even with --lat & --lon missing in the file /etc/default/dump1090). It seems LAT & LON of a feeder are obtained by dump1090-fa/Piaware from Flightaware Database.

Did you do this

  1. sudo piaware-config feeder-id xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx
    sudo systemctl restart piaware
    (Replace xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx by your actual feeder id. Yo can get it from your FA “My ADS-B” page.

  2. If you have already done that, then check on you Flightaware “My ADS-B” page if your coordinates are correctly recorded there.

Here is map displayed by my “adsb-receiver_2.6.1_dump1090-fa_raspbian-stretch-lite.img” running on Pi Model2

NOTE: This image does NOT have latest dump1090-fa version 3.5.3. It has older ver 3.5.1


#12

About to go for some exercise but will try that in a couple of hours, thanks old friend. :slight_smile:


#13

I did another experiment.
In Flaightaware “My ADS-B” page, I opened Configuration and set my receiver’s location to your LAT and LON, and Rebooted the PI. The results are identical to your situation, but of course reversed in location. Please see the screenshots below.

.
.
SCREENSHOT 1 of 3
1_Wrong%20Lat%20Lon%20in%20My%20ADSB%20Page-1

.
.
SCREENSHOT 2 of 3

.
.
SCREENSHOT 3 of 3


#14

well I believe I have it running. Now can we put the extra circles and colours on this??


#15

.

Great!
So was it due to wrong Lat/Lon setting in your “My ADSB” page’s configuration?

Curious to know how you fixed it.

.

.

Open file config.js to edit

cd /usr/share/dump1090-fa/html
sudo nano config.js

.
Press Ctrl+w, and type SiteCircles, and press Enter key. The cursor will jump to this line:

SiteCirclesDistances = new Array(100,150,200);

Add the circle by adding circle dia in this line,. For example if you want a circle at 250 nm, add this number within the brackets. Note that adjuscent numbers should be seperated by a comma. The above line will become:

SiteCirclesDistances = new Array(100,150,200,250);

Save file (Ctrl+o), Close file (Ctrl+x)

Now reload/refresh browser. If extra circle dont show, clear browser cache and reload it.


#16

This is what got it going. Once FA servers identified the feed, it worked fine, so not sure if it was an image thing or FA not picking up on the new feed, but that manual fix did it. Thanks for above I found an old post of yours re same. How do you add the circle id to the mutability version of the same?? A handy visual thing to have.