Mac OS Dump1090 map view


#1

Hi there,
I’m new to the ADS-B tracking. I recently bought the FA RTL USB donlge and installed it. I’m currently using Dump1090 and it’s working as a localhost on port 8080. I noticed on some videos also using Dump1090 but having a more detailed map with a table to the right. I want to note that I’m currently using Mac OS.

The question is how can I obtain the same view of the map, what did I do differently?

Thanks in advance,


#2

try dump1090-fa from here

There is also modes2deco
http://xdeco.org/?page_id=39

and VRS
http://www.virtualradarserver.co.uk/


#3

Thanks. I’m aware of these applications. However, dump1090 should have a view similar to the below pictures (taken from another thread) and my view is a simple google maps, with no additional information or table.


#4

All of mine have the table.
The clocks have been removed from later versions of dump1090.


#5

Here is what I see:


#6
  1. This is dump1090 antirez, the ORIGINAL dump1090 from which Malcom Robb frorked and from Malcom Robb the Mutability forked, and from Mutability FA forked.
  1. It is obvious that you are trying to view the map in Safari on your Mac computer.

    On which computer you have installed dump1090?


#7

I installed it on my Mac and I’m viewing off my Mac in that picture too. Should I install the link you shared?


#8
  1. No, dont install from the link I shared. It is for information only.

  2. From where you got dump1090 installation package for Mac? The pre-built packages are available only for Linux/Debian.

  3. If you want a table at right with details, you have to install either dump1090 (Malcom Robb), or dump1090-mutability, or dump1090-fa. As far as I know pre-built installation packges for all these 3 are available for Linux Debian only.

    May be someone is aware from where a pre-built installation package fo Mac is available, and can post a link.


#9

I’m actually using the same file that you shared with me. I only had to run “make” command in Mac then run the file.
Below is a quick guide that I used:

https://absent.org/2015/12/31/dump1090-on-elcap-quickstart.html


#10

Try to use “make” command with any one of the following two. The make process is nearly similar for both and is described on these Github pages:

(1) dump1090 (MalcomRobb)

.
.

(2) dump1090-mutability

.
.
NOTE:
First UNINSTALL existing dump1090

.

This video may help


#11

For dump1090 MalcomRobb

brew update

brew install librtlsdr

git clone https://github.com/MalcolmRobb/dump1090.git  

cd dump1090

make

#12

For dump1090-mutability

brew update 

brew install librtlsdr 

git clone https://github.com/mutability/dump1090.git  

cd dump1090 

make

#13

Thanks

I tried the second one, now I’m not able to see the map at all, tried two different browsers.


#14

If by “second one” you mean mutability, then try to see map at
127.0.0.1/dump1090/gmap.html
OR
localhost/dump1090/gmap.html


#15

I did mutability. Those link aren’t working either…


#16

Did you try following?
127.0.0.1:8080
OR
localhost:8080

Unfortunately I dont have a Mac, so cannot test myself.

Did you delete folder dump1090 BEFORE installing dump1090-mutability? If not, then may be files of antirez and mutability got mixedup as both use the same folder dump1090.

An alternative is to delete folder dump1090 with its contents, and try to install dump1090 MalcomRobb. May be that will succeed.

Note: dump1090 MalcomRobb shows map at:
localhost:8080
OR
127.0.0.1:8080


#17

No worries. I did remove all dump instances and re-sintalled the one you shared (mutuation). I still can’t view the map.


#18

To run the program with networking support, and connect with your browser to http://localhost/dump1090/gmap.html to see live traffic:

./dump1090 --net


#19

its very weird. I’m doing what I usually do to start dump1090. I can see planes in terminal but not in the browser.


#20

I finally got it to work. I had to run it from my desktop and not my /etc/ folder. Now it’s working as expected and showing the table to the right. Thank you very much for your time and support.