Live feed dropping

Is there a way to have the Pi auto-reboot if the live feed drops? Mine drops the live feed several times a day, but the feed is restored once I reboot it.

It is a better idea to diagnose the underlying problem than to try to wallpaper over the cracks.

True. But I have no idea what the problem may be. The power, router, and internet connection are all stable. The connections are secure. Every ting Pi-related had been updated. What else should I check?

Does it lose both your flightfeeder ssh connection (stats page) and your local dump1090 display or only the flightfeeder ssh connection?

The feeder check-in stays live, but I can’t see it when I try to view live data. Also, my hourly collection stats flatline. But, I’ll have to verify it next time it happens.

Sounds like dump1090 is dying. The usual causes are:

  • bad power
  • bad USB connection
  • you exposed the webserver to the internet at large and it’s crashing on some requests

That could be it. How do I set it up so that I can see the air traffic without exposing it to the internet at large?

Don’t port forward port 8080.

If you still want to access it remotely either run a VPN, use a reverse proxy with a tightly controlled access list, or run dump1090-mutability which has a mode where it writes data locally and a proper webserver can serve the data to the world (the problem is that the built-in dump1090 webserver is not very good and you don’t want it exposed directly to the world)

I’ve disabled the port forwarding.

How do I run dump1090 mutability?

Probably a better option is to use a Windows computer to run Virtual Radar Server Then you can open that up to the internet for all to view and no matter what, the resources on your Pi are not being impacted.

It also looks a little bit better and has more options than the dump1090 webserver. is mine and it is combining feeds from 2 different PiAware systems into the one ‘Merged feed’. No matter how many requests get pulled up, the Pi’s never see an increase in traffic or resource demands.

Yeah, I like that view. I may try that again…
I had it setup before but it didn’t seem to track as many as Flight Aware did, but then that was when the Pi was still crashing so who knows…

So far, the Pi is still live since I disabled the port forwarding last night. Even after my nightly modem/router reboot.

I was hosting a DNS server for my domain on a Ubuntu server with an i7 (8 cores) and 16GB or 32GB of RAM and someone started attacking it to the point that it became unresponsive. Be very careful what you make publicly accessible and be ready to disable the public access.

When I enable Virtual Radar, I can only see traffic via the local address. It won’t display using the internet address.

If you’re on your local network, some home routers aren’t smart enough to loopback into their own external IP. Also, you have to make sure that you have the port forwarded properly in the router.

I think that’s where I’m stuck. Which port do I forward and to where? My network address is but I don’t want to port forward right to my desktop, right?

If you’re running VRS on your desktop, then yes, you would forward in your router to that IP:Port. I wouldn’t do that myself, but I have plenty of other machines laying around that I can use for that purpose.