FlightAware Discussions

Linux - remove repository

I did try to install openhab and by mistake I run a script that had added armf repositories to my Linux x86 machine.
Now every time I do apt update I have a bunch of errors plus I can see the Ign (ignored) for arm packages being listed.

Is there an easy way to remove them?

This is the output:

Should be a file you can delete in /etc/apt/sources.list.d

1 Like

That eliminated some of those but I still see a lot of them:

Check /etc/apt/sources.list then, it’s a file.

Delete the lines you don’t want.

1 Like

There are no lines there that specify arm packages. I don’t know where else they are hidden…

Did you by chance use PPA repositories?

If yes, maybe this helps:

Maybe this is an option : ```
sudo apt-get remove --purge dpkg --get-selections | grep armhf | awk '{print $1}'

followed by ```
sudo dpkg --remove-architecture armhf
1 Like

Is not listed in the GUI at Software Sources.

E: Command line option --get-selections is not understood in combination with the other options

That worked by itself! Thanks!

1 Like