FlightAware Discussions

Is feeding FlightAware via Windows and dump1090 possible?

Does anyone know how to configure dump1090 on Windows 10, and successfully have the data register on the FlightAware site under your account?

If so, are you willing to share what settings you use in your dump1090.bat file?

I’m extremely new to SDR and ADS-B, but I feel that if I can acquire data on a computer, I should be able to set things up such that I can send the data on to the internet with relative ease (I control all aspects of my home network, so opening ports is something I would consider trivial - if required).

I am able to successfully run dump1090 with it’s default settings, and the terminal window is definitely showing valid results from aircraft (I reviewed tailnumbers on FlightAware, and correlated their position and flight path in relation to my base location to ensure valid proximity).

I am just totally lost now as to how to configure dump1090, such that I would know it is sending data externally, and FA is receiving that same data.

I’ve spent some hours searching this forum and in general searches, and so far I’ve not found a guide or sufficient information to enable me to accomplish this task.

Any help, or recommendations as to a better software or path to sending the data to FA, is heartily appreciated.

The short answer is no. The piaware feeder software which uploads data to FlightAware is not supported under Windows.

If you have a system that can run piaware (e.g. a Pi running Raspbian, or another unix-like install, or even a Linux VM on your Windows machine) then you could in theory run dump1090 (or another ADS-B demodulator that produces Beast-format output) under Windows and have piaware consume data over the network from the Windows machine.

However, dump1090 support under Window is minimal; I think most versions are a few years old and mostly unsupported now.

Most feeder installs use a Raspberry Pi and either the FlightAware piaware sdcard image, or a Raspbian sdcard image, to run both the demodulator and the piaware feeder software itself, 24/7.

From Windows10, I am feeding flightaware successfully as follows:

Option (1):

Installed Oracle VM. In VM installed Debian 10.5. On Debian 10.5 installed dump1090-fa and piaware data feeder (both built from source code, and I have posted how-to in this forum).

Option (2):

Configured WSL2 on Windows10, then installed Kali Linux 2020 on it. On Kali Linux installed dump1090-fa & piaware data feeder, (both built from source code, and I have posted how-to in Kali Linux forums)

Note-1:
In WSL2 distros from Windows Store, the systemd is not installed. Hence commands sudo systemctl start|stop|restart wont work. You will get message " System has not been booted with systemd as init system".

In order to overcome this issue, do not use sytemctl commands, instead use sudo /etc/init.d/piaware start|stop|restart or sudo service piaware start|stop|restart

LATER ADDITION
Both the dump1090-fa and piaware fail to build on WSL2/Kali Linux 2020.2 (provided by Windows Store), although same procedure successfully installs them on OracleVM/Kali Linux 2020 downloaded from Kali’s official site. Still struggling to resolve the issue.

 

To install Oracle VM on Windows10 Computer:

https://www.oracle.com/virtualization/technologies/vm/downloads/virtualbox-downloads.html

Download and install following two packages:

(1) Oracle VM VirtualBox Base Packages
(2) Oracle VM VirtualBox Extension Pack

NOTE:
In Settings >> Network, change default " NAT " to " Bridge Adapter "

2 Likes

Thank you very much, abcd567.

Those instructions will make it very easy for me to spin up a VM, and just operate my SDR form that to feed FlightAware data for now.

I had hoped there was some Windows native solution, but from the snippets I’ve gathered on the forums, various postings across the internet, and now your instructions…it seems there is not.

This works for now. Then I’ll possibly get a Raspberry Pi, and use that as my 24/7 feed system.

Thank you, obj.

I had feared this would be the case, as I would have expected far more traffic mentioning how to setup and/or successfully run a Windows client that would feed data to FlightAware.

I can always hope for the future, but for now I know my options. All are absolutely viable for me to setup and use with relative ease too.

The RPi (or equivalent) is the least expensive way to do ADS-B feeding 24/7/365. They start at ~$10 for an Orange Pi. Operationally they use less electricity than a Windows system. They are a hobbyist’s delight - all the fun without a huge expense.

2 Likes
abcd-wsl@DESKTOP-1:~$ uname -a
Linux DESKTOP-1 4.19.128-microsoft-standard #1 SMP Tue Jun 23 12:58:10 UTC 2020 x86_64 GNU/Linux 
abcd-wsl@DESKTOP-1:~$ cat /etc/os-release
PRETTY_NAME="Kali GNU/Linux Rolling"
NAME="Kali GNU/Linux"
ID=kali
VERSION="2020.2"

 

@obj
Any idea why I get this error when I tried to build dump1090-fa & piawre from source-code on Kali Linux 2020 in Win10/WSL2?
Same procedure works perfectly well on Kali Linux 2020 installed in Win10/OracleVM.

dump1090-fa

/usr/bin/ld: sdr_rtlsdr.o:./dump1090.h:400: multiple definition of `Modes'; dump1090.o:./dump1090.h:400: first defined here
collect2: error: ld returned 1 exit status
make[2]: *** [Makefile:48: dump1090] Error 1
make[2]: Leaving directory '/home/abcd-wsl/dump1090'
dh_auto_build: error: make -j1 RTLSDR=yes BLADERF=no DUMP1090_VERSION=3.8.1 returned exit code 2
make[1]: *** [debian/rules:23: override_dh_auto_build] Error 255
make[1]: Leaving directory '/home/abcd-wsl/dump1090'
make: *** [debian/rules:32: build] Error 2
dpkg-buildpackage: error: debian/rules build subprocess returned exit status 2
Installing dump1090-fa
dpkg: error: cannot access archive 'dump1090-fa_3.8.1*.deb': No such file or directory 

 

piaware

/usr/bin/ld: util.o:./dump1090/dump1090.h:400: multiple definition of `Modes'; faup1090.o:./dump1090/dump1090.h:400: first defined here
collect2: error: ld returned 1 exit status
make[2]: *** [Makefile:54: faup1090] Error 1
make[2]: Leaving directory '/home/abcd-wsl/piaware_builder/package-bionic/dump1090'
make[1]: *** [debian/rules:47: build_dump1090] Error 2
make[1]: Leaving directory '/home/abcd-wsl/piaware_builder/package-bionic'
make: *** [debian/rules:95: build] Error 2
dpkg-buildpackage: error: debian/rules build subprocess returned exit status 2
Installing piaware package
dpkg: error: cannot access archive 'piaware_3.8.1*.deb': No such file or directory

If i’m not mistaken there was a change in relation to the Modes struct, try the dev branch for dump1090-fa.

1 Like

It’s a very old bug in dump1090 (dates back to antirez’s original version!) which only surfaced when some default options changed in gcc 10.

As wiedehopf says, it’s fixed in the current dev branch. Or try adding -fcommon to CFLAGS in the Makefile as a temporary workaround.

1 Like

@obj
@wiedehopf

Thak you both for your quick responses.
Will shortly try the suggestions and report back the outcome.

In my bash script for installing dump1090-fa, added following lines immediately after git clone command

echo "Workaround for a bug "
cd ${INSTALL_DIRECTORY}/dump1090
sudo sed -i '/^CFLAGS /s/$/ -fcommon/' Makefile 

Now the install script built and installed dump1090-fa successfully.
However this stupid WSL2 has stripped everything from the distro:

$ sudo systemctl status dump1090-fa
System has not been booted with systemd as init system (PID 1). Can't operate.
Failed to connect to bus: Host is down

$ sudo service dump1090-fa status
dump1090-fa: unrecognized service

$ sudo /etc/init.d/dump1090-fa status
sudo: /etc/init.d/dump1090-fa: command not found

$ dump1090-fa
Sun Sep 27 19:45:25 2020 EDT  dump1090-fa 3.8.1 starting up.
rtlsdr: no supported devices found.

WSL2 says no supported devices found, although I have plugged a ProStick in Windows Desktop.

Finally I got fed up with this STUPID WSL2 and shut it down (Kali on WSL2 does not shutdown by command sudo shutdown now, it requires to type exit and press Enter key).

I then fired up my old faithful Oracle VM, only to find that enabling WSL2 has done something bad to VM, and it fails to run any distro, and gives error messages. After lot of Googling finally I could fix Oracle VM by following method, only to find that now Kali on WSL2 refused to run!

In short both VM and WSL2 cannot coexist on same machine.

Type in the Windows Search bar “Windows Features” and following window will open. Check / Uncheck features as shown to switch between WSL2 and Oracle VM

  • Containers
  • HyperV
  • Virtual Machine Platform
  • Windows Hypervisor Platform

@wiedehopf
@obj

I will try this on Kali on WSL2

 

EDIT:

Tried the above method to install systemd.
It successfully installed systemd in Kali Linux on WSL2.

After installation of systemd, did following additional steps:

sudo systemctl enable dump1090-fa   
sudo systemctl start dump1090-fa  

 

Checked status, found dump1090-fa did start but failed.

abcd-wsl@DESKTOP-1:~$ sudo systemctl status dump1090-fa
● dump1090-fa.service - dump1090 ADS-B receiver (FlightAware customization)
     Loaded: loaded (/lib/systemd/system/dump1090-fa.service; enabled; vendor preset: disabled)
     Active: inactive (dead) (thawing) (Result: exit-code) since Mon 2020-09-28 12:23:58 EDT; 43min ago
       Docs: https://flightaware.com/adsb/piaware/
    Process: 235 ExecStart=/usr/share/dump1090-fa/start-dump1090-fa --write-json /run/dump1090-fa --quiet (code=exited,>
   Main PID: 235 (code=exited, status=1/FAILURE)

Sep 28 12:23:58 DESKTOP-1 systemd[1]: Stopped dump1090 ADS-B receiver (FlightAware customization)

 

Checked by directly running dump1090-fa, found the dongle is not passedthrough to WSL2/Kali

abcd-wsl@DESKTOP-1:~$ dump1090-fa
Mon Sep 28 13:08:55 2020 EDT  dump1090-fa 3.8.1 starting up.
rtlsdr: no supported devices found.

 

The WSL (Windows Stupid Linux) has a series of problems. You solve one, another one pops up :rage:

 

 

You’re absolutely right, ua549!

I decided I couldn’t wait, and just jumped to my end game. Bought the Pi 4, assorted other pieces, and in next to no time today have it feeding FA.
It requires some more tinkering to get me to the point of leaving it alone, but this has been just what I needed on a day of gloomy weather.

3 Likes

HaHa - Good luck with that!!
None of us are very good at ‘leaving it alone’ :smiley:

2 Likes

Best decision.
For ADSB, Pi is the way to go. Easy to install and configure, minimum issues and bugs, cost effective (very low electricity consumption compared to a regular computer), easy software availblity through repository, and abudant help in case of any issues.

1 Like

I am finding this to be absolutely true!

Every day I want to do something new with the Pi; add some service, get stats on how well something is running, or look into options to solve some random idea that came to mind.

The simplicity of using Putty and Pageant for access has only improved my feelings about having taken this route.

It’s a great little machine.

Next move is hardware upgrades - feed better data, and dissuade the cats from thinking it’s their new toy.

2 Likes

Used to use PuTTY, but then I found MobaXTerm.

Thanks for the mention of MobaXTerm, wesjamis. I’ll give it a look.

I use the Windows built-in ssh features available in Powershell or CMD prompt.