Ethernet 0 and wlan 0 down

Just did a fresh in stall of 3.3 on a new Pi 3. Cannot get wired or wireless enabled. Do I need to manually set through config.txt?

You need to put your ssid and password in there for wifi. I thought wired worked out of the box but I haven’t tried that.

Remove microSD card from Pi and insert into a card reader and insert card reader into Laptop/ Desktop (on which you wrote the 3.3 image),. Then open command prompt console of desktop/laptop, and give command

ech o >M:\ssh

  1. No space between ech and o in above command. I am forced to put space in this post, as otherwise it says “Forbidden, cannot post”
  2. Instead of M Use drive letter of your microSD card.

The above command will create a file named ssh in / boot directory of your microSD card.
Reinsert the microSD card in RPi and power up. SSH will start working.

From memory that will just echo the text to the console in windows, it needs to be piped to a file:

ech o >ssh

(without the space between the h and o)

Alternatively use a text editor to create a new text file in the root directory of the SD card and save as “ssh” (including the quotes) (or create elsewhere and copy to the root). The ssh file has no content.

The command “echo >M:\ssh” given in Command Prompt (Windows cmd.exe console), creates a blank file “ssh” in root directory of drive M. If M is drive letter for microSD card, file “ssh” will be created in boot partition of microSD card. I have posted this after testing it.

If a text file is created, it will be ssh.txt, and depending on Windows setting, the file extension .txt may not show, and the file name looks ssh only, though it is ssh.txt actually. I am not sure if a file ssh.txt will do the job, or an extension-less file ssh is required.

Wow! word echo can now be posted. Seems FA ops have now added word echo also in their “harmless” list :smiley:




Using quotes around the file name causes it to be saved exactly as written - so no ‘.txt’ extension.

The file for debian won’t work with an extension (hence why I said to use the quotes)

Just tried the command prompt method your way on a windows 7 and windows 10 (using standard command prompt and admin level command prompt on each) and as I remembered it echos the comment to the console and not to a file.

Piping it did create the file

Getting away from the OP now but I am intrigued as to why it would work with windows on your PC

The raspbian logic looks for both /boot/ssh and /boot/ssh.txt

Thank all. Back to normal function now.