FlightAware Discussions

Dump1090 picking up less than 5 aircraft

I have been running my flight tracker for a year in the Washington, DC metro area off of my apartment balcony:

Equipment:

  • Raspberry Pi Zero
  • FlightAware ProStick Plus
  • FlightAware 1090 MHz ADS-B Antenna - 66 cm

In Washington, I was averaging somewhere around 150-200 aircraft at any one time. I recently moved to Austin, TX, and am now setting up my receiver on my new apartment blacony in the same configuration. Now, it only seems I am able to pick up 3-5 aircraft max at any given time, and many times no aircraft at all. I have tried messing with gain but to no avail. The fact that I am getting some aircraft leads me to believe that the receiver is indeed working, but I would expect to be getting far more, at least 30 or so I would think. Unfortunately I cannot find much info online about how to resolve a tracking station that only picks up very few aircraft. Any advice is appreciated and I am happy to provide more info on request. I have gain currently set to -10 for the auto select, and it seems dump1090 is picking 49.6 dB once it starts. This is how I run dump1090:

./../dump1090-fa/dump1090 --net --interactive --forward-mlat --json-location-accuracy 2 --write-json ../dumpfiles/ --lat REDACTED --lon REDACTED --gain -10

I run dump1090 myself since on the side I harvest the data myself for other uses in addition to sending it to FlightAware.

Is your balcony on the airfield side or the other site around? Maybe its over gained, you could try a gain of 20-30? Or the signal is to low (i.e planes are to low to catch.) Which RSSI you get?

This is taken from dump1090:

RSSI: Max -28.5+

My balcony is on the airfield side. I tried setting it to ~26 but not much better.

It’s almost as if you’re running without an antenna. Did you check all your connections? When I recently changed the coax to my antenna Skyaware showed only one aircraft! I was shocked. I checked and found that the SMA connector was only partially screwed on. The center pin probably was not making contact. After tightening it everything was back to normal.

I tigheted the connections and got about 5 more aircraft. Better than nothing but definitely not what I was getting pre-move. I tried a different antenna/coax, slightly better but still far less than I’d expect it to get. Also tried different power supply as well. I think that maybe my ProStick Plus is dead/dying? Since neither antenna is performing as well as I’d expect that would be my best guess for the “broken” link in the chain… not sure if performance with the ProStick can degrade vs. just go to zero.

2 Likes

Thats not a strong signal. Are you able to start it up a a different location, to check if there is some jammer on the 1090Mhz frequency inside your home? (switch off the main power and run the Pi from a power bank would work). My HDMI cable was providing a jamming signal, found it with switching gear on and off :wink:

Gain -10 is most likely way too high and it causes lots of noise.
But going down to 25 could be simply too low.

I would start going downwards with settings like 49.6, 48.0, 44.5, 42.4 etc

And install graphs1090 and monitor the messages > -3dBFS. This is a good indicator of how much noise your device is getting.

If this does not give an indication, then it can be a physical problem.

Oh and make sure to remove the “minus” in front of the gain setting. It works only with 10
All other gain values must be without the minus in front of it

I made the mistake at the beginning and set it to -49.6
Afterwards i was asking myself why the map is empty

Tried booting it up on my power bank but still same issues :frowning:

Working on this now. I installed graphs1090 but have nothing in the ADSB related graphs. Unsure if this is because my dump1090 instance is being run manually from commandline or if something really is wrong…

Why would you do that, you can change the settings when it’s a service in /etc/default/dump1090-fa …
Go to that and graphs will work (they require data in /run/dump1090-fa …).

Seems you’re currently writing the temporary jsons to disk which well … unnecessary writes but i suppose one could do worse.

If you want the --interactive view … just open view1090-fa after dump1090-fa is running as a service. It gets the data from localhost via TCP.
And i’m sure you can get the data from /run/dump1090-fa instead form …/dumpfiles?
Or i suppose you could change the graph1090 configuration … check the readme.
But really using the service is a much better approach i think.

Your install script is very easy and provide a good start.