FlightAware Discussions

Dump 1090 appears to crash with too many aircraft

So please bear with me while I explain. I’m running on a PiZero, and it’s only running piaware plus dump1090. It’s from a purchased PiAware SD card so should be clean. It has been updated to 5.0 recently.

Now it doesn’t have a particularly good antenna, so doesn’t see that many aircraft. In general it is stable. So today, I installed a decent antenna on a pole on the shed. I moved the system, connected up and it worked, seeing loads more aircraft. But only for a few minutes before dump 1090 crashed. Restarted a dozen times, same each time. Moved it back to the location with a poor antenna and all is well.

I tend to keep a window open on my laptop viewing Skyaware directly on the Pi.

So, is it that my system is not capable of dealing with so many signals and an open skyaware servicing session? Do I need a more powerful Pi? Or is there something else that it could be?

There are improvements under way to reduce CPU load on the pi zero with version 5.0.

Beyond that you should check your power supply.
Significantly reducing the gain can also help a lot with CPU usage.

Thanks for the reply. To me reducing the gain seems to be a bit of a waste of the new, better antenna. But I guess it could be a simple way of proving that’s the issue. What I’d prefer to do, if it’s likely that it’s the problem, is change the Pi to one where the CPU is capable. I do have one ordered for something else that might fit the bill (Pi4 B).

I’m fairly confident it’s not the PSU. It’s an original Pi official one, and only about 10 months old. The fact that it went back to working fine with the old antenna with less signal is why I think that. I guess I could swap it out for the PSU that came with my Pi4 (or is Pi4 USBC?). But I doubt it’s that.

Please explain how you determined that dump1090 had crashed (what did you observe?)
Do you have dump1090 logs from after a crash but before rebooting?

For power, yes.

Reducing gain doesn’t mean reducing reception in many cases.
Thoughts on optimizing gain

1 Like

Hi. each time, the Pi reported via skyaware that it wasn’t receiving any data from dump 1090. Also the skyaware screen went from displaying 20-30 aircraft signals to none. I don’t have logs, I’m not sure how I would get them. I run the Pi headless, so everything I see is via the skyaware page I see when accessing it on it’s local IP address. I can try getting logs but in spite of years of computing experience I find Linux a special kind of inaccessible.

On your FlightAware stats page, you can click the gear icon and get a glimpse of latest logs.

Do you have the exact error? (A screenshot would be handy)

If you’re willing to ssh into the Pi, you can get the dump1090-fa status & logs with these commands:

$ sudo systemctl --no-pager status dump1090-fa
$ sudo journalctl --no-pager -n50 -u dump1090-fa

I’m willing to but that’s what I mean about Linux. I have no idea what SSH is or how I would perform it from my laptop. On the other hand I can move the kit back and take some screenshots no problem.

As I mentioned, I’m not inexperienced with computing, having learned programming back in the late seventies. I still write embbedded C for Arduino and PIC. but just find commands like SUDO completely unintelligible and how to ‘apply’ such commands somewhat confusing.

For Beginners - How-to SSH to RPi - Setup Putty in Windows

Once you’re connected it’s just a matter of copy pasting the commands given.

sudo just executes another command as root.
So the actual command starts after the sudo (and has several arguments).

1 Like

OK, thanks. I’ll fire up the windows machine and have a go.

So it looks like I can use Terminal on my laptop to do the same. But I need to enable SSH access on the pi.

Just to check in. I haven’t done anything on this yet as the decent weather outside means I’m concentrating on outdoors stuff while I can.

Sorry it’s been an age, but have just got around to enabling SSH and using it. I can now communicate with the Pi. Later on I will trasnfer it to the more sensitive antenna, see if I get the same issue, and post what I find.

Just another update. I’m starting to be convinced it’s a CPU issue, before even moving back to the better antenna. Having managed to SSH in I’m now also able to interrogate CPU usage. With the poorly placed, low gain antenna, dealing with up to four aircraft, I’m running around 60% CPU. So I guess it’s not surprising that when there are tens or more of signals to deal with, it can’t cope.

In a way, I was prompted to do this, because even with the poor antenna, it seems to have been a busy day for flights locally and it ‘fell over’ twice earlier though before I’d sorted the SSH access, so I still don’t have logs for those failures.

Does anyone know if I can simply put the existing SD card into a more powerful Pi without too much grief?

Yes that would be a possibility. Only catch I can think of is that the network interface can be named different so you need to hook it up to a local monitor in order to modify that if needed.
Other thing to consider is that the Wi-Fi chip can be different on a different model and thus needing another driver.
That can be fixed by running an update on the Raspberry Pi.

As long as you give is a DHCP adres that isn’t an issue but usually you will give a fixed ip adres to a flightfeeder.

CPU load is mostly independent of the number of aircraft (the bulk of the work is in scanning the raw samples for messages; actually decoding messages once they’re found is relatively cheap)