FlightAware Discussions

Disabling autogain1090

How do I disable autogain1090? It apparently had a hiccup and more than doubled the gain (from 17 to 45) on January 5th. I manually changed it back to 17 on the 12th. After running autogain1090 again last night, it set the gain up to 43 and message rate fell way off. Preference is to maintain a static gain so the closer in flights will get picked up.
dump1090-localhost-signal-14d

Edit your config file., the adative_dynamic_range will set to yes in your current config file

set the follwowing setting

RECEIVER_GAIN=(your gain figure here)
ADAPTIVE_DYNAMIC_RANGE=no

Save the file and restart dump1009-fa with sudo systemctl restart dump1090-fa

Then the autogain function will be disabled

2 Likes

Don’t know if which autogain you’re talking about, in case you’re talking about mine, removal is at the bottom of the page:
https://github.com/wiedehopf/adsb-scripts/wiki/Automatic-gain-optimization-for-readsb-and-dump1090-fa

Yes, that autogain. Thanks!

Getting this trying to run the uninstall script: wget: unable to resolve host address ‘raw.githubusercontent.com. Any suggestions?

The URL works fine for me … you have more issues.

Anyhow.

systemctl disable autogain1090.timer &>/dev/null
systemctl stop autogain1090.timer &>/dev/null
systemctl disable dump1090-fa-autogain.timer &>/dev/null
systemctl stop dump1090-fa-autogain.timer &>/dev/null

That’s the most important lines from the script … sufficient to stop it from doing anything.

Good to know how to stop the timers. And thanks for you work on autogain1090.