FlightAware Discussions

Changing 8080 port on piaware

Hello, I have a pi running Screenly and installed Piaware on top. The problem is Screenly uses port 80 to forward to port 8080 and Piaware 8080 is interfering. How do I change Piaware’s port to something else? I have searched on here but the only answers seem to be changing lighttpd’s ports and that wont work as Screenly needs them.
Thank you

In the file
/etc/lighttpd/conf-enabled/89-dump1090-fa.conf

change 8080 to any port you like.

dump1090-fa uses lighttpd to serve its webpage and the mentioned file is where this is configured.

If the other aliases are a problem you can remove the alias.url section that is in there without a port mentioned (it will apply to the webpage on port 80)

Thanks for the reply. I tried that then system reboot. But when I point my browser to port 8080 it still tries to load dump1090’s page and the assigned new port 8085 says “connection refused”. Is there anywhere else that loads the ports?

maybe you didn’t save the file?

you need to use sudo or you don’t have rights to save the file.
please check if it is changed in the file.

what did you install?
piaware and dump1090-fa?
or something else as well?

The pi is running “screenly” which runs off lighttpd as well. I installed piaware on top of that. So it seems screenly and piaware fight for the lighttpd resources. I was hoping simply changing the 8080 port would let them run side by side. But yes sudo nano the .conf file as below and reboot with no luck:

Allows access to the static files that provide the dump1090 map view,

and also to the dynamically-generated json parts that contain aircraft

data and are periodically written by the dump1090 daemon.

alias.url += (
“/dump1090-fa/data/” => “/run/dump1090-fa/”,
“/dump1090-fa/” => “/usr/share/dump1090-fa/html/”
)

redirect the slash-less URL

url.redirect += (
“^/dump1090-fa$” => “/dump1090-fa/”
)

Listen on port 8080 and serve the map there, too.

$SERVER[“socket”] == “:8085” {

you can just remove that and the slash-less URL config sections.

Anyway i don’t know what screenly does i’ll have to check.

Thanks. Screenly is signage engine but uses a local web interface for administration.

remove everything from the file but this section: (where you changed the port)

# Listen on port 8080 and serve the map there, too.
$SERVER["socket"] == ":8080" {
  alias.url += (
    "/data/" => "/run/dump1090-fa/",
    "/" => "/usr/share/dump1090-fa/html/"
  )
}

Are you sure you are still getting the map on 8080 then?
Try ctrl-f5 in the browser.

if the previous post doesn’t fix things, let’s have a look around:

extra config directory:
ls /etc/lighttpd/conf-enabled

and the main lighttpd config:
cat /etc/lighttpd/lighttpd.conf

you are right the map page was cahced now all I get is “connection refused” on both 8080 and 8085. I commented out everything but the port in 89-dump1090-fa.conf and changed to port back 8080…restart and still get "connection refused everywhere except port 80 (screenly).

$ls /etc/lighttpd/conf-enabled
88-dump1090-fa-statcache.conf 89-dump1090-fa.conf

$cat /etc/lighttpd/lighttpd.conf
server.modules = (
“mod_access”,
“mod_alias”,
“mod_compress”,
“mod_redirect”,
)

server.document-root = “/var/www/html”
server.upload-dirs = ( “/var/cache/lighttpd/uploads” )
server.errorlog = “/var/log/lighttpd/error.log”
server.pid-file = “/var/run/lighttpd.pid”
server.username = “www-data”
server.groupname = “www-data”
server.port = 80

index-file.names = ( “index.php”, “index.html”, “index.lighttpd.html” )
url.access-deny = ( “~”, “.inc” )
static-file.exclude-extensions = ( “.php”, “.pl”, “.fcgi” )

compress.cache-dir = “/var/cache/lighttpd/compress/”
compress.filetype = ( “application/javascript”, “text/css”, “text/html”, “text/plain” )

default listening port for IPv6 falls back to the IPv4 port

include_shell "/usr/share/lighttpd/use-ipv6.pl " + server.port
include_shell “/usr/share/lighttpd/create-mime.assign.pl”
include_shell “/usr/share/lighttpd/include-conf-enabled.pl”

show me the current
cat /etc/lighttpd/conf-enabled/89-dump1090-fa.conf

also use the right symbol next to the quote marks to post config files and such.
(or just put backticks ( ` ) around them.)

maybe screenly even disables lighttpd.

let’s check the lighttpd log:
sudo journalctl -u lighttpd -en50 --no-pager

Checking the logs. I should have started there. I am sorry I am still pretty new to this. But that was it. Thank you! Screenly had port 80 tied up and was preventing lighttpd from starting. I was mistaken that screenly was lighttpd based but it was originally installed by cups. Anyways changing lighttpd.conf server port allowed lighttpd to start and display map page.
Many, many thanks for your help!

1 Like