FlightAware Discussions

Announcing PiAware 5!

Yes I see you are on dump1090-fa 5.0 so you’re good to go

@wwshack wasn’t the only one having problems interpreting this advice.

I read it as saying that after doing a package update to v5 using apt upgrade, you also needed to upgrade dump1090-fa via the stats page to make the update “stick”.

I’ve been scratching my head as to why you would need to do this twice!

If you trigger the upgrade from the stats page, on a package install behind the scenes it’s essentially doing an “apt upgrade piaware” which will upgrade specifically the piaware feeder package only (we don’t want to unexpectedly upgrade unrelated packages which you might not be expecting). To also upgrade dump1090 or dump978 from the stats page currently requires a second separate upgrade command.

If you’re on a piaware sdcard install, a stats page upgrade command upgrades the piaware-release metapackage which pulls in updated versions of all the sdcard image components, so there’s no second step.

If you manually do an apt upgrade of all packages, obviously that gets everything at once, as you say.

3 Likes

I have been able to upgrade to PiAware and SkyAware 5.0 although my SkyAware has a strange version number 5.0-bp09+1

I am unable to see the sliders for the filters. Is this a different version? Also is it possible to get the flight numbers to show on the map (next to the aircraft) as per the earlier screenshot.

Thanks
Mark

Are you running Raspbian Stretch rather than Buster?

1 Like

You are using Stretch
bp09 = back port version 9 (OS version 9 = Stretch)
Time to re-image to latest image which is Buster.(OS version 10)

Thanks for the advice. Will give that a go!

Better Use a spare microSD card for Buster image and do not reimage existing microSD card. Leave existing one intact as backup till you are satisfied with fresh install of Buster image.

1 Like

Thanks to @obj for commit 455896e (Fix broken 32-bit x86 test that broke builds on non-x86).

After adding line git reset --hard 455896e in PKGBUILD file, could sucessfully install Piaware ver 5.0 on following:

Machine: Raspberry Pi Model 4

OS:

(1) Arch Linux armv7 (32-bit)

(2) Arch Linux aarch64 (64-bit)

Guide and installation scripts:

(1) - Install dump1090-fa (on armv7 and aarch64 OS)

https://github.com/abcd567a/dump1090-fa-arch/blob/master/README.md

 

(2) - Install piaware (on armv7 and aarch64 OS):

https://github.com/abcd567a/piaware-arch/blob/main/README.md

 

NOTE: For Ver 5.0, following lines were added to file PKGBUILD ofdump1090-fa:

In function build() :

git reset --hard 455896e

In function package():

mkdir -p ${pkgdir}/usr/share/skyaware/html
cp -r ${srcdir}/dump1090/public_html_merged/*  ${pkgdir}/usr/share/skyaware/html
  
mkdir -p ${pkgdir}/usr/lib/dump1090-fa/
cp -r ${srcdir}/dump1090/starch-benchmark  ${pkgdir}/usr/lib/dump1090-fa/
cp -r ${srcdir}/dump1090/debian/generate-wisdom ${pkgdir}/usr/share/dump1090-fa/

 

No lines were added to copy new file 89-skyaware.conf to ${pkgdir}, as following existing command did the job:

cp -r ${srcdir}/dump1090/debian/lighttpd/* ${pkgdir}/etc/lighttpd/conf.d

 

1 Like

I selected “Upgrade and restart dump1090” 15 minutes ago. Both dump1090-fa and piaware packages were upgraded to 5.0, and services restarted without a second click. (piaware-web package is also installed.)

Two additional observations:

  1. “Which version of PiAware are you running?” dropdown on PiAware - Upgrade PiAware to the latest version - FlightAware still only shows up to 3.0 :wink:
  2. When I follow abcd567’s instructions to build and install 5.0 including piaware-web on a Debian x86_64 machine, the new Web GUI at the original URI /dump1090-fa/ shows a warning “This version of SkyAware will soon be depcrecated. Visit URL: [local IP Address]/skyaware for the most up-to-date SkyAware interface.” Additionally, the root URI now links to /skyaware/, rather than to /dump1090-fa/ as it did in 4.0. However, after package updates on Raspberry Pi, there is no warning on /dump1090-fa/, and the root URI still links to /dump1090-fa/. This seems strange because I assume that both builds would come from the same source.

What image are you using?

1 Like

One of my recievers won’t upgrade to 5.0. It’s Buster image with PiAware package add-on.

Pastebin log; Create a new version of paste: - Pastebin.com

1 Like

Looks like your install has damaged package information (filesystem / sdcard corruption?)

2 Likes

I also have the same issue. Just used “sudo apt update/upgrade” on a remote Pi (Buster, add-on package) that was on 3.8.1 and now the dump1090 doesn’t work… “problem fetching data”.
Also the map is centered in Italy.
Any ideas?

pi@raspberrypi:~ sudo apt-get upgrade piaware Reading package lists... Done Building dependency tree Reading state information... Done piaware is already the newest version (5.0). Calculating upgrade... Done 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. pi@raspberrypi:~ sudo apt-get upgrade dump1090-fa
Reading package lists… Done
Building dependency tree
Reading state information… Done
dump1090-fa is already the newest version (5.0).
Calculating upgrade… Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Without logs for dump1090-fa via pastebin.com that’s a very broad question.
Debug commands · wiedehopf/adsb-wiki Wiki · GitHub

1 Like

Looks like lighttpd won’t start

The fix for that was discussed repeatedly with piaware 5.0.
If you have tar1090 you can rerun that install to fix it.

1 Like

Thanks! Didn’t have tar1090 but I added it and that worked.

The Raspberry Pi installation used a stock PiAware 4.0 image. (A number of other programmes including graphs1090 were manually installed later although I do not believe that they install anything in the paths that the original packages use.)

Ok, that’s expected behaviour for a piaware sdcard image. There is a piaware-release metapackage which depends on the exact versions of all the components that make up each release; trying to upgrade just one component e.g. dump1090-fa will end up pulling in upgrades of all components to satisfy the metapackage dependencies.

i.e.

  • piaware-release 4.0 depends on (exactly) dump1090-fa 4.0, piaware-support 4.0, piaware 4.0, etc
  • piaware-release 5.0 depends on (exactly) dump1090-fa 5.0, piaware-support 5.0, piaware 5.0, etc
  • upgrading dump1090-fa to 5.0 while you have piaware-release 4.0 installed forces piaware-release to also be upgraded (apt is smart enough to work this out); that in turn forces everything that piaware-release depends on to be upgraded.
1 Like