FlightAware Discussions

Announcing PiAware 4.0!

Yes, you did not upgrade dump1090-fa which generates the SkyView map.
The dump1090-fa is still version 3.81, hence it is showing 3.8.1 on the map.
Please see this post:

I sent the “Upgrade and restart PiAware” command, but now the device is no longer registering with FlightAware. My device shows as disconnected (red) on the ADS-B page, but when I click the “PiAware SkyAware” link I can still connect to the device and see activity. Has anyone else had this problem?

I tried restarting by unplugging and plugging it back in, but nothing changed (other than the PiAware SkyAware page went down temporarily).

For me it was working by simply run
sudo apt update
sudo apt upgrade

The FA repository updated both Piaware and dump1090-fa in one step.
This was working on both of my devices without any additional interaction

Thanks, I knew it would be something obvious. I had to do a manual apt-get update and upgrade first because it failed first time but it’s all good now.

How does this affect the UAT978? I’m running both the 1090 and 978 receivers on my RPi.

Whit

On my Pi-4, I have 2020-05-27-raspios-buster-arm64.img
I have originally installed ver 3.8.1 of piaware and dump1090-fa by building packages from source code as given in the how-to linked below.

To upgrade, I repeated the process of building source code, but as the master baranch is now at ver 4.0, the built packes are version 4.0.

However I had to install two additional dependencies of dump1090-fa, which were not required for ver 3.8.1, and hence not included in the how-to linked below:

$ sudo apt install libhackrf-dev liblimesuite-dev

Howto Install Piaware 3.8.1 on 64 bit Raspberry Pi OS (Raspbian) / Pi4

 

 

Stn # 76000 with Pi-4 and 64-bit Raspbian
image

1 Like

Does piaware-config -show wireless-connection return yes? I’d double check your wireless SSID and password.

The simplest thing to do might be starting fresh and re-image with 4.0. Once flashed, open piaware-config.txt and edit the wireless-ssid and wireless-password settings. And add the following line at the end to use your existing feeder id.

feeder-id <insert feeder_id here>

The update should work fine. The new SkyAware updates will apply to SkyAware978 map as well.

If you are using 64-bit Respbian and have build & installed ver 3.8.1 packages from source-code, then:

  1. You already have all the build tool and dependencies (except two new one) already installed.
  2. You already have source-code on your Pi in following folders:
  • dump1090
  • piaware_builder

To build packages for version 4.0, do this:

DUMP1090-FA

sudo apt install libhackrf-dev liblimesuite-dev  

cd dump1090  
git fetch --all  
git reset --hard origin/master

sudo dpkg-buildpackage -b --no-sign 

cd ../
sudo dpkg -i dump1090-fa_4.0_arm64.deb 

PIAWARE

cd piaware_builder 
git fetch --all 
git reset --hard origin/master 

sudo ./sensible-build.sh buster  
cd package-buster   
sudo dpkg-buildpackage -b --no-sign   

cd ../   
sudo dpkg -i piaware_4.0_arm64.deb 
2 Likes

Is there a way to add the correct packages to give you the display on an upgrade to the 3.8.1 SD card? Getting radios sorted out was kind of ugly and I hate to go through it again.

I have above
and did below twice still all info shows 3.81 im just a little annoyed as it should work
i have no problem redoing installs all night long
id rather fix this 1
when i watch build i only see version 3.8.1 mentioned in both builds dump1090 & piaware_builder

Although on my Piaware SD Card image ver 3
8.1, I have successfully upgraded piaware and dump1090-fa from my stats page to ver 4.0, I am soon going to re-image with the ver 4.0 microSD card image.

My personal experience tells that reimaging with latest image has much less issues in long term than upgrading from a previous version.

Add another to the list of lost “terrain limit rings”
Upgraded and restarted piaware and dump1090
restarted dump1090 severa times after confirming upintheair.json in the proper directory.
Cleared browser cache, tried from fresh browser instance on different local device.
Both FA feeder stats page and skyaware page recognize version 4.0
FA Site Information: PiAware (SD Card) 4.0
skyaware sidebar: [4.0~bpo8+1]

Interested in a solution here.

Easy Peasy!

So the new Raspberry Pi models are fully supported?

Thank you

Upgraded and the display works great but the touchscreen is not working. Is there anywhere to enable this?

Are you using the 3.5 inch Waveshare LCD A? Touch screen should work unless something is wrong with the display.

1 Like

I did the remote update to 4.0 on my other PiAware. Went smooth as silk!
image

2 Likes

Were you able to figure this out? I can get to the map page with 192.168.0.XXX:8080. But I can’t get to the landing page. I get the same 403 forbidden. I’ve cleared my caches, tried different browsers. 4.0 version appears everywhere; I have all functionality except landing page access.

@jonathancarey The landing page is not present with PiAware package installs, only SD card installs. I have not done it myself, but I believe you can install the piaware-web package to get it.

sudo apt-get install piaware-web

Installing piaware-web on a non-SD card system will work, BUT, make sure you don’t already have any default files (index.html) in the /var/www/html directory - I had been running httpd on port 80 for another purpose and forgot about the previously created index.html - I had to delete it, then

sudo apt-get install --reinstall piaware-web

to get the status page to operate correctly.

1 Like