FlightAware Discussions

Airspy - This is annoying, decoding stopping and starting

Just moved over to Airspy this evening, not smooth running yet, having issues with decoding stopping and starting as per logs:
Dec 02 18:56:05 piaware airspy_adsb[290]: Client connected from 127.0.0.1:45996 (beast)

Dec 02 18:56:33 piaware airspy_adsb[290]: Decoding stopped

Dec 02 18:56:33 piaware airspy_adsb[290]: Client disconnected 127.0.0.1:45996 (beast)

Dec 02 18:56:34 piaware airspy_adsb[290]: Acquired Airspy device with serial B8B067DC3014801F

Dec 02 18:56:34 piaware airspy_adsb[290]: Decoding started at 12 MSPS

Dec 02 18:57:33 piaware airspy_adsb[290]: Client connected from 127.0.0.1:46000 (beast)

Dec 02 19:04:39 piaware airspy_adsb[290]: Decoding stopped

Dec 02 19:04:39 piaware airspy_adsb[290]: Client disconnected 127.0.0.1:46000 (beast)

Dec 02 19:04:40 piaware airspy_adsb[290]: Acquired Airspy device with serial B8B067DC3014801F

Dec 02 19:04:40 piaware airspy_adsb[290]: Decoding started at 12 MSPS

Dec 02 19:05:39 piaware airspy_adsb[290]: Client connected from 127.0.0.1:46008 (beast)

Dec 02 19:08:57 piaware airspy_adsb[290]: Decoding stopped

Dec 02 19:08:57 piaware airspy_adsb[290]: Client disconnected 127.0.0.1:46008 (beast)

Dec 02 19:08:58 piaware airspy_adsb[290]: Acquired Airspy device with serial B8B067DC3014801F

Dec 02 19:08:58 piaware airspy_adsb[290]: Decoding started at 12 MSPS

Dec 02 19:09:57 piaware airspy_adsb[290]: Client connected from 127.0.0.1:46012 (beast)

I get the same if my airspy mini is connected to a specific port and I happen to move the RPi just slightly. If I change to the other USB3-port it’s not as sensitive and can withstand a little more movement before restarting.
Probably enough for the voltage to drop slightly due to a bad connection.

So, change USB port, if that doesn’t work, try another PSU (if you are running on a Raspberry Pi).

Yes I have a Pi3B.
OK will have a play around with that. I might be drawing too much power as I have a USB SSD on one port.
Probably going to upgrade to Pi4 but have been waiting for support from the official image, might just build one manually.

It very possible that the USB disk and airspy draws too much power for the PSU to handle.
It’s easy to build your own receiver with the help of @wiedehopf 's guide:
https://github.com/wiedehopf/airspy-conf

Make sure that you get the official PSU to the RPi4, it’s reasonably priced and performs well.

An USB SSD might just be a bad idea in general with the Airspy.
It will use huge amounts of bandwidth when active, giving you problems with MLAT.

The most likely problem with the decoding stopping is indeed voltage.

Just write the Raspbian Buster Lite onto a sd-card image, then run this script:
https://github.com/wiedehopf/adsb-scripts/wiki/Bundle-install-for-dump1090fa

dump1090-fa is then installed and you can also just install piaware like this:

sudo apt install piaware
sudo systemctl disable --now dump1090-fa-autogain.timer

(and disable the automatic gain adjustments)

RPi4 is a much better platform for the Airspy.
Still wouldn’t recommend an USB SSD, although it might work without issue as it should use the USB3 bus if it has an USB3 controller.
If it’s USB2, then i wouldn’t use it either.

Edit: For setting up the RPi without connecting monitor/keyboard, look at this:
https://www.raspberrypi.org/documentation/configuration/wireless/headless.md

Note that you need to add this line to the wpa_supplicant.conf to make sure it works (not sure why they don’t mention this important fact on that page):

country=NZ

The USB port on the Pi3 is garbage. If you use the Airspy on it, especially at 20MHz, the data volume is so high that it will conflict with anything else on USB ports (your SSD) and on the Ethernet port (shares the one PCIE lane).

Also, the Pi3 really needs 5.1V as supply, or it will throttle the frequency. In this aspect is not that far from other ARM devices, I have Amazon power blocks with 5.1 and even 5.25V listed on them.

I have moved away from my Pi3 because of that…

Thanks everyone, went offline last night for reasons unknown and required a hard reboot.

Off to get a Pi4 this morning…

1 Like

According to a youtube video i watched, this case does a decent job keeping the pi4 cool enough: https://www.amazon.com/dp/B07WG4DW52

No case might works ok as well.
But a plastic case is not a good idea in regards to temperature throttling.

There are other similar aluminium heatsinks that pull double duty as a case, i don’t think the model isn’t that important.

Yes I was just researching case/cooling options as you posted this! Will check that out…

Remember that even on the RPI4 all USB2.x and USB1.x devices share a common USB bus.
Only USB3.x devices have another bus to use.

I couldn’t run an airspy for dump1090 with a rtl-sdr or FA dongle for dump978-fa, even on an RPI4.

Check out lsusb and lsusb -t from the CLI.

For pi4 cooling, I’m currently using the fan shim with no heatsinks
you can install it without any of the software, it just runs.


It’s available on amazon as well.
It’s worked great on my Pi that’s in a Florida attic.

4 Likes

This is the case I brought up in another thread (Kodi version) that I use for the Pi4 (also have old version for P3) and it works great. Avg temp @ 2.1Ghz running full tilt is ~45c with ambient temp around 24c, but I also have the rig sitting on top of a laptop cooler, so it has air moving around the unit, but even without the external fan, I’ve never seen it above 50c. Highly recommended.

I have the RaspberryPi 4 with only a FlightAware Pro Stick Plus connected to the USB 3.0 port. So far, no issues at all. Streaming via WiFi to 4 services with Raspbian OS on a 16 GB MicroSD card.

1 Like

OK, back up and running, nice and stable on Pi4 running of SD card.

I am seeing a big improvement locally now with the AirSpy’s better dynamic range, no need to setup a second receiver for near by aircraft :slight_smile:

5 Likes