FlightAware Discussions

Airspy decoding restarts intermittenly

Today i have identified a potential issue with my Airspy while looking on the graphs:


A little earlier the ADS-B CPU utilization went down:

Finally i can find these entries in the log:

Jun 28 13:12:39 Raspy airspy_adsb[321]: Acquired Airspy device with serial 
Jun 28 13:12:39 Raspy airspy_adsb[321]: Decoding started at 12 MSPS
Jun 28 13:12:51 Raspy airspy_adsb[321]: Push client connected to localhost:30004 (beast)
Jun 28 13:12:57 Raspy airspy_adsb[321]: Decoding stopped
Jun 28 13:12:57 Raspy airspy_adsb[321]: Push client disconnected from localhost:30004 (beast)
Jun 28 13:12:58 Raspy airspy_adsb[321]: Acquired Airspy device with serial 
Jun 28 13:12:58 Raspy airspy_adsb[321]: Decoding started at 12 MSPS
Jun 28 13:13:07 Raspy airspy_adsb[321]: Decoding stopped
Jun 28 13:13:07 Raspy airspy_adsb[321]: Push client disconnected from localhost:30004 (beast)
Jun 28 13:13:08 Raspy airspy_adsb[321]: Acquired Airspy device with serial 
Jun 28 13:13:08 Raspy airspy_adsb[321]: Decoding started at 12 MSPS
Jun 28 13:13:11 Raspy airspy_adsb[321]: Push client connected to localhost:30004 (beast)
Jun 28 13:13:17 Raspy airspy_adsb[321]: Decoding stopped
Jun 28 13:13:17 Raspy airspy_adsb[321]: Push client disconnected from localhost:30004 (beast)

Any idea what causes that?

EDIT:
Trying to relaunch the airspy_adsb service which hung while shutting down.
I needed to kill the process and now it’s back running again.

too hot? don’t know.
have seen it before someone having similar.
don’t remember if it was resolved or not.

1 Like

After restarting the service it appears again. However the decoding is working:

 airspy_adsb.service - Airspy ADS-B receiver
   Loaded: loaded (/lib/systemd/system/airspy_adsb.service; enabled; vendor preset: enabled)
   Active: active (running) since Mon 2021-06-28 13:38:20 CEST; 3min 31s ago
     Docs: https://discussions.flightaware.com/t/howto-airspy-mini-piaware-dump1090-fa-configuration/44343
 Main PID: 26452 (airspy_adsb)
    Tasks: 4 (limit: 3860)
   CGroup: /system.slice/airspy_adsb.service
           └─26452 /usr/local/bin/airspy_adsb -v -f 1 -e 11.5 -l 47787:beast -c localhost:30004:beast -g 19 -m 12

Jun 28 13:39:15 Raspy airspy_adsb[26452]: Push client connected to localhost:30004 (beast)
Jun 28 13:40:19 Raspy airspy_adsb[26452]: Decoding stopped
Jun 28 13:40:19 Raspy airspy_adsb[26452]: Push client disconnected from localhost:30004 (beast)
Jun 28 13:40:20 Raspy airspy_adsb[26452]: Acquired Airspy device with serial 
Jun 28 13:40:20 Raspy airspy_adsb[26452]: Decoding started at 12 MSPS
Jun 28 13:40:32 Raspy airspy_adsb[26452]: Push client connected to localhost:30004 (beast)
Jun 28 13:41:45 Raspy airspy_adsb[26452]: Decoding stopped
Jun 28 13:41:45 Raspy airspy_adsb[26452]: Push client disconnected from localhost:30004 (beast)
Jun 28 13:41:46 Raspy airspy_adsb[26452]: Acquired Airspy device with serial 
Jun 28 13:41:46 Raspy airspy_adsb[26452]: Decoding started at 12 MSPS

Would be strange.

I had it on my covered balcony where the temperatures were > 30°C, currently it’s 28
Could a higher message rate due to increased traffic have an impact to temperature as well?

I assume you mean that thread:

In this case using a different USB-Port was recommended. On my Pi4 there is only the power for the Uputronics connected. It was working stable for more than a week using the same ports.

But i will give that a try as well

Sounds like an intermittent USB contact. Try a contact cleaner and other cables as well.

1 Like

Yes, will try that.

I’ve attached the Airspy plus Filter to my second receiver and it is fully operational since the problem several hours ago.

Well considering it’s the hottest day for the last week … heat is not a bad guess.
Could also be the USB chipset in the pi has an issue.

Quite a few people have reported issues with fast hdds via USB on the pi4.
So … checking for a temperature correlation (wether it’s the airspy being hot or the pi4 being hot is impossible to tell) makes sense to me.
With pi4 instabilities it isn’t a bad idea if raising the core voltage will fix the issue.

You can try those pretty safely

over_voltage=1
over_voltage=2

See Overclocking options in config.txt - Raspberry Pi Documentation

I’d also just reduce the frequencies for good measure as you don’t need full power anyhow.

arm_freq=1300
gpu_freq=400

Such things are very hard to debug, mostly trial / error.

Thanks for your suggestion. The combination was also facing environment temperatures of up to 34°C without issues the other day, so i did not take temperature under consideration… at least not so far…

The Raspberry itself never exceeded 55°C (CPU) i am using an active Armor case. Beside that the CPU is running at 800 MHz most of the time (as shown in RPIMonitor) and not on full speed.

I did not connect the Airspy directly, there is a USB extension cable in between, so the Airspy is producing the heat only by itself. Only the Uputronics is directly connected, but this device is not even getting hand warm.

Next step is checking the connectors, trying to slightly tighten the USB plug and reconnect everything.

Again, thanks for the support

I’d expect it to clock to full speed when you run at -e 11.5 … i wouldn’t trust RPIMonitor in that case.

55 C is good.

Yeah if a setup runs fine for a week, everything is kinda unlikely … as no one changed anything.
As such try a bunch of stuff … see if it helps.

I have it reconnected about two hours ago. after squeezing the connectors of the cables a bit i used different ports on the Raspberry and it runs fine so far.

I changed the -e option to 9 getting the CPU load reduced a bit. Current CPU temperature is a little less than 50°C but also the environment temperature goes down.

Let’s see how it goes overnight and tomorrow.

I had a similar problem last year with the mini becoming unresponsive, but recovering when I rebooted the Pi. My experience supports @prog’s suggestion that it was an intermittent USB connection - at the time the problem went away and didn’t recur. However a few weeks later I discovered I got exactly the same symptoms when I accidentally disconnected and reconnected the mini’s USB cable while the Pi was running.

It is possible that just brushing the USB cable or vibrating the Airspy would be enough to very briefly disconnect the device. While it is not an option, while you are experimenting with your configuration, I now tape the USB cable connector to the Airspy to reduce the chance of this happening. My setup lives outside at the base of the antenna pole and can move around in strong winds.

The downside of taping is that it reduces the area of the mini that can efficiently radiate heat, so adding heatsinks is a good idea.

Thanks for your input.

After now more than eight hours the device works as expected.
I also see the USB connection as the root cause, even if the temperature topic as suspected by wiedehopf is still in my mind. Temperatures are going down now, so i will monitor it.

Quick update:

Device is now running the whole day without any further issues. Temperatures are a little lower currently but i keep it monitoring.

Seem to be the USB connect which prog already suspected

1 Like