FlightAware Discussions

A helpful hint when FTP'ing files

Greetings Y’all!!!
Quick back story.
2 months ago got the bug, so I set up a PiAware out in my building. Got it working great (Moving right on up the ‘ladder’ of Rank as it were quite well).

As you see from my handle here, I’m an Amateur Extra radio operator. Picked up an Anytone HT a while back which is APRS capable. Where I’m at, there’s not a lot of digipeaters or IG’s (internet gateways) around that it can hit. Sooooo I thought, WHY NOT!

Did a bunch of searching on stuff, had an older VHF radio laying around to use (144.39 mhz in the USA for VHF APRS), and a TNC attached to it I had previously used for an emergency WinLink setup. So it all SHOULD have worked fine.

Installed Direwolf, added a USB sound card, a powered USB hub, and a USB to Serial cable.

My RTL-SDR adapter is directly plugged into the Pi
The powered USB Hub is plugged into the Pi
The USB-Serial cable and USB Soundcard are into the powered hub

Installed Direwolf (from sudo apt-get install Direwolf), and it installed clean
As you search for info on it (should you), you’ll see that it says (based on you compiling it yourself) that there will be a direwolf.conf file in the home directory (/home/pi/direwolf.conf) but guess what? It doesn’t show up ANYWHERE when installed this way (LOCATE is your friend in *nix, sudo apt-get install locate ).

So,

Installed VSFTPD (following instructions at https://pimylifeup.com/raspberry-pi-ftp/ ), and sat on my Windows system in the house and made the Direwolf config file in Notepad, saved as direwolf.conf, then FTP’d (Command Prompt in Windows, FTP xxx.xxx.xxx.xxx then it SHOULD as for login info or use your favorite flavor of FTP software) into my PiAware box and PUT (the command to transfer files) the file from my windows box to my PiAware box.

THOUGHT I had everything set up correctly. Had made the necessary mods to the Callsign area’s, the PTT (push to talk) line (PTT /dev/ttyUSB0 RTS DTR) and the rest of the config changes from the template I had used.

NO JOY on firing it up and it working to operate the radio/TNC

I checked and rechecked and triple checked and searched into the wee hours of the morning trying to figure out what went wrong where.

Turns out, there is embedded coding of the file in Windows/DOS (and MAC too) that *nix doesn’t like in files!!!

I’d open the file up (nano direwolf.conf) and I kept seeing “Converted from DOS format” at the bottom of the screen. I ignored it, REPEATEDLY.

One word here. DON’T!

It all has to do with how *nix, DOS, MAC process carriage returns and such.

On the bottom of the nano screen, you’ll see a M-D and M-M. the first M stands for using the ALT key (the ^ is CTRL key by the way), and if you press ALT and D it will either select or DESELECT DOS formatting for saving the file !!!

I FINALLY figured this out, saved the file and saw the “Filename to write: direwolf.conf [DOS FORMAT]” and hit ALT D, the Dos format went away and it saved it in native *nix formatting.

Then I sudo systemctl restart direwolf and as SOON as it came online it triggered the radio retransmitting an APRS signal like it should have!!! Talk about FRUSTRATING to say the least!!!

Now with all THAT said… I’m not sure if it would work using just the RTL-SDR dongle to receive signals, *nix is kind of funny about accessing hardware by more than one thing. It MIGHT work to run both Direwolf AND PiAware and have them both listen to sigs coming from as single dongle, so long as you DON’T have a filter in place to block out anything below 440 mhz (There are HF and VHF and UHF APRS signals, short and digital in nature )

Anyone can receive these sigs, but only licensed amateurs can transmit them.

Anyway, thanks for reading this far, I’m not a *nix genius by any stretch, I just know how to GOOGLE better than most!

Peace and Fair Journeys,

Gary - K4GHL

Might have to get another dongle and give it a shot.

1 Like

Thank you @K4GHL . This is great :+1: .
Very simple, and if one does not know it, he can spent hours, and still may not solve the problem. It also has advantage that it is done on RPi, so it is applicable to files created on both Win and Mac.

There is another way to solve it: Change formatting before FTP while file is still in Windows Computer. This can be achieved by a software called Notepad++. Unfortunately Notepad++ is available for Windows only, and therefore this method is not useful for Mac users.

Home page: https://notepad-plus-plus.org/
Download page: https://notepad-plus-plus.org/downloads/

Open file in Notepad++ and follow steps below to convert it from Windows (CR LF) or Mac (CR) to Unix (LF)

 

Win2Unix-Notepad++1

 

 

Win2Unix-Notepad++2

1 Like

https://packages.debian.org/sid/armhf/direwolf/filelist suggests it installs an example config into /usr/share/doc/direwolf/examples/

(/usr/share/doc/<package name> is always a good starting point on Debian for docs for a package)

rtlsdr dongles:

(a) are single channel receivers with fairly narrow bandwidth - you cannot have them simultaneously receive on two different frequencies unless the frequencies are very close to each other
(b) provide a single USB bulk endpoint for sample data - if you want two different programs to consume that data, you will need something in between, talking to the hardware endpoint and redistributing copies of the data. This is true regardless of OS.

tl;dr: no, you can’t do ADS-B and APRS simultaneously with a single dongle.

Also re FTP, it’s uncommon to use FTP these days, it’s mostly been replaced by {sftp,scp,rsync}. Your ssh client will probably do sftp.

I never use FTP if not required.
Textfiles which require to be exchanged with a UNIX system i am editing with Notepad++

The transfer i always do with WinSCP which is a norton style file manager using the SSH connection to a client:

Never had issues with wrong coded files.

I use FileZilla (public domain) to move files between Windows, Android and *nix systems. It also works on Apple Mac.

1 Like

SFTP from Windowd CMD Terminal

image

 

SSH From Windows CMD Terminal

image

1 Like

the Windows client is delivering incorrect colors and the mouse doesn’t work.
(you can click on a column header e.g. in htop to sort it. This is working on PuTTY, but not on Windows SSH shell)

Top Windows Client, bottom PuTTY

Again abcd567, Thanks!
I’ve been messing around with computers since the mid to late 70’s, worked at MS at one point in my life, and have used a LOT of different FTP clients in my day (remember TUCOWS? ROFL).

Until the last year or so is when I’ve started getting into different linux flavors for various reasons, which as I said originally, I’m far from a Linux Genius… DOS on the other hand… used to be pretty good at it back in the day… Guess we stick with what we know huh?

Gary

1 Like