978MHz UAT


#1

I live in US, in an area that has a few GA planes buzzing around. Sometimes I can hear them above my house but they are not on the 1090 - MLAT or ADS-B, so I imagine I could have some “hits”.

I have right now a Pi with a FA Pro dongle and I have another generic dongle that I have used previously. I am curious if anyone managed to make two dongles work on one Pi - one on 1090 and the other on the 978. I know that for the European folks this is not interesting… sorry.

I have the standard RASPBIAN JESSIE and have run the scripts from jprochazka thread (modified to work with the newer versions) so the dump978 is installed, just not running. Right now I have running the dump1090-fa on device #0, I figured that maybe I can run the dump978 on device #2 and modify the output to another port. I can try to merge them with socat (previously I failed to make it running all the time) or as a band aid, use VRS on my Windows PC (as I do now) that’s on 24/7.


#2

I personally ran dump978 on a separate PI. That make it easier to manage the feeders. I would not recommend to combine the feeds to one instance of PiAware as that will brake the MLAT, so if you would like to run both dump1090 and dump978 on one PI you will have to run two instances of PiAware.


#3

That’s OK, because I am only at 26% with CPU utilization. I have run already as a test the dump978 and I was getting some results.

I just wanted to know if anyone did so yet, and how, my linux skills are mediocre at best.


#4

That make it easier to manage the feeders. I would not recommend to combine the feeds to one instance of PiAware as that will brake the MLAT, so if you would like to run both dump1090 and dump978 on one PI you will have to run two instances of PiAware.

You can have one pi for 978 and one for 1090, or have it on a single unit. The 978 pi can feed the 1090 pi and the 1090 pi can feed Flightaware. It will not effect MLAT due to the type of message. I’ve had this setup running for years.


#5

Any pointers for using two dongles in in a single unit?


#6

I’m using two different Pis due to different antenna locations. I might be setting up some dual units shortly and should have first hand data on that soon. I know it’s already been posted on here. The short hand is assign a serial number to each dongle, then tell dump1090 to use that specific S/N. The 978 string also has to be modified to it’s specific S/N dongle. Exact directions are on the forum somewhere, it just takes some searching.


#7

Changing Serial Number of a Pro Stick

All Pro Sticks have serial number 00001000
Now I will change it to serial number 0001001

pi@raspberrypi:~ $ sudo systemctl stop dump1090-mutability

pi@raspberrypi:~ $ rtl_eeprom -s 00001001

Found 1 device(s):
0: Generic RTL2832U

Using device 0: Generic RTL2832U
Found Rafael Micro R820T tuner

Current configuration:


Vendor ID: 0x0bda
Product ID: 0x2832
Manufacturer: Realtek
Product: RTL2832UFA
Serial number: 00001000
Serial number enabled: yes
IR endpoint enabled: no
Remote wakeup enabled: no


New configuration:


Vendor ID: 0x0bda
Product ID: 0x2832
Manufacturer: Realtek
Product: RTL2832UFA
Serial number: 00001001
Serial number enabled: yes
IR endpoint enabled: no
Remote wakeup enabled: no


Write new configuration to device [y/n]? y

Configuration successfully written.
Please replug the device for changes to take effect.


#8

I’m lucky because I have one Pro Plus with serial 1000 and a (generic 820T2 - blue one) with serial 1 :slight_smile:


#9

By 1000 and 1 do you mean
00001000
00000001

All 3 of my Generic Sticks have serial number 00000001

All 3 of my FA Pro Sticks have serial number 00001000

Using rtl_eeprom command, I have changed Pro Stick’s serial numbers to Unique numbers as follows
00001001
00001002
00001003


#10

Yes. Didn’t know how many zero’s are :slight_smile:
Right now is popped in my PC, decoding some Rolling Stones on FM radio (SDR#).

So, in /etc/rc.local I have a line:

/home/pi/adsb-receiver/build/dump978-maint.sh

That rc.local doesn’t have the executable set, I can do it.

The dump987-maint.sh has the first argument “0”, then a tee that ends with nc -ql 127.0.0.30001
"rtl_sdr -d 0 - f 978000000 - 2083334 - 48 - …" etc

I suppose that “0” gonna be “1” when I add my other dongle? And the output can stay at 30001?
Anything else? Won’t “fight” with dump1090-fa for the piaware faup1090?


#11

abcd567 has it! Then assign the serial number to dump1090 via


sudo dpkg-reconfigure dump1090-mutability

. Sorry, I only use mutability, so if you use a different version, it might be different. And yes, I think you’re right on the 978 config.


#12

Installed the second stick. The generic one with serial 00001 received ID #0 and the Pro received ID #1.
I have run the jprochazka scripts because supposedly it could install both 1090 and 978 and assign receivers automatically.
Well… on the web page I get the "AJAX call failed, … maybe dump1090 not running?"
Not working. At all.

Ran the


sudo systemctl status lighttpd -l

Got:

● lighttpd.service - Lighttpd Daemon

Aug 02 18:17:04 raspberrypi systemd[1]: Starting Lighttpd Daemon…
Aug 02 18:17:14 raspberrypi lighttpd[512]: Syntax OK
Aug 02 18:17:14 raspberrypi systemd[1]: Started Lighttpd Daemon.
Aug 02 18:17:14 raspberrypi lighttpd[762]: 2017-08-02 18:17:14: (plugin.c.131) Cannot load plugin mod_setenv more than once, please fix your config (we may not accept such configs in future releases

Any suggestions? Maybe the dump1090-fa doesn’t work like this, I’ll try mutability…

LE: I forgot to change the version in the script to:

FlightAware PiAware

PIAWAREVERSION="3.5.1"
Retrying.
LLE: Nope, still not working.
I have removed the generic dongle and… everything is back online!


#13

Well, I followed this tutorial:
adsbexchange.com/how-to-fee … our-pipi2/

The difference is that the default settings for dump1090-fa are located in /etc/default
Since I want to use the Pro Stick Plus for 1090, and because the ID is associated in order with serial number (Pro Stick Plus gets ID #1), I had to change the -d argument to 1. When I connect the second stick, the 1090 works and I can “see” both dongles.
But when I go ahead and activate the dump978… everything crashes.


#14

Sounds like a power problem.


#15

It might. I tried to add a powered hub but the one that I had unused it’s a pre-USB 2.0 one and that didn’t work well when switched to “external power”.
At my PC I have an USB3 hub, powered, and the sticks are happily working connected trough that.

I might need to buy another USB hub. Or another Pi3, because I can’t program and no-one is helping me :smiley:


#16

[quote=“abcd567”]

pi@raspberrypi:~ $ rtl_eeprom -s 00001001

I don’t have that installed. How?
LE: I did found the Windows compiled ones and they work!
github.com/2013-UQ-Communicatio … in-Windows[/quote]


#17

Well, using some information from here and connecting directly the two dongles to the Pi ports, I have a setup that seemingly is running, with “top” I can see both dump1090-fa and dump 978 running.
The dump978 sends the data to the localhost port 30001

Now, is there a way to show the traffic discriminated on the map? I don’t see any TIS-B colored fields.

LE: Hmm, wonder if I need to use -mutability instead of -fa:

uat2json writes aircraft.json files in the format expected by dump1090’s
-map html/javascript.
+uat2json writes aircraft.json files in the format expected by my fork of
+dump1090’s map html/javascript.


#18

That was it, I need to install the mutability and the two clock map. Now, if I just can see any planes. Or range circles :slight_smile:
Address is like this (and yes, it has weather on it):
](http://)/dump978.php


#19

Slightly off-topic, but it pertains to what was mentioned prior regarding power issues. It’s been my personal experience that running more than 1 RTL stick directly from the Pi’s USB ports is touchy at best - especially if running the FA Orange or Blue with their internal amplifiers. If you do so, make sure to plug one in the top rail, and the other into the bottom rail since the top and bottom USB ports have their own fuse. That said, it’s pretty tough to get them next to each other anyhow due to their width, but just the same.

I’d highly recommend a powered hub for dual RTL setups such as this - but use caution here: USB 3.0 chipsets are extremely noisy on the RF spectrum. Many wifi router manufacturers (the good ones at least) wont even incorporate USB 3.0 ports on their equipment due to the excessive noise - especially in the 2.4Ghz range since it really tosses a monkey-wrench in their router’s wifi signal. Find a good powered (5v/4A) USB 2.0 hub - they will be cheaper and there is zero to gain by using a USB 3.0 hub on a Raspberry Pi 1-3. USB 3.0 may not cause excessive noise in the 978/1090 Mhz range that you are talking about here, but noise is noise and if you have a choice, may as well caution on the side of quiet right? I guess this is especially noteworthy for those using wifi connections instead of wired. Personally, I think it’s best to shut the wifi and bluetooth drivers down at boot, but that’s not an option for everyone’s setup. If you are running wired, it be a good thing to look into. Just my opinion of course.

EDIT: Just found this - even better explanation of possible USB 3.0 issues - Note the chart from Intel’s whitepaper - nasty little spike just south of 1Ghz right smack in the middle of UAT. https://discussions.flightaware.com/ads-b-flight-tracking-f21/usb-3-0-broadband-interference-t36797.html


#20

Did you ever get thie 978 working? If so, how many hits are you getting in 978? I’m trying to decide if setting this up is worth it.