FlightAware Discussions

978 UAT Traffic Types

My 978 receiver is showing two types of traffic. Predominant are ADS-B messages from light aircraft. There are a few listed as “other”


What other than the expected UAT signals are being received?
MLAT is zero as I have it disabled.

“other” is essentially anything without position information; could still be UAT (you just never heard a position)

3 Likes

I managed to have 1090 and 978 antennas onto the same RPi. I see 978 traffic in SkyView978. What I do not see is reports of the tracking on the FA My ADS-B page. When the antennas are using the same PiAware, will the 1090 and 978 traffic pop up in the same list “Flights with positions from this feeder in the last hour” ?

When I had 978 on a separate feeder with a separate ID, it showed up as expected.

Did you configure piaware to fetch data from dump978?

sudo piaware-config uat-receiver-type sdr

This should do the trick.
The statistics will be merged though.

how can I check that I did ?
I see the following:

root@odroid:~# piaware-config
receiver-host localhost # value set at /etc/piaware.conf:8
receiver-port 30005 # value set at /etc/piaware.conf:9
receiver-type rtlsdr # value set at /etc/piaware.conf:7
uat-sdr-gain 38.6 # value set at /etc/piaware.conf:10

Should have read better at @abcd567 post at link

piaware-status should show you if it’s using UAT data.

That won’t have any effect by the way.
Only works on the sd-card image.

When I restart piaware, I do see:
May 27 11:36:17 odroid sudo[14268]: pam_unix(sudo:session): session closed for user root

May 27 11:36:17 odroid piaware[14255]: ADS-B data program ‘dump1090-fa’ is listening on port 30005, so far so good

May 27 11:36:17 odroid piaware[14255]: Started faup1090 (pid 14270) to connect to dump1090-fa
May 27 11:36:17 odroid piaware[14255]: No faup978 found at , UAT support disabled
May 27 11:36:18 odroid piaware[14255]: piaware received a message from dump1090-fa!

Does that mean 978 is not running ?

I’m not sure what that means, sorry.
Looks like it’s not working.

Can you check the output of this command:

ls /usr/lib/piaware/helpers/

Indeed, it has no faup978

root@odroid:~# ls -l /usr/lib/piaware/helpers/
total 4692
-rwxr-xr-x 1 root root 14176 May 24 17:31 fa-mlat-client
-rwxr-xr-x 1 root root 92232 May 24 17:31 faup1090
-rw-r–r-- 1 root root 1155 May 24 17:31 flightaware-archive-keyring.gpg
drwxr-xr-x 15 root root 4096 May 24 17:33 lib
-rw-r–r-- 1 root root 4681536 May 24 17:31 libpython3.6m.so.1.0
-rwxr-xr-x 1 root root 2466 May 24 17:31 run-apt-get

Tried a rebuilt of piaware as in: https://discussions.flightaware.com/t/dump978-add-on-installation-procedures/49377/17. No luck. Still no faup978…

Can’t you just install it from the repository?
Maybe there is a problem with the build you are not aware of.

it will be 32-bit version. That is fine, of course. As long as it does not interfere with the 64-bit build.

I’m not sure why the build wouldn’t work.