FlightAware Discussions

3.8.1 on new Raspbery Pi 4B

Hi! I’ve recently installed a new RPi 4b and ever since installation I have had difficulty getting it to produce results. It is showing connected to FlightAware and that is is running 3.8.1 which I flashed to new SD card (in fact I have done this many times now). It also shows connected to Mode s receiver but no recent data seen. I have used 3 different DVB-T dongles and 4 different antenna. I also have a RPi3b running perfectly well. I have tried all of the combinations of kit between the two Rpis but the 3 runs happily but the 4 does not. Any suggestions?
Thanks

so the local map does not show any aircraft but it’s working in general?
What’s your current gain setting of dump1090-fa?

Where do I find the dump1090 gain?
Rgds

OK, I’ve found it.
Jun 29 09:06:52 piaware systemd[1]: Started dump1090 ADS-B receiver (FlightAware customization).
Jun 29 09:06:52 piaware dump1090-fa[16319]: Mon Jun 29 09:06:52 2020 UTC dump1090-fa 3.8.1 starting up.
Jun 29 09:06:52 piaware dump1090-fa[16319]: rtlsdr: using device #0: Generic RTL2832U OEM (Realtek, RTL2838UHIDIR, SN 00000001)
Jun 29 09:06:52 piaware dump1090-fa[16319]: Detached kernel driver
Jun 29 09:06:52 piaware dump1090-fa[16319]: Found Fitipower FC0013 tuner
Jun 29 09:06:52 piaware dump1090-fa[16319]: rtlsdr: tuner gain set to 19.7 dB
Jun 29 09:06:53 piaware dump1090-fa[16319]: Allocating 4 zero-copy buffers
Jun 29 09:06:53 piaware dump1090-fa[16319]: Detected Kernel usbfs mmap() bug, falling back to buffers in userspace

So my DVB-T dongle is set to 19.7 dB. Is this the correct setting? If not, how do I change it?
Many thanks in advance.
Rgds

This type of tuner is not usable for ADS-B. You need a R820T/R820T2.

Thanks for responding, obj. Here is the spec for my tuner from the seller’s website

1xUSB2.0 Digital DVB-T SDR+DAB+HDTV Tuner Receiver Stick RTL2832U+R820T2 Control

So it is R820T2 and should be suitable for ADS-B, or am I missing something?

Rgds

The seller cheated you.

Doesn’t matter what the print on the case or the product information says.

Also this SDR wouldn’t work on the RPi3 either.
Thus you haven’t tested it on the RPi3 as you stated.
I’d suggest more rigorous testing before saying you tested it :wink:

Plug in another of your multiple SDRs and check the log:

sudo journalctl --no-pager -u dump1090-fa

or

sudo journalctl -e -u dump1090-fa

isn’t that now the second one this week who received a “fake” device?
Maybe a warning here in the Forum is required now.

Sorry, when I said in my original post that I had tried all the combinations on both my RPi3 and RPi4 and that the RPi3 ran happily, I meant that the dongle noted here DID run on the RPi3 so if that wasn’t a conclusive test I don’t know what was!

You actually had good reception with that SDR?
I highly doubt that.

The FC0013 will happily run, you’ll just not receive anything.
Or if you’re lucky instead of nothing you receive just one or two aircraft.

Anyhow the RPi4 is expected to behave the same as the RPi3 given that you use a proper power supply (Raspberry Pi Official power supply is recommended).

1 Like

This gain setting seem to be low on a stick without LNA, independent if its working in general or not

The FC0013 has a different gain range.

How can I increase the gain and what should I set it to?
Thanks

Interesting, thank you.

I’ll post that again for clarity.

The default gain would be higher with the correct tuner …
But that’s not even the issue.
Still the wrong hardware.

Did you check the other SDRs you have if they are the correct tuner?

Try the following, but I think you are better off spending another $10 for a no-name stick with the R820T or T2:

https://www.rtl-sdr.com/driver-patch-for-fc0013-rtl-sdrs-improves-uhf-and-ads-b-performance/

Thank you. I have another dongle on order with guaranteed R820T2. In the meantime nothing is lost trying this patch on the FC0013 chip. Can you please detail the steps needed to add this patch?
I’m relatively new at all this and need all the help I can get.
Thanks again