FlightAware Discussions

3.7.1 upgrade failure

Hi everyone,

Just been lurking a bit here of late, life has been getting in the way of hobbies etc of late, and my feeder running 3.5.0 has just been plodding along … and whats the old saying? “if it ain’t broke, don’t fix it !!”

Anyways, decided to do the upgrade remotely tonight but its failed… log dump is as follows:


[2019-05-23 22:26 AEST] performing manual update, action: piaware
[2019-05-23 22:26 AEST] manual update (user-initiated via their flightaware control page) requested by adept server
[2019-05-23 22:26 AEST] run-apt-get(31413): Get:2 http://repo.feed.flightradar24.com flightradar24 Release.gpg [801 B]
[2019-05-23 22:26 AEST] run-apt-get(31413): Get:1 http://flightaware.com wheezy Release.gpg [833 B]
[2019-05-23 22:26 AEST] run-apt-get(31413): Err http://raspberrypi.collabora.com wheezy Release.gpg
[2019-05-23 22:26 AEST] run-apt-get(31413): Err http://repo.mutability.co.uk wheezy Release.gpg
[2019-05-23 22:26 AEST] run-apt-get(31413): Ign http://repo.mutability.co.uk wheezy Release
[2019-05-23 22:26 AEST] run-apt-get(31413): Get:3 http://archive.raspberrypi.org wheezy Release.gpg [488 B]
[2019-05-23 22:26 AEST] run-apt-get(31413): Something wicked happened resolving 'raspberrypi.collabora.com:http' (-5 - No address associated with hostname)
[2019-05-23 22:26 AEST] run-apt-get(31413): Get:5 http://repo.feed.flightradar24.com flightradar24 Release [12.1 kB]
[2019-05-23 22:26 AEST] run-apt-get(31413): Get:7 http://flightaware.com wheezy/piaware armhf Packages [1194 B]
[2019-05-23 22:26 AEST] run-apt-get(31413): Get:6 http://archive.raspberrypi.org wheezy Release [17.6 kB]
[2019-05-23 22:26 AEST] run-apt-get(31413): Ign http://raspberrypi.collabora.com wheezy Release
[2019-05-23 22:26 AEST] run-apt-get(31413): Get:9 http://archive.raspberrypi.org wheezy/main armhf Packages [145 kB]
[2019-05-23 22:26 AEST] run-apt-get(31413): Ign http://mirrordirector.raspbian.org wheezy Release
[2019-05-23 22:26 AEST] run-apt-get(31413): Err http://raspberrypi.collabora.com wheezy/rpi armhf Packages
[2019-05-23 22:26 AEST] run-apt-get(31413): Something wicked happened resolving 'raspberrypi.collabora.com:http' (-5 - No address associated with hostname)
[2019-05-23 22:26 AEST] run-apt-get(31413): Something wicked happened resolving 'repo.mutability.co.uk:http' (-5 - No address associated with hostname)
[2019-05-23 22:26 AEST] run-apt-get(31413): Something wicked happened resolving 'repo.mutability.co.uk:http' (-5 - No address associated with hostname)
[2019-05-23 22:26 AEST] run-apt-get(31413): Ign http://repo.feed.flightradar24.com flightradar24/raspberrypi-beta Translation-en
[2019-05-23 22:26 AEST] run-apt-get(31413): Err http://repo.mutability.co.uk wheezy/rpi armhf Packages
[2019-05-23 22:26 AEST] run-apt-get(31413): Err http://repo.mutability.co.uk wheezy/rpi Translation-en
[2019-05-23 22:26 AEST] run-apt-get(31413): Ign http://archive.raspberrypi.org wheezy/main Translation-en
[2019-05-23 22:26 AEST] run-apt-get(31413): Err http://mirrordirector.raspbian.org wheezy/main armhf Packages
[2019-05-23 22:26 AEST] run-apt-get(31413): 404 Not Found
[2019-05-23 22:26 AEST] run-apt-get(31413): 404 Not Found
[2019-05-23 22:26 AEST] run-apt-get(31413): Err http://mirrordirector.raspbian.org wheezy/non-free armhf Packages
[2019-05-23 22:26 AEST] run-apt-get(31413): 404 Not Found
[2019-05-23 22:26 AEST] run-apt-get(31413): Ign http://mirrordirector.raspbian.org wheezy/contrib Translation-en
[2019-05-23 22:26 AEST] run-apt-get(31413): Ign http://mirrordirector.raspbian.org wheezy/main Translation-en
[2019-05-23 22:26 AEST] run-apt-get(31413): Ign http://mirrordirector.raspbian.org wheezy/non-free Translation-en
[2019-05-23 22:26 AEST] run-apt-get(31413): W: Failed to fetch http://raspberrypi.collabora.com/dists/wheezy/rpi/i18n/Translation-en Something wicked happened resolving 'raspberrypi.collabora.com:http' (-5 - No address associated with hostname)
[2019-05-23 22:26 AEST] run-apt-get(31413): W: Failed to fetch http://mirrordirector.raspbian.org/raspbian/dists/wheezy/rpi/binary-armhf/Packages 404 Not Found
[2019-05-23 22:26 AEST] update request complete
[2019-05-23 22:26 AEST] run-apt-get(31413): Ign http://mirrordirector.raspbian.org wheezy/rpi Translation-en
[2019-05-23 22:26 AEST] run-apt-get(31413): Fetched 179 kB in 26s (6787 B/s)
[2019-05-23 22:26 AEST] run-apt-get(31413): W: Failed to fetch http://repo.mutability.co.uk/raspbian/dists/wheezy/rpi/i18n/Translation-en Something wicked happened resolving 'repo.mutability.co.uk:http' (-5 - No address associated with hostname)
[2019-05-23 22:26 AEST] run-apt-get(31413): W: Failed to fetch http://mirrordirector.raspbian.org/raspbian/dists/wheezy/contrib/binary-armhf/Packages 404 Not Found
[2019-05-23 22:26 AEST] run-apt-get(31413): W: Failed to fetch http://repo.mutability.co.uk/raspbian/dists/wheezy/rpi/binary-armhf/Packages Something wicked happened resolving 'repo.mutability.co.uk:http' (-5 - No address associated with hostname)
[2019-05-23 22:26 AEST] run-apt-get(31413): W: Failed to fetch http://mirrordirector.raspbian.org/raspbian/dists/wheezy/main/binary-armhf/Packages 404 Not Found
[2019-05-23 22:26 AEST] run-apt-get(31413): W: Failed to fetch http://raspberrypi.collabora.com/dists/wheezy/Release.gpg Something wicked happened resolving 'raspberrypi.collabora.com:http' (-5 - No address associated with hostname)
[2019-05-23 22:26 AEST] run-apt-get(31413): W: Failed to fetch http://mirrordirector.raspbian.org/raspbian/dists/wheezy/non-free/binary-armhf/Packages 404 Not Found
[2019-05-23 22:26 AEST] skipping action piaware

So … this is on a Pi B+ running wheezy. Ideas please!!

Thanks!

Andrew

You can remove

http://raspberrypi.collabora.com/
http://repo.mutability.co.uk/

from /etc/apt/sources.list
or one of the files in /etc/apt/sources.list.d/

The other URLs should suffice for the package update information.

The URLs are not current anymore and don’t work, thus an error occurs.

These commands should remove the offending URLs:

sudo sed -i -e '/raspberrypi.collabora.com/d' /etc/apt/sources.list /etc/apt/sources.list.d/* 
sudo sed -i -e '/repo.mutability.co.uk/d' /etc/apt/sources.list /etc/apt/sources.list.d/* 

As an alternative you could upgrade to a fresh sd-card image, that will include the new operating system version stretch instead of wheezy what you have right now.
You can save your old the piaware-config.txt and put your current feeder-id into it.
Then you have a up to date system with stretch :slight_smile:
(writing sd card image described here https://flightaware.com/adsb/piaware/build)
(For Beginners - How to Get Back Existing Station Number in A Fresh Install)

Moving to a more recent distribution is the main thing. wheezy isn’t supported upstream at all AFAIK (no security updates…) and at best it’s on life support for piaware support; the errors you’re seeing are because a lot of the old repositories you have configured have gone away.

Thanks obj and wiedehopf.

The penny didn’t drop that it’s still running wheezy … Ah well it might have to stay at 3.5.0 at the moment as I don’t have the time to do an OS update and have it fall over. It’s running 1090-mutability feeding both FA and FR with some other custom stuff so it can just stay put at this point in time until I can get some time to play around with it further.

Cheers.