WiFi Passphrase Constraints?


I set up a Pi 3 with PiAware last weekend and was unable to achieve authentication with the WiFi passphrase that was already set on my router. The router was configured as WPA/WPA2-PSK (AES) and the passphrase was generated using this site with the following options; 63 characters, upper case, lower case, numbers and exclude similar. I tried enclosing the passphrase in quotes and used a shorter version but the random generated items would not authenticate. ‘LetMeInHere’ was successfull however :unamused: I don’t recall trying a number in there.

Is anyone aware of limitations that I am falling victim to? It’s not as if there are any special characters, just mixed case alphanumeric.

It is my intent to try again tonight in a quiet period for traffic and look at /etc/wpa_supplicant/wpa-roam.conf to see what is getting into there. If that matches the router, I am stumped.

Cheers, Kev.

When I ran into that problem some time ago, the issue turned out to be case-sensitivity of the password. One side started with a capital, the other didn’t. It took a second set of eyes to pick it up. YMMV

As far as I could tell, I was really careful, re–typed and proof read it at least three times. I can’t remember for sure if I tried before but the next effort will be copy and paste via SSH.

Well, I got it to work on the second attempt. The first time using ‘piaware-config wireless-password blah’ wpa-roam.conf did not get updated to the new value, the second time it had changed by the time I finished typing ‘sudo cat /etc/wpa_supplicant/wpa-roam.conf’.


I only used a 32 char key and don’t intend to upset it by going to 63 now it’s working.

You need to reboot after changing network config via piaware-config.