Where is?


#1

Hey everyone, Recently started contributing again after moving and using new 3.5.3 I believe.
In the past, I could login to the web interface and remotely reboot my PI from FA or at least remote in and run a few commands… I thought so anyway.
I don’t see that option now, Any advice?

Thanks In advance.

Dave


#3

Hi Dave, log in to flightaware.com then visit your PiAware and you’ll see your status page.

Click on “View your site statistics” to get to your stats page. You’ll see your site listed in an orange bar. At the end of the bar is a gear icon.

site

Click that and in there are options for rebooting, etc.

configure

You can also enable remote SSH. To do that, get the SDcard and pop it into your computer. This will mount the /boot partition. In there create a file called ‘ssh’. Put the card back in the RPi and now SSH will be enabled with username ‘pi’ and password ‘flightaware’. In there you can do all the usual Linuxy stuff, edit files, reboot etc.


#5

:+1: :+1: :+1:
I think @Dxista is right, except that no should not be there in the command, only yes should be there (no will make the ‘Device command’ menu disappear)


#7

@Dxista: You have rightly guided @themcfarland, but often persons who are not very good in linux tend to simply copy-paste the command without realizing the need to edit its arguments. This may result in command not doing what it should. For this reason, I thought it is better to clarify this.

One more thing: new settings by these commands will be saved in config file of piaware in Pi, but will not be implemented on the ‘My ADSB’ page, and ‘Device commands’ menu will not show unless either the Pi is rebooted, or piaware is restarted by following command:


sudo systemctl restart piaware


#9

@Dxista
My comment persons not very good at linux was not meant for you. What I meant was that if someone not good in linux reads your post, that person may simply copy-paste the commands “as is” causing failure/malfuntion of commands.

By the way I have learned Linux the same path as you are following :slight_smile: , and I never have been a trainer, or a teacher or a professor or a writer. :slight_smile:.


#11

For reference with both options set to ‘no’ the Device Commands dropdown is replaced by explanatory text.

commands_disabled


#12

Thank you everyone… I was able to get it… I had done the manual update . failed to reboot then also did not click on the yellow banner or the individual site info… plus my screen was masking the black cmd window.


#13

.
Three years ago, I got my first Pi and started to “play” with Linux. Following are two examples of my linux blunders which I then commited. These examples show what was my Linux knowledge at that time: :smile:

Jan 13, 2015, post #965

Jan 13, 2015, post #975


#14

That is the thing I like best about the Raspberry Pi, I have learned so much about Linux using it.