Where is the configuration file for version 3.5.3


#1

I have a new FlightAware Pro Stick on its way. Somewhere I saw where I could change the gain, but how do I see what’s the gain is currently set to?

I’ve see references in other posts to a conf file but I don’t have a /etc/piaware.conf file. Nothing in /boot either. So where does Piaware store its configuration?

This is running Rasbian Stretch Lite released on 2018-03-13.

Thanks


#2

See the advanced configuration documentation. Sorry, most of this only works for the SD image.
See @abcd567 responses below.

https://flightaware.com/adsb/piaware/advanced_configuration


#3

Check OS

pi@raspberrypi:~ $ cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 9 (stretch)"
NAME="Raspbian GNU/Linux"
VERSION_ID="9"
VERSION="9 (stretch)"
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"

Check file piaware.conf


pi@raspberrypi:~ $ sudo cat /etc/piaware.conf
# This file configures piaware and related software.
# You can edit it directly or use piaware-config from the command line
# to view and change settings.
#
# If /boot/piaware-config.txt also exists, then settings present in
# that file will override settings in this file.
feeder-id xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx   # updated by fa_piaware_config
allow-auto-updates yes   # updated by fa_piaware_config
allow-manual-updates yes   # updated by fa_piaware_config
pi@raspberrypi:~ $

CHANGE GAIN

  1. Open file /etc/default/dump1090-fa for editing
    pi@raspberrypi:~ $ sudo nano /etc/default/dump1090-fa
Above command will open following file:
.
    #dump1090-fa configuration
    #This is read by the systemd service file as an environment file,
    #and evaluated by some scripts as a POSIX shell fragment.

    #If you are using a PiAware sdcard image, this config file is regenerated
    #on boot based on the contents of piaware-config.txt; any changes made to this
    #file will be lost.

    RECEIVER_OPTIONS="--device-index 0 --gain -10 --lat 43.xxxx --lon -79.xxxx --ppm 0 --net-bo-port 30005"
    DECODER_OPTIONS="--max-range 360"
    NET_OPTIONS="--net --net-heartbeat 60 --net-ro-size 1000 --net-ro-interval 1 --net-ri-port 0 --net-ro-port 30002 --$
    JSON_OPTIONS="--json-location-accuracy 1"
  1. In line starting with “RECEIVER_OPTIONS”, change the gain value to whatever value you desire:

  2. Save (Ctrl+o) and Close (Ctrl+x) file.

  3. Now restart dump1090-fa for new gain value to be implemented

    sudo systemctl restart dump1090-fa  

#4

I had already found that, but when I run piaware-config I get
“warning: /etc/piaware.conf: failed to read config file: couldn’t open “/etc/piaware.conf”: permission denied”

If I run sudo piaware-config It just goes back to a command prompt.

I mispoke earlier, there is a file /etc/piaware.conf, but if I do “sudo less /etc/piaware.conf”

This file configures piaware and related software.

You can edit it directly or use piaware-config from the command line

to view and change settings.

If /boot/piaware-config.txt also exists, then settings present in

that file will override settings in this file.

(END)

it has no settings and there is no /boot/piaware-config.txt file.

Thanks


#5

Try
sudo piaware-config -showall


#6

You are trying to use command applicable to Piaware SD Card image to a install which is Raspbian Stretch image + Piaware & dump1090-fa add-on package

In Raspbian Stretch image + Piaware & dump1090-fa add-on package:

  1. The piaware-config.txt file does NOT exist.
  2. Use sudo at start of each piaware-config command.
  3. Gain is NOT set by sudo piaware-config rtlsdr-gain xx. It is set by
sudo piaware-config rtlsdr-gain 35
Set rtlsdr-gain to 35 in /etc/piaware.conf:10
sudo systemctl restart piaware

It can also be set by EDITING the file /etc/default/dump1090-fa


#7

“sudo piaware-config -showall” works, YAH!!!

I would still like to know where the file that holds this is.

Thanks


#8

Why on earth would they make an SD card image and “apt-get install piaware” different?

That makes zero sence to me and I’ve been in computers and electronics for over 40 years!

It just creates confusion like it did here.!


#9

If you want to adjust GAIN in your install, then you have to forget piaware-config.

In your install, irrespective where piaware-config stores the gain value, piaware will NOT SET THE GAIN OF DUMP1090-FA.

The gain value in the file etc/default/dump1090-fa is the value which determines the gain. This value is controlled and over-written by piaware-conf ONLY in Piaware SD Card image, NOT in Stretch + Piaware add-on.

SHORT ANSWER:
Edit file /etc/default/dump1090-fa and set gain value there, and restart dump1090-fa.


#10

What are valid values for the gain settings in case I need to adjust it? Mine is currently

“RECEIVER_OPTIONS=”–device-index 0 --gain -10 --ppm 0 --net-bo-port 30005"

so -10

Thanks


#11

is that a typo ? should be --device NOT -device
RECEIVER_OPTIONS = ”--device-index 0 --gain -10 --ppm 0 --net-bo-port 30005"


#12

any value from zero to 50 is valid. Any value between these limits you enter, the dump1090-fa will adjust gain to its neares value. For example maximum gain is 49.6. If you enter 50 or 51 or 49, dump1090-fa will set the gain to nearest value i.e. 49.6.

If a negative number is used such as -4 or -11, the gain will be set to ZERO.

The only negative value dump1090 accepts is -10. This does not mean gain is set to -10. The value -10 is a special value and it switches the dongle to AGC (Automatic Gain Control) mode.

To see the list of gain steps:

pi@raspberrypi:~ $ sudo apt-get update

pi@raspberrypi:~ $ sudo apt-get install rtl-sdr

pi@raspberrypi:~ $ sudo systemctl stop dump1090-fa

pi@raspberrypi:~ $ rtl_test -t
Found 1 device(s):
0: Realtek, RTL2832U, SN: 00001003

Using device 0: Generic RTL2832U
Found Rafael Micro R820T tuner
Supported gain values (29): 0.0 0.9 1.4 2.7 3.7 7.7 8.7 12.5 14.4 15.7 16.6 19.7 20.7 22.9 25.4 28.0 29.7 32.8 33.8 36.4 37.2 38.6 40.2 42.1 43.4 43.9 44.5 48.0 49.6
[R82XX] PLL not locked!
Sampling at 2048000 S/s.
No E4000 tuner found, aborting.
pi@raspberrypi:~ $


#13

Odd, I copied and pasted the whole line but somehow that extra dash is missing. The file is correct however


#14

Thanks for all the great info. The new FA dongle seems to be working slightly better than the NOOELEC that I had. I’m going to let it run for a while before I go making any changes.

Thanks for all the help.


#15

.
.

If you copy-paste code, some lines will appear very bold, as in your above quoted post… This can be avoided. Please see this thread::

.