FlightAware Discussions

3.6.3


#1

I was able to get the new version to work on my B+ using the same card from my B Pi. However I am not able to find the piaware-config.txt file to play with my gain. I am a newbie with linux.
I did a get-apt update and upgrade and updated my dump1090.


#2

if it is a piaware SD card image, cat /boot/piaware-config.txt will confirm location and file contents.
you can change gain with this command sudo piaware-config rtlsdr-gain nn.n.
HTH

evangel

ED1 correction


#3

Use the following commands to set gain and restart dump1090-fa (no need to reboot):

sudo piaware-config rtlsdr-gain 30
sudo systemctl restart dump1090-fa

#4

Basic Info required:

Is it a

  • Piaware SD Card Image
    OR
  • Raspbain image with Piaware package install

EDIT:
OK, found from your Flaightaware Stats page:
PiAware (SD Card) 3.6.3

Please follow advises by @evangelyul and @wiedehopf


#5

this is what I got when I tried your suggestion.

sudo piaware-config rtlsdr-gain=49.0
warning: /boot/piaware-config.txt:89: feeder-id overrides a value previously set on line 67
warning: cannot set option ‘rtlsdr-gain=49.0’, it is not a known config option

remember I am a newbie


#6

The = is bogus. Use a space like i wrote it down in the my post above.


#7

apologies the ‘=’ not required !


#8

Thanks that worked. How do I change the freq from 700 to 800?