Very Strange screen... Help!

My piaware running 6.1 is sending the ADSB data to all the sites I set it up to send to, but when I browse directly into it, this is the screen I get… I tried multiple browsers and get the same result. Any ideas?

Screen Shot 2021-11-15 at 3.57.58 PM|512x500

Is this with the PiAware image or a package install on Raspbian or some other ARM Linux? What led up to this condition? Is it a fresh installation or has it been working in the past?

It was working fine in the past… I recently adjusted my settings to automatically change adaptive gain, and this started happening.

I believe I am running all of the latest software…

Again, did you burn the piaware image to the SD card or a Raspbian PiOS image then install piaware from packages?

Exactly what steps did you take to enable adaptive gain?

Did you try putting your settings back the way they were before you changed them?

I burned the image on an SD card running on a Raspberry Pi 3. Upgraded the OS using the FlightAware settings page, updated and restart both Piaware and dump1090 on that page, watched the process in the log, etc… I did set the adaptive gain back to manual. currently running PiAware Version: 6.1
**Dump1090-fa Version: dump1090-fa 6.1~bpo9+1

What image exactly? (20 characters)

I did it a few months ago and don’t recall. What is the best way to find it. Currently in the terminal…

The PiAware image is a headless Linux image meaning there’s no graphical user interface (GUI) when you connect a monitor, keyboard and mouse to your Pi. Raspbian and similar OSs will display a GUI desktop.

Got it. What is the best way to determine exactly what OS I have. I hooked up a monitor to my Pi at one point and could watch it start up and give a running status, but have never interacted with it. I don’t have a wired keyboard or mouse to attach…

What does that mean? Did you get a GUI desktop or not?

1 Like

Also, please answer peoples questions or they can’t help you.

That sort of page display is a symptom that some of the support files (CSS, etc) for the map page are broken. Try clearing your browser cache and try again; if it persists, look for errors in the dev console (e.g. F12 in Chrome, look at the Console or Network tab)

1 Like

I think you nailed it. I get the same screen as the OP if I go into the View menu and set Page Style to no style. If I set it back to Basic Page Style I get the normal screen again.

I cleared browser caches, tried it on my iPhone, iPad, laptop, different browsers with the same result. This is what the developer console shows on Chrome…

Also, the Piaware seems to hang up so that I cannot ssh in from the console… To get in, I have to unplug it and try within a few minutes of plugging it back in. Not sure if that is related, though. Still, it is feeding all of the sites data… FA, FR24, ADSBX, OpenSky, Radarbox are all getting data. I also cannot connect to Virtual Radar Server without unplugging it and trying it soon after plugging back in.


If I had to guess I’d say that you have filesystem corruption and one of the support files for skyaware has been damaged. The ssh / VRS problem also implies there’s something badly wrong with that install overall…

It is very eady to find out just by looking at terminal.

If command prompt is:
pi@piaware:~ $
it is a piaware SD card image

If command prompt is:
pi@raspberrypi:~ $
it is Raspbian image with package install of piaware & dump1090-fa


Getting down to brass tacks, what is my best bet for fixing it? I have a lot of stuff on there and would hate to lose it all… RPI monitor, Graphs1090, feeds directing traffic to half a dozen sites, etc…

By answering the questions you have been asked, without that information it’s not possible to figure out the issue and give instructions on how to resolve.