FlightAware Discussions

Usb_interface_claim error on 978

My UAT978 receiver quit working. It’s the FA orange dongle and it worked well until the latest update. I’ve serialized according to instruction here.

Log shows the 1090 active but 978 shows the usb_interface_claim_error

dump978-fa.service:Unit entered failed state
dump978-fa.service: failed with result ‘exit-code’.

Post a longer log, preferably on pastebin and link it here.
https://github.com/wiedehopf/adsb-wiki/wiki/Debug-commands

Also check the command
sudo piaware-config
to see if the serials are configured correctly.

Then check if the dongles are still showing the right serial:

sudo systemctl stop piaware dump1090-fa dump978-fa
sudo rtl_test

You can either restart the services or just reboot.

  1. pi@piaware:~ $ sudo piaware-config

  2. allow-auto-updates yes # value set at /bo ot/piaware-config.txt:67

  3. allow-manual-updates yes # value set at /bo ot/piaware-config.txt:71

  4. allow-mlat yes # value set at /bo ot/piaware-config.txt:75

  5. allow-modeac yes # value set at /bo ot/piaware-config.txt:79

  6. feeder-id 7f8a6959-18dd-4458-a614-c55f346ddc7e # value set at /boot/piaware-config.txt:84

  7. image-type piaware # value set at /us r/share/piaware-support/piaware-image-config.txt:5

  8. manage-config yes # value set at /us r/share/piaware-support/piaware-image-config.txt:4

  9. rtlsdr-gain max # value set at /bo ot/piaware-config.txt:60

  10. uat-receiver-type sdr # value set at /bo ot/piaware-config.txt:85

  11. uat-sdr-device driver=rtlsdr,serial=00000978 # value set at /bo ot/piaware-config.txt:86

  12. wired-network yes # value set at /bo ot/piaware-config.txt:27

  13. wireless-network yes # value set at /bo ot/piaware-config.txt:33

  14. wireless-password # value set at /bo ot/piaware-config.txt:49

  15. wireless-ssid MyWifiNetwork # value set at /bo ot/piaware-config.txt:48

  16. pi@piaware:~ $

  17. pi@piaware:~ pi@piaware:~ sudo piaware-config

  18. -bash: pi@piaware:~: command not found

  19. pi@piaware:~ $ allow-auto-updates yes # v alue set at /boot/piaware-config.txt:67

  20. -bash: allow-auto-updates: command not found

  21. pi@piaware:~ $ allow-manual-updates yes # v alue set at /boot/piaware-config.txt:71

  22. -bash: allow-manual-updates: command not found

  23. pi@piaware:~ $ allow-mlat yes # v alue set at /boot/piaware-config.txt:75

  24. -bash: allow-mlat: command not found

  25. pi@piaware:~ $ allow-modeac yes # v alue set at /boot/piaware-config.txt:79

  26. -bash: allow-modeac: command not found

  27. pi@piaware:~ $ feeder-id 7f8a6959-18dd-4458-a614-c55f346ddc 7e # value set at /boot/piaware-config.txt:84

  28. -bash: feeder-id: command not found

  29. pi@piaware:~ $ image-type piaware # v alue set at /usr/share/piaware-support/piaware-image-config.txt:5

  30. -bash: image-type: command not found

  31. pi@piaware:~ $ manage-config yes # v alue set at /usr/share/piaware-support/piaware-image-config.txt:4

  32. -bash: manage-config: command not found

  33. pi@piaware:~ $ rtlsdr-gain max # v alue set at /boot/piaware-config.txt:60

  34. -bash: rtlsdr-gain: command not found

  35. pi@piaware:~ $ uat-receiver-type sdr # v alue set at /boot/piaware-config.txt:85

  36. -bash: uat-receiver-type: command not found

  37. pi@piaware:~ $ uat-sdr-device driver=rtlsdr,serial=00000978 # v alue set at /boot/piaware-config.txt:86

  38. -bash: uat-sdr-device: command not found

  39. pi@piaware:~ $ wired-network yes # v alue set at /boot/piaware-config.txt:27

  40. -bash: wired-network: command not found

  41. pi@piaware:~ $ wireless-network yes # v alue set at /boot/piaware-config.txt:33

  42. -bash: wireless-network: command not found

  43. pi@piaware:~ $ wireless-password # v alue set at /boot/piaware-config.txt:49

  44. -bash: syntax error near unexpected token `newline’

  45. pi@piaware:~ $ wireless-ssid MyWifiNetwork # v alue set at /boot/piaware-config.txt:48

  46. -bash: wireless-ssid: command not found

  47. pi@piaware:~ $ allow-auto-updates yes # v alue set at /boot/piaware-config.txt:67

  48. -bash: allow-auto-updates: command not found

  49. pi@piaware:~ $ allow-manual-updates yes # v alue set at /boot/piaware-config.txt:71

  50. -bash: allow-manual-updates: command not found

  51. pi@piaware:~ $ allow-mlat yes # v alue set at /boot/piaware-config.txt:75

  52. -bash: allow-mlat: command not found

  53. pi@piaware:~ $ allow-modeac yes # v alue set at /boot/piaware-config.txt:79

  54. -bash: allow-modeac: command not found

  55. pi@piaware:~ $ feeder-id 7f8a6959-18dd-4458-a614-c55f346ddc 7e # value set at /boot/piaware-config.txt:84

  56. -bash: feeder-id: command not found

  57. pi@piaware:~ $ image-type piaware # v alue set at /usr/share/piaware-support/piaware-image-config.txt:5

  58. -bash: image-type: command not found

  59. pi@piaware:~ $ manage-config yes # v alue set at /usr/share/piaware-support/piaware-image-config.txt:4

  60. -bash: manage-config: command not found

  61. pi@piaware:~ $ rtlsdr-gain max # v alue set at /boot/piaware-config.txt:60

  62. -bash: rtlsdr-gain: command not found

  63. pi@piaware:~ $ uat-receiver-type sdr # v alue set at /boot/piaware-config.txt:85

  64. -bash: uat-receiver-type: command not found

  65. pi@piaware:~ $ uat-sdr-device driver=rtlsdr,serial=00000978 # v alue set at /boot/piaware-config.txt:86

  66. -bash: uat-sdr-device: command not found

  67. pi@piaware:~ $ wired-network yes # v alue set at /boot/piaware-config.txt:27

  68. -bash: wired-network: command not found

  69. pi@piaware:~ $ wireless-network yes # v alue set at /boot/piaware-config.txt:33

  70. -bash: wireless-network: command not found

  71. pi@piaware:~ $ wireless-password # v alue set at /boot/piaware-config.txt:49

  72. -bash: syntax error near unexpected token `newline’

  73. pi@piaware:~ $ wireless-ssid MyWifiNetwork # v alue set at /boot/piaware-config.txt:48

  74. -bash: wireless-ssid: command not found

  75. pi@piaware:~ pi@piaware:~

  76. -bash: pi@piaware:~: command not found

  77. pi@piaware:~ pi@piaware:~ pi@piaware:~ $ sudo piaware-config

  78. -bash: pi@piaware:~: command not found

  79. pi@piaware:~ $ -bash: pi@piaware:~: command not found

  80. -bash: -bash:: command not found

  81. pi@piaware:~ pi@piaware:~ allow-auto-updates yes # value set at /boot/piaware-config.txt:67

  82. -bash: pi@piaware:~: command not found

  83. pi@piaware:~ $ -bash: allow-auto-updates: command not found

  84. -bash: -bash:: command not found

  85. pi@piaware:~ pi@piaware:~ allow-manual-updates yes # value set at /boot/piaware-config.txt:71

  86. -bash: pi@piaware:~: command not found

  87. pi@piaware:~ $ -bash: allow-manual-updates: command not found

  88. -bash: -bash:: command not found

  89. pi@piaware:~ pi@piaware:~ allow-mlat yes # value set at /boot/piaware-config.txt:75

  90. -bash: pi@piaware:~: command not found

  91. pi@piaware:~ $ -bash: allow-mlat: command not found

  92. -bash: -bash:: command not found

  93. pi@piaware:~ pi@piaware:~ allow-modeac yes # value set at /boot/piaware-config.txt:79

  94. -bash: pi@piaware:~: command not found

  95. pi@piaware:~ $ -bash: allow-modeac: command not found

  96. -bash: -bash:: command not found

  97. pi@piaware:~ pi@piaware:~ feeder-id 7f8a6959-18dd-4458- a614-c55f346ddc7e # value set at /boot/piaware-config.txt:84

  98. -bash: pi@piaware:~: command not found

  99. pi@piaware:~ $ -bash: feeder-id: command not found

  100. -bash: -bash:: command not found

  101. pi@piaware:~ pi@piaware:~ image-type piaware # value set at /usr/share/piaware-support/piaware-image-config.txt:5

  102. -bash: pi@piaware:~: command not found

  103. pi@piaware:~ $ -bash: image-type: command not found

  104. -bash: -bash:: command not found

  105. pi@piaware:~ pi@piaware:~ manage-config yes # value set at /usr/share/piaware-support/piaware-image-config.txt:4

  106. -bash: pi@piaware:~: command not found

  107. pi@piaware:~ $ -bash: manage-config: command not found

  108. -bash: -bash:: command not found

  109. pi@piaware:~ pi@piaware:~ rtlsdr-gain max # value set at /boot/piaware-config.txt:60

  110. -bash: pi@piaware:~: command not found

  111. pi@piaware:~ $ -bash: rtlsdr-gain: command not found

  112. -bash: -bash:: command not found

  113. pi@piaware:~ pi@piaware:~ uat-receiver-type sdr # value set at /boot/piaware-config.txt:85

  114. -bash: pi@piaware:~: command not found

  115. pi@piaware:~ $ -bash: uat-receiver-type: command not found

  116. -bash: -bash:: command not found

  117. pi@piaware:~ pi@piaware:~ uat-sdr-device driver=rtlsdr,seria l=00000978 # value set at /boot/piaware-config.txt:86

  118. -bash: pi@piaware:~: command not found

  119. pi@piaware:~ $ -bash: uat-sdr-device: command not found

  120. -bash: -bash:: command not found

  121. pi@piaware:~ pi@piaware:~ wired-network yes # value set at /boot/piaware-config.txt:27

  122. -bash: pi@piaware:~: command not found

  123. pi@piaware:~ $ -bash: wired-network: command not found

  124. -bash: -bash:: command not found

  125. pi@piaware:~ pi@piaware:~ wireless-network yes # value set at /boot/piaware-config.txt:33

  126. -bash: pi@piaware:~: command not found

  127. pi@piaware:~ $ -bash: wireless-network: command not found

  128. -bash: -bash:: command not found

  129. pi@piaware:~ pi@piaware:~ wireless-password # value set at /boot/piaware-config.txt:49

  130. -bash: syntax error near unexpected token `newline’

  131. pi@piaware:~ $ -bash: syntax error near unexpected token `newline’

  132. pi@piaware:~ $ wireless-ssid MyWifiNetwork # value set at /boot/piaware-config.txt:48

pi@piaware:~ sudo systemctl stop piaware dump1090-fa dump978-fa pi@piaware:~ sudo rtl_test
Found 1 device(s):
0: Realtek, RTL2832U, SN: 00000978

Using device 0: Generic RTL2832U
Detached kernel driver
Found Rafael Micro R820T tuner
Supported gain values (29): 0.0 0.9 1.4 2.7 3.7 7.7 8.7 12.5 14.4 15.7 16.6 19.7 20.7 22.9 25.4 28.0 29.7 32.8 33.8 36.4 37.2 38.6 40.2 42.1 43.4 43.9 44.5 48.0 49.6
[R82XX] PLL not locked!
Sampling at 2048000 S/s.

Info: This tool will continuously read from the device, and report if
samples get lost. If you observe no further output, everything is fine.

Reading samples in async mode…
pi@piaware:~ sudo systemctl stop piaware dump1090-fa dump978-fa pi@piaware:~ sudo rtl_test
Found 1 device(s):
0: Realtek, RTL2832U, SN: 00000978

Using device 0: Generic RTL2832U
Detached kernel driver
Found Rafael Micro R820T tuner
Supported gain values (29): 0.0 0.9 1.4 2.7 3.7 7.7 8.7 12.5 14.4 15.7 16.6 19.7 20.7 22.9 25.4 28.0 29.7 32.8 33.8 36.4 37.2 38.6 40.2 42.1 43.4 43.9 44.5 48.0 49.6
[R82XX] PLL not locked!
Sampling at 2048000 S/s.

Info: This tool will continuously read from the device, and report if
samples get lost. If you observe no further output, everything is fine.

Reading samples in async mode…

RAW Paste Data

pi@piaware:~ sudo systemctl stop piaware dump1090-fa dump978-fa pi@piaware:~ sudo rtl_test
Found 1 device(s):
0: Realtek, RTL2832U, SN: 00000978

Using device 0: Generic RTL2832U
Detached kernel driver
Found Rafael Micro R820T tuner
Supported gain values (29): 0.0 0.9 1.4 2.7 3.7 7.7 8.7 12.5 14.4 15.7 16.6 19.7 20.7 22.9 25.4 28.0 29.7 32.8 33.8 36.4 37.2 38.6 40.2 42.1 43.4 43.9 44.5 48.0 49.6
[R82XX] PLL not locked!
Sampling at 2048000 S/s.

Info: This tool will continuously read from the device, and report if
samples get lost. If you observe no further output, everything is fine.

Reading samples in async mode…
pi@piaware:~ sudo systemctl stop piaware dump1090-fa dump978-fa pi@piaware:~ sudo rtl_test
Found 1 device(s):
0: Realtek, RTL2832U, SN: 00000978

Using device 0: Generic RTL2832U
Detached kernel driver
Found Rafael Micro R820T tuner
Supported gain values (29): 0.0 0.9 1.4 2.7 3.7 7.7 8.7 12.5 14.4 15.7 16.6 19.7 20.7 22.9 25.4 28.0 29.7 32.8 33.8 36.4 37.2 38.6 40.2 42.1 43.4 43.9 44.5 48.0 49.6
[R82XX] PLL not locked!
Sampling at 2048000 S/s.

Info: This tool will continuously read from the device, and report if
samples get lost. If you observe no further output, everything is fine.

Reading samples in async mode…

So you see, one of the dongles isn’t working anymore.
Hmm or maybe you need to specify a device with rtl_test?

sudo rtl_test -d 1

Anyway the output of

sudo piaware-config

Is the other interesting part of the puzzle.

Unplug both dongles, then after 30 seconds replug both dongles, and run the test:

rtl_test -t

I’m running this as a single dongle UAT978.

I added the 978 dongle but didn’t add the 1090 device. Seems you need to add both as it looks for both dongles.

Then you need to disable 1090 MHz reception.

sudo piaware-config uat-receiver-type sdr
sudo piaware-config receiver-type none
sudo systemctl restart piaware

Piaware SD card image 3.7.1 Quickstart Guide

1 Like