FlightAware Discussions

Updating from MyFlightaware page not working

Hi, I’m trying to update from version 5.0 to 6.0 via the MyFlightaware page
By running: “upgrade and restart piaware” (auto update is also on).

I tried several times, but my receiver remains version 5.0.
I don’t know why it won’t work this way, but I prefer not to update by using a fresh image.

Is there another way round to upgrade manually?

Do you have a package install?
If so you also need to select the “Upgrade and Restart dump1090” option to upgrade dump1090.

He seem to have a Piaware image in use:

Feeder Type: PiAware (SD Card) 5.0

1 Like
[2021-09-04 08:30 GMT] run-apt-get(737): E: Repository 'http://raspbian.raspberrypi.org/raspbian buster InRelease' changed its 'Suite' value from 'stable' to 'oldstable'

Not sure how you ended up pointing at the upstream mirror (the 5.0 sdcard ships with the configuration pointing at the FA mirrors, and the FA mirrors have a workaround for this) but you have two options

  1. reimage
  2. run sudo apt update from a shell and accept the change in Suite value when it asks, then try the upgrade again

This worked. Thanks a lot!