Unique feeder id is still default


#1

I am running Rasbian Jessie and the separate piaware program as well as the planeplotter ppup1090 and the ADSB-Receiver package for graph based analysis. Having upgraded my Pi when I installed a FA dongle a while ago, I spoofed the MAC to keep the stats from before (before the ability to update exitsing sites was available). That is fine but I notice that the unique identifier on the site information box is still the default 12345…

this is for site 2510 which has been on the air for a little while now…

I need to remove the MAC spoofing, please can you tell me how to get the unique identifier for this site. The /var/log/piaware.log just gives the default feeder id.

thanks
Roger


#2

There is no default feeder ID, what exactly are you seeing?

edit: oh, huh. That’s not a valid feeder ID, how did that get in there?
edit2: can you

  1. stop piaware
  2. remove the feeder-id line entirely from your piaware-config.txt if you have one
  3. remove /var/cache/piaware/feeder_id
  4. restart piaware
  5. send me (via PM or email) the new UUID that you see in /var/log/piaware.log and I’ll fix the site.

Not sure how that placeholder 1234… UUID leaked into the server-side data but it shouldn’t be there.


#3

obj
thanks for fixing it. The reason it was the old (1234…) was that I reverted the feeder id to that to check it was all still working, and had not got back to changing to to the new one before you looked at it.

My MLAT shows red at present although it is enabled / supported. Other than that it seems to be OK. I guess the other sites were created as part of the “messing about” when I tried to fix it.

Hopefully the stats etc will now remain and continue as they are (I asssume) associated with the new UUID.

Roger


#4

mlat should be working now, it just needed a reconnect.


#5

all working fine on the new UUID
thanks for your help
Roger