Ubuntu No Rpi

Ubuntu to FA

I thought this would be an easy effort to get my 4 th. up loader to FA :neutral_face: . Netbook Aspire One and Ubuntu 14.04 and Git dl of dump1090 works very well. But, I’ve yet to get Piaware working. Source code was gotten here on the forum (pastebin).

Using ‘sudo piaware-status’ shows only Dump1090 working.

No pgm listening on port 30005
faup1090 is not connected to port 30005
piaware is not connected to FA
couldn’t open socket: conn. refused
Dump1090 is not producing data on 30005

What is happening to my Piaware? The step by step ‘copy & paste’ all seemed a normal build. I’ve completed a 2nd reformat and reenstall. No joy. TIA! Pointers?


Did you tried this one?

You could also try this:

It automates building and installation of dump1090-mutability, piaware and performance graphs. I ran it yesterday on a Pi. It did build Piaware but did not install it. Manually installing it afterwards did the trick. See full details here:

Many thanks to both of you!

jprochazka/adsb-feeder I get the ubuntu 1404 screen. The dl unpacking etc took about 25 mins then dump1090 another 6 mins or so. Now how to get the planes on screen and piaware up and running?

Any suggestions are appreciated as I would like to get this netbook on FA. TIA! Meanwhile I am working on the forum lead offered.


sudo /etc/init.d/dump1090-mutability restart with the 'udev" first but no joy.

What is in /var/log/dump1090-mutability.log?
That would be the first thing to check when looking for issues with dump1090.


I found nothing there. I have reformatted and reinstalled Ubuntu OS 14.04 on the Acer Netbook. Completed the steps for script by jprochazka and no rings or anything that indicates dump1090 is operative. Do I have the wrong idea of a “feeder”? I expected dump1090 mutability to boot (show a/c) somewhere in this effort. It talks about range rings as though a dynamic graphic was around the corner.

What is next to achieve a piaware/ Flight Aware upload?

Carl Thanks for your effort! In the meantime I’ll look at the prochazka adsb feeder wiki

dump1090 by itself won’t display anything. No rings, no planes, no maps, nothing. It is designed to receive ADS-B messages, decode them and periodically provide output data. This data, together with the web page code that was created during dump1090 install, needs to be viewed in a browser, either on the same machine or another machine.

First, lets try to find out if you currently have dump1090 installed. Please run the following commands from a shell prompt and post exactly what is displayed:

ps -ef | grep dump1090


sudo find / -name "dump1090-mutability"

the 1st gives:
cp 6626 2529 0 15:37 pts/1 00:00:00 grep --color auto dump1090

the 2nd gives:
find: paths must precede expression: mutability
usage: find [h] -L] -p] [o level]-d help | tree| search | stat | rates | opt | exec ] path…] [expression] performed with no " ". performed with " " shows nothing

Is the 2nd a syntax problem?

Thank you HTH!


The first output tells us that dump1090-mutability is not currently running.

The second output indicates a syntax problem. I tested the command on two of my systems and it works fine for me. Please try again.

Also do the following:

ls /etc/init.d/


ls /etc/init.d/

acp.d, anacron, apparor, apport, avahi-daemon, bluetooth, britty, collected, console-setup, cron, cups, cups-browsed, dbus, dns-clean, dump1090-mutability, friendly- recovery, grub-

common, halt, trqbalance, kerneloops, killprocess, kmod, lightdm, lighttpd, networking, ondemand, pppd-dps, propcps, pulseaudio, rc, rc.local, rcs, readme, reboot, resolveconf, rysnc

rsync, rsyslog, sansed, sendsigs, single, skeleton, speech-dispatcher, sudo, udev, umountfs, umountnfs, umountroot, unattended-upgrades, urandom, x11-common

The earlier syntax one is the same reported. Is there any pre- or post code necessary that I am missing on the syntax?



OK, it looks like dump1090-mutability may be installed. Try to configure it and post any issues seen or questions you have here. Most defaults will be OK for now.

sudo dpkg-reconfigure dump1090-mutability

Then try to start it:

sudo /etc/init.d/dump1090-mutability restart

Check what it is doing:

cat /var/log/dump1090-mutability.log

configured and added blacklist. I’ll “cat” and see but can’t find the directory to get it running! There is no “dump1090” subdirectory?


I’m not aware of any dump1090 subdirectory. The executable is normally located at /usr/share/dump1090-mutability

To start dump1090-mutability, run:

sudo /etc/init.d/dump1090-mutability start

To stop:

sudo /etc/init.d/dump1090-mutability stop

To check:

sudo /etc/init.d/dump1090-mutability status

To see log file:

cat /var/log/dump1090-mutability.log


this should be running but no planes.

Fri Jan 8 10:09:38 2016 CST dump1090-mutability v1.15~dev starting up.
Using sample converter: UC8, integer/table path
Found 1 device(s):
0: Realtek, RTL2838UHIDIR, SN: 00000001 (currently selected)
Found Rafael Micro R820T tuner
Max available gain is: 49.60 dB
Setting gain to: 49.60 dB
Exact sample rate is: 2000000.052982 Hz
Gain reported by device: 49.60 dB

Are we getting closer?

And this too:

0 messages with signal power above -3dBFS
Messages from network clients:
0 Mode A/C messages received
0 Mode S messages received
0 with bad message format or invalid CRC
0 with unrecognized ICAO address
0 accepted with correct CRC
0 accepted with 1-bit error repaired
378105 total usable messages
0 surface position messages received
18894 airborne position messages received
17747 global CPR attempts with valid positions
0 global CPR attempts with bad data
0 global CPR attempts that failed the range check
0 global CPR attempts that failed the speed check
6 global CPR attempts with insufficient data
1052 local CPR attempts with valid positions
988 aircraft-relative positions
64 receiver-relative positions
95 local CPR attempts that did not produce useful positions
95 local CPR attempts that failed the range check
0 local CPR attempts that failed the speed check
0 CPR messages that look like transponder failures filtered
51430 non-ES altitude messages from ES-equipped aircraft ignored
249 unique aircraft tracks
24 aircraft tracks where only one message was seen
0 HTTP requests
CPU load: 12.2%
377580 ms for demodulation
172480 ms for reading from USB
18855 ms for network input and background tasks
Fri Jan 8 11:27:11 2016 CST Normal exit.
Fri Jan 8 11:27:58 2016 CST dump1090-mutability v1.15~dev starting up.
Using sample converter: UC8, integer/table path
Found 1 device(s):
0: Realtek, RTL2838UHIDIR, SN: 00000001 (currently selected)
Found Rafael Micro R820T tuner
Max available gain is: 49.60 dB
Setting gain to: 49.60 dB
Exact sample rate is: 2000000.052982 Hz
Gain reported by device: 49.60 dB

How are the planes not showing in dynamic 2d?

Before solving Piaware this shortcoming must be solved?

Carl TIA Any and all advice please?!

Yes, this looks good to me. But what is dynamic 2d?

Have you tried these two addresses from a browser on your PC or laptop?


The browser works on IP address and the 8080 port. But the dynamic 2 dimensional (all alpha Numeric) screen does not (Unlike the other 4 uploaders that I have running).

Now it is Piaware time.

Many thanks for your kind efforts!


Great! I still have no idea what a dynamic 2 dimensional (all alpha Numeric) screen is and how it is connected so can’t comment about that.

For PiAware, restart it and check the log a few seconds later:

sudo /etc/init.d/piaware restart
cat /tmp/piaware.out