U-blox-7 GPS on Pi 5

Hi All!

I just wanted to drop a quick post on a newly built PiAware receiver. I just set up a Raspberry Pi 5 with PiAware 9.01 and attached a cheap USB VK-162 G mouse GPS (U-Blox-7) I got off Amazon. This receiver will be mobile as I travel. I had some problems with the GPS not reporting properly even though it was the GPS was getting a 3D position lock and working properly. GPSD would never update PiAware with coordinates other than 0,0.

To get it working, all I had to so was set up PiAware via the normal instructions.

Then I added the GPS by:

sudo apt install gpsd
sudo piaware-config use-gpsd yes

I rebooted, but no luck. I ran “cgps -s” and it reported that it had a 3D Fix, but the coordinates were showing 0.000000, 0.00000. However, gpsmon was outputting the proper coordinates. Weird, right?

To solve the situation I did a LOT of Googling including reading on this site.

What finally worked was modifying /etc/default/gpsd to look like this:

DEVICES=/dev/ttyACM0
GPSD_OPTIONS=“-n -b -s 115200”
USBAUTO=“true”

The GPSD_OPTIONS passes settings as the service starts:

-n “Don’t wait for a client to connect before polling whatever GPS is associated with it.”

-b “Broken-device-safety mode, otherwise known as read-only mode. A few bluetooth and USB receivers lock up or become totally inaccessible when probed or reconfigured;”

-s 115200 Sets the speed the GPS can communicate on the usb bus.

Once I changed those settings, the Pi started working flawlessly. Even on a cold boot, it updates the location as soon as the GPS grabs a lock.

I don’t know if anyone needed this information. I only posted because it took me a while to figure out what was happening.

Have Fun!

Mark

4 Likes

:+1: :+1: :+1:

Thank you for recording your findings.
This is how we help each other and spread knowledge.

I run flightaware on a PC with ubuntu. On the Raspberry Pis, is GPS part of the setup? This is the 2nd time in 2 days I saw mentions of GPS – the first was yesterday with a flightfeeder (which may just be a RPI in a box) and today with this post.

No, I chose the Pi to be mobile. The GPS just updates the location of the receiver as it moves. You totally don’t need GPS for FlightAware if you a feeding it from a static location.

Mark

4 Likes

That’s super cool. Having FA on a desktop only I never even thought of that possibility. Thanks!

Thank you for this post. This helped me get GPS (and subsequently MLAT) working. :slight_smile:

Where did you find the variables info. -n, -s and so forth.

Trying to get my device to track movement.

GPSD has a flag of -f

Wondering if that means an equivalent of “fixed” location. Read once and thats it.

If I reboot at a different location it will find it, but the be locked there.

Going to try the set up in options listed below,

Crossing my fingers it works!