Add a GPS to Raspberry Pi running PiAware

I’ve tried a various amount of options and non have worked fully.

I am able to get FA/Dump1090 to see the location but that’s only if I reboot.

Nothing when I’ve tried on the move.

Any ideas as on the move would be ideal.

What type of GPS do you have to run on the RPI? I use a GPS dongle for RPI from Amazon.

Geekstory G72 G-Mouse USB GPS Dongle Glonass Beidou GNSS Receiver Module for Raspberry Pi Linux Window Geekstory, Better Than vk-172 GPS

I use it for Mobile ADSB in my pickup truck, Here is the installation video for this dongle. It is just a very generic dongle and instructional video.

Click on the video for the Raspberry PI setup link.
Hope this helps…

Morning thank you for your reply. I’m using the following off Amazon

DIYmalls VK-162 Remote Mount USB GPS Dongle G-Mouse Navigation External GPS Receiver Antenna for Raspberry Pi Linux Window Google Earth

For Raspberry Pi

VK-162 GPS receiver just plain works with Raspberry Pi. No grief, no surprises, no struggles.

Plug the unit into a free USB port on your Pi, run “sudo apt-get install gpsd” to install the basic GPS tools for the Pi, and away you go,then it quickly lock satellites.

I’ve had it working but I wanted live gps as in when moving for it to update. So is that what yours does?

What OS or image for the pi are you using. Then have you installed dump1090

dump1090 has support GPSD for some time. I have seen many references to this in the last.

You just need to enable GPSD in the piaware config

sudo piaware-config -showall

#use-gpsd yes # using default value

I am using it.

You can enable it by issuing this command
sudo piaware-config use-gpsd yes
sudo piaware-config -restart
Not sure if dump1090-fa would need to be restart too.

1 Like

It’s actually piaware, not dump1090 as such.

piaware will connect to a local gpsd and restart dump1090 (& faup1090) with the new position when there has been a sufficiently large change, and also update the mlat servers.

The main gotchas are:

  1. some GPS devices are not all that reliable and will tend to flap between reporting a position and not reporting a position, which can cause problems
  2. SkyAware has no mechanism to poll for an updated receiver location, so the receiver dot / range rings on the SkyAware display will not update unless you refresh the page.

The piaware config defaults to using gpsd data when available, you don’t need to explicitly configure this.

I’ve just flashed a fresh SD with Piaware 8.2
Enabled SSH
Added wifi in the piaware-config

I’ve connected the GPS, FA Pro Stick. Powered up and able to see map and traffic.

I ran you commands…
sudo piaware-config use-gpsd yes
sudo piaware-config -restart

Nothing showed. I then did sudo reboot and still nothing showing.

Edit, I’ve just ran sudo apt-get install gpsd and now it’ts showing GPS. Now to see if that works when moving

Just been out for a drive and the location didn’t update

No auto update
No update if refreshing

Does update on a power reboot

Does it need to move much in terms of distance from the home point starting


I’m in southeastern South Carolina (USA), and I have a mobile ADSB receiver set up in my pickup truck. I have a RPI4, Flightaware Pro Stick Plus, telescoping mag mount antenna mounted on the roof of the truck, adjusted to a half wave length, (approximately 5.3 inches, whip length), and a Geekstory G72 Mouse USB Dongle (vk-172 GPS).

My truck is a 2021 Ford Ranger, with a built-in (subscription) WIFI. The RPI4 is powered by a vehicle USB port when the truck is started, or the key is turned to the accessory position. The GPS dongle has a 1 to 2 minute cold start time, but it starts and a green light on the dongle flashes every second after it starts. The RPI is configured to use the wifi in the truck to connect to Flightaware.

In the logs, (seen when the gear icon is activated to show the log) I see the LAT/LON numbers presented as “lat --lon” I do not have a display in the truck to see the skyaware map to see my location, as that would be distracting while driving. However, I have used a tablet to view the skyaware map once I have reached my destination. The location is updated, the black location dot is displayed, and the range rings are correct. If I leave the tablet on while driving, the map has to be updated manually, it will not be automatically updated. If I plug in the actual LON/LAT numbers into Google Maps, I can see my actual location, ± 25-50 feet or so.

I find that the location will not be updated in the log, and on the map, until the vehicle has moved approximately 0.52 miles, (850 meters). Thanks, @OBJ! When I look at the log after a short trip, I see that the location changes sometimes every minute, or possibly 2 to 3 minutes, depending on cloud cover or tree canopy.

When the GPS updates it’s location, it triggers the piaware to restart, adding more time before piaware updates the mobile location again, and on each update, the process starts all over again. I have MLAT activated, and as I travel, I receive all of the types of plane broadcasts, the same as I see my stationary receivers do.

I did purchase the same GPS VK-162 GPS Remote Mount GPS that you did, and I have not been able to get it to work correctly yet. It works great stationary, but mobile, it doesn’t. I’m sure it’s operator error.

MY WISHLIST: In the stationary receivers, limit the polling of locations to every 5 minutes. When polling the location, do not restart piaware unless the location has changed. When mobile, update the location, but do not restart piaware. Maybe once an hour of less. Maybe something programmed into the software to click as a mobile or stationary receiver when in the initial setup.
I disabled the 978 portion of piaware, but when piaware restarts, it still looks to restart 978. If disabled, then don’t look for 978. Maybe I did that wrong.

Maybe through software, the option to be stationary or mobile can be selected.
I find that when mobile, I get much better reception, receive more planes, and I get planes further away that I do with any of my stationary receivers. Maybe more mobile users will sign up if mobile options are offered by Flightaware. I have been in this hobby since early 2017, and I love it. Let’s grow the hobby!!!


Hi Bert

Thank you for the reply. Lots of info there.

I’ve ordered a Stemedu Vk-172 Usb Dongle GPS Module G-mouse Glonass off Amazon and it’ll be here today.

So with regards to the Pi what flavour of Os/SD Image did you use? Also any configuration for it to run the GPS?

I think as you’ve pointed out the issue is the GPS not supporting movement.

Just to be clear as everyone’s flapping over this. I won’t be using the mobile/tablet/laptop device when driving. I am driving. This is for when being a passenger.

Hi Pete,
Here is the Youtube video link for instructions to set up the GPS on the RPI.

The video refers to all of the commands at the end of the video, but his list is not there. It’s good instructions, and works perfectly. Don’t worry about the python-gps, there is no file by that name.

I had to stop/start the video several times and put the command in the RPI manually.
Contact me again if you need to, I’ll help walk you through any problems you might have…

Hi Bert thank you.

Still unsure about Os. Are we using

Pi Aware 8.2 SD Card Image
Pi OS then install FA, dump etc.

GPS has arrived, sadly I’m work for a bit. If I can get it setup tonight I can test on a school run tomorrow morning.

I am using the Flightaware image on a 16GB SD card. The same OS that I downloaded from the Flightaware Build website. 8.2 version.
I used the program balenaEtcher to write the .img file to the SD card. I’m sure you have used something similar to write the program to your SD card.

Adding the GPS files will work, as your Flightaware is feeding info to the servers. By adding the GPS, then, your mobile station is resetting your location every couple of minutes. The dump1090-fa, or skyaware will not automatically update or reset your display map. You have to refresh your map- ctrl and F4 at the same time to refresh your viewer.
Good luck, I hope I have helped you get the GPS up and running. Please update me and let me know if I can be any further assistance.

P.S. I looked at your 2 stations, IMPRESSIVE!!!


Hi Bert,

Not long got in, got a beer in hand and started.

Okay cool so both on same page, I grabbed a new copy of 8.2, flash the SD using Etcher.
Made a ssh.txt note pad and renamed it by removing the .txt
Setup wifi on the config as well.

Booted on online, then change password from the default and also did the keep feeder ID and Stats
sudo piaware-config feeder-id INSERT ID HERE
sudo systemctl restart piaware

So far were cooking with gas and everything is running nicely. Now to add the GPS


So from the video the commands are

cd /dev/
sudo apt-get install gpsd gpsd-clients python-gps
sudo systemctl stop gpsd.socket
sudo systemctl disable gpsd.socket
vim /lib/systemd/system/gpsd.socket
sudo kilall gpsd
sudo gpsd /dev/ttyACM0 -F /var/run/gpsd.sock

However it’s not working and I get errors


Okay I ran

sudo apt-get update
sudo apt-get install gpsd gpsd-clients
sudo systemctl stop gpsd.socket
sudo systemctl disable gpsd.socket
vim /lib/systemd/system/gpsd.socket
sudo kilall gpsd
sudo gpsd /dev/ttyACM0 -F /var/run/gpsd.sock

If i run the sudo apt-get install gpsd gpsd-clients python-gps < I get an error.

sudo systemctl disable gpsd.socket < I get Removed /etc/systemd/system/

vim /lib/systemd/system/gpsd.socket < I get command not found.

sudo kilall gpsd < I get command not found.

I was really hoping to take this with me on saturday morning as away for a few days but im guessing not. Wish I could borrow someones SD card image and try it

I found another site that has something that the video that I posted left out. I forgot that I saw multiple sites before I got my GPS to work.

You may have done all of these steps before, but try them again, (I duplicated all of the below on another RPI, and it worked good.)

sudo apt -y install gpsd gpsd-clients python-gps


sudo nano /etc/default/gpsd

between the " " add if not already there----
DEVICES= “/dev/ttyACM0” ACMzero not Oh

ctrl o (enter) ctrl x

Then type at the prompt gpsmon You should see raw data in the box

cgps -s Should see a more stable box with LAT/LON, 3D FIX, and on the right side of the box you will see all of the satellites that your GPS is picking up. the “Y” indicates a good connection.

Some of these videos are really good, but I find that most of them leave out important steps. It’s hard to find a good PLUG and PLAY video!!! Cheers on the beer, I’m having a few myself.


The command is “killall”

Morning Bert,

Thank you again for this help.

Flash SD with 8.2
Remove SD and reinsert
Config wifi
Add ssh.txt and rename it ssh
Boot PI

SSH in
Change password

sudo apt-get update
sudo apt-get upgrade

Keep feeder ID and Stats
sudo piaware-config feeder-id WINK WINK NUDGE NUDGE
sudo systemctl restart piaware

Confirmed working, see local access, FA stats page. Then reboot whole system to be nice and fresh

Sudo reboot

sudo apt -y install gpsd gpsd-clients python-gps



sudo nano /etc/default/gpsd


DEVICES= “/dev/ttyACM0”

ctrl o (enter) ctrl x

I then got the following error.

pi@piaware:~ $ gpsmon
-bash: gpsmon: command not found

So I then tried

sudo apt-get install gpsd
sudo nano /etc/default/gpsd

Some stuff was listed but I populated with the below

DEVICES= “/dev/ttyACM0”

GPSMON or cgps -s gave no data so sudo reboot

Piaware home page gave GPS TAB in green with 3D lock and my long and lattiude.
Skyware map gave black dot, range rings and map zoomed in did show me being spot on.

GPSMON or cgps -s now give me data.

SO… I’m now going to hot spot to my phone. Take a drive and hope this works!!!

By the way I just saw your comment about my stats…

If you really fancy it HFDL, select Receiver on the top left, HFDL Merged and let the page reload. It’s 1054 am here but it’ll get busy I hope as the day goes on etc.

Okay change PiAware config WiFi to connect to my phone. This working no issues.

So loaded in the car, powered up, connected. 2 mins GPS connected but didn’t update location.

Drove to work and still no update.

So didn’t work sadly

For the 978 functionality, I would think you would be shutting that down in your Piaware config file that is read on boot.


When you look on your stats page, look at your logs. You should see that your LON and LAT changes every 3 to 5 minutes. If it doesn’t, then maybe your configuration is off somewhere. You may have to retrace your steps to see if some command has been left out or possibly a simple reboot might work.

I was hoping you would be a happy camper with a working GPS today!!!


I really don’t get why it’s not. Gone back over my steps. You’ve seen the error it gave.

I wish I could try your image or even do a remote session and you try it.