FlightAware Discussions

Troubleshooting SkyAware 5 issue? Randomly stops working

I’m running SkyAware 5.0 on a Raspberry Pi 4b with the blue FlightAware Pro Stick Plus and band-pass filter.

Everything has been working great for the last three months, but over the last week this setup has randomly stopped working several times. ADS-B tracking stops and no planes are visible on the map, but I am able to ssh to my Pi and reboot. That fixes the issues for a while, anywhere from a few minutes to a couple of days, but it will eventually quit working again.

Any suggestions on how to troubleshoot this issue? Are there error logs anywhere?

A bit more information:

  • Failures are getting more frequent, usually fails within an hour now
  • I noticed that dump1090-fa appears to have stopped running

Could this be a failing FlightAware USB stick?

I did have an issue some while back where the microSD card was failing, it could be read so PiAware worked fine but would not allow data to be written to it. Puzzled me for a bit until I tried to reinstall but all data remained the same.

New card solved it.

Just bought two Toshiba 16GB class 10 cards for £4.44 each. Don’t need anything big or fast for this hobby.

Geoff

Sounds very much like either the power supply or the SDR indeed.
Either of them could be responsible.

But with a pi4 it’s probably the official power supply and rather new, so the SDR might be more likely.

But these symptoms generally mean the SDR hangs due to low voltage or because it’s just dying.

Thanks for the help.

I will start swapping parts one at a time and see if that fixes anything. Starting with the SDR, then the power supply. I think the microSD card is fine, I was able to run apt-get update and upgrade without issue. The power supply is the official version, part of the CanaKit bundle, about three months old at this point