System Monitoring


#461

This is true ONLY IF you use Piaware image.

If you use Raspbian image, and install dump1090-fa by JP script, or the method I have posted above, then dump1090-fa configuration is NOT controlled by Piaware.

In case of package install by JP script or the method I posted above, the only parameter which Piaware (if installed) will over-ride in settings in files/etc/default/dump1090-fa and /usr/share/dump1090-fa/html/config.js is latitude and longitude. If Piaware is not installed, then latitude and longitude in dump1090-fa’s above noted config file will be valid and used.


#462

The script now mandates installation of piaware too even for package installation. I have tried both ways: - having dump1090-fa installed before running the script and also running the script without having the dump-1090 installed. In both instances, the script insists that that installing piaware is mandatory.

No explicit way of configuring dump1090-fa is now available. I am now going to try the via way - install dump1090-fa with piaware and then disable piaware.


#463

This is a DUMMY warning. Just ignore it

I have installed dump1090-fa by commands in my post above.

I had this BEFORE running JP’s script for Web Portal:

image

WHEN I STARTED JP’s SCRIPT:

I said <NO> to dump1090-fa

image

Wrong display showing Piaware will also be installed. I simply ignored it and pressed <YES>

image

After Web Portal Installatio: No Piaware installed

image


#464

@abcd567 - I was in the middle of the process as your post came through. Trying with dump1090-fa. After my last post I got distracted moving the boot partition to a USB drive :slight_smile:
Thank you!


#465

Now why on earth would you want to do that? :slight_smile:


#466

I initially worked on moving the boot partition but then learned that pi3 and 3b+ support direct boot from usb without i a microsd card. While with just moving the boot partition worked well and all applications worked albeit, slower, the move to boot directly from usb met with partial success. JP’s monitoring portal would not work - always ended up with 500 error page - server error on the browser.

Now, why did I do that - to save my microsd from wearing out too soon and also to a lesser extent, as an experiment.

I am now back with everything on the microsd card, I want to reduce the writes on the sdcard. I read about using adc earlier, but that didn’t work for me. Now back to getting dump1090-fa gui to work. I am struggling to edit /etc/default/dump1090-fa as I’ve no idea of the parameters to be used there.


#467

you want a net only configuration yes?
can you provide your dump1090-mut config?

ill see if i can “translate” it.


#468

I have the following:

DEVICE="none"
GAIN="max"


# dump1090-mutability configuration file
# This is a POSIX shell fragment.
# You can edit this file directly, or use
# "dpkg-reconfigure dump1090-mutability"

# Set to "yes" to start dump1090 on boot.
START_DUMP1090="yes"

# User to run dump1090 as.
DUMP1090_USER="dump1090"

# Logfile to log to
LOGFILE="/var/log/dump1090.log"

#
# Receiver options
#

# RTLSDR device index or serial number to use
# If set to "none", dump1090 will be started in --net-only mode
DEVICE="none"

# RTLSDR gain in dB.
# If set to "max" (the default) the maximum supported gain is used.
# If set to "agc", the tuner AGC is used to set the gain.
GAIN="max"

# RTLSDR frequency correction in PPM
PPM="0"

#
# Decoding options
#

# If yes, fixes messages with correctable CRC errors.
FIX_CRC="yes"

# If set, supplies a reference location for local position decoding.
LAT="0.0000"
LON="0.0000"

# If set, provides the absolute maximum receiver range used to
# filter bad position reports, and to determine when local position
# decoding is safe to use. Specify this in nautical miles (NM).
MAX_RANGE="400"
# Networking options
#

# Port to listen on for raw (AVR-format) input connections. 0 disables.
RAW_INPUT_PORT="0"

# Port to listen on for raw (AVR-format) output connections. 0 disables.
RAW_OUTPUT_PORT="0"

# Port to listen on for SBS-format output connections. 0 disables.
SBS_OUTPUT_PORT="0"

# Port to listen on for Beast-format input connections. 0 disables.
BEAST_INPUT_PORT="30005"

# Port to listen on for Beast-format output connections. 0 disables.
BEAST_OUTPUT_PORT="0"

# TCP heartbeat interval in seconds. 0 disables.
NET_HEARTBEAT="60"

# Minimum output buffer size per write, in bytes.
NET_OUTPUT_SIZE="500"

# Maximum buffering time before writing, in seconds.
NET_OUTPUT_INTERVAL="1"

# TCP buffer size, in bytes
NET_BUFFER="262144"

# Bind ports on a particular address. If unset, binds to all interfaces.
# This defaults to binding to localhost. If you need to allow remote
# connections, change this.
##NET_BIND_ADDRESS="127.0.0.1"

#
# Misc options
#

# Interval (in seconds) between logging stats to the logfile. 0 disables.
STATS_INTERVAL="3600"

# Path to write json state to (for use with an external webserver). Blank disables.
JSON_DIR="/run/dump1090-mutability"

# Interval between writing json state (in seconds). 0 disables.
JSON_INTERVAL="10"

# Accuracy of receiver location to write to json state, one of "exact" / "approximate" / "none"
JSON_LOCATION_ACCURACY="exact"

# Set to yes to log all decoded messages
# This can get large fast!
LOG_DECODED_MESSAGES="no"

# Additional options that are passed to the Daemon.
EXTRA_ARGS=""
#NET_BIND_ADDRESS=""

#469

Tested this and it should work just fine. As you can see with 0 all ports are disabled except Beast in on 30005 (which is kinda strange as that is normally the output port but oh well it’s your setup.)

You might want to change lat and lon. (where your receiver is or … something in between)
Also json-location-accuracy you can set to 2 if you want those coordinates exact on your webview.

Have fun!
Oh and i changed it so the webview will update every second instead every 10. 1 is now the default.

# dump1090-fa configuration
# This is read by the systemd service file as an environment file,
# and evaluated by some scripts as a POSIX shell fragment.

# If you are using a PiAware sdcard image, this config file is regenerated
# on boot based on the contents of piaware-config.txt; any changes made to this
# file will be lost.

RECEIVER_OPTIONS="--lat 50.12345 --lon 10.6789"
DECODER_OPTIONS="--stats-every 3600 --fix"
NET_OPTIONS="--net --net-only  --net-bi-port 30005 --net-bo-port 0 --net-ri-port 0 --net-ro-port 0 --net-sbs-port 0 --net-heartbeat 60 --net-ro-size 1000 --net-ro-interval 1"
JSON_OPTIONS="--json-location-accuracy 1 --write-json-every 1"

#470

Thank you so much @wiedehopf, really appreciate it. I will try this later today.

Edit: dump1090-fa does not seem to be reading any of the settings from the config file: /etc/default/dump1090-fa

I got a spinning wheel and the map had centered to the default location behind the spinning wheel even though i provided my coordinates within the config file. Is it that FA have implemented a tighter integration between dump1090-fa and piaware necessitating the installation of piaware?


#471

You should really not just edit your post if you want someone to read it. Only new message give a notification :wink:

No installing only piaware is fine.
I guess you already tried CTRL-F5?
Which address are you getting the spinning thing? (dump1090-fa is under /dump1090-fa normally)

I already explained you probably need to change your lighttpd config to get the stats going again as it expects data in /dump1090 on the webserver.


#472

I have noticed the min/max area in yellow is unnecessarily imprecise because it uses data older than 7 days which get recorded at a reduced resolution.

If you want to improve that resolution you can increase the time data are kept at the higher 7-day resolution. You only need day 8 so it’s 1440 table entries instead of 1260 entries with each entry representing 8 minutes.
This is the command to do this, if you are afraid about long term stats you might want to either not do this at all or do a backup of the file in question. Worked flawlessly for me without any data loss though.

sudo rrdtool tune /var/lib/collectd/rrd/localhost/dump1090-localhost/dump1090_messages-local_accepted.rrd RRA#6:=1440 RRA#7:=1440 RRA#8:=1440

This increases the size of that file from 152KB to 156KB so it’s not really noticeable.


#473

@wiedehopf
Thi sis good mod.
Better add a Pull Request at J Prochazka’s adsb-receiver at GitHub.


#474

@wiedehopf
Sorry for the late reply, just been busy with other things. I temporarily halted my ‘expedition’ but will restart over the weekend.


#475

Have you tried accessing the webinterface like this:

http://192.168.x.y/dump1090/
# or maybe:
http://192.168.x.y/dump1090-fa/

Maybe check if dump1090-fa and the webserver is running correctly (don’t hesitate to post the output if it’s not clear):

systemctl status dump1090-fa
systemctl status lighttpd

(Press Q to quit if it won’t let you back out to the console)