FlightAware Discussions

Strong amateur radio signal breaks 6.0 decoding

I host a VHF link to an amateur radio networked repeater. I’ve been running PiAware on a Zero-W for a couple of years. The decodes drop to zero when the link is active (as I would expect) but they returned to normal as soon as the link dropped.

I imaged a new SD card with 6.0 yesterday, and installed it in a Pi 3B+. It worked great! Lots more decodes than before. Unfortunately, when the link came up my decodes dropped to near zero, but don’t recover after the other transmission ends. I go from 500-600 decodes per second to 30 or less, and it stays there until I reboot. It’s fine from that point on, until the link comes up again.

I tried disabling the adaptive gain, but the problem persists. Any thoughts before I go back to the old configuration?

What do the dump1090 logs say? They’ll tell you what it is doing with gain.

With adaptive gain off, I’d expect no real difference between 5.0 and 6.0. I think you have something else going on here.

In the dump1090-fa/data/stats.json file, the gain goes from 43.4db to 0.9dB. Hmmm. That might be a problem! I guess I need to take another look at the gain settings and see what I missed. Thanks! Rick WØFH

Properly turning off adaptive gain worked. Thanks!

How much RF are you putting out and how close are the antennas?

Reading your description, you’ve made both a hardware change and a software change at the same time?
Try reverting one (but not the other) to see if the problem follows the hardware or software (my money is on hardware).

1 Like

I’d be interested in what it’s doing with adaptive gain on, if you still have those logs.

The dynamic range mode is not really designed to react rapidly to large changes in the noise floor, so I suspect what’s happening is that

a) dynamic range probes for a good gain setting and picks 43.4dB
b) transmitter fires up, noise floor goes way up, dynamic range notices this and starts reducing gain to try to reduce the noise floor, eventually hitting 0.9dB
c) transmitter stops transmitting, noise floor goes back to normal. Dynamic range does nothing (yet) because, in general, it can’t usefully detect that the external noise floor has dropped and it can safely increase gain, without actually trying an increased gain.
d) periodically, dynamic range will re-probe to see if an increased gain helps. When this happens, dynamic range should re-probe all the way back up to 43.4

Step (d) only happens once an hour by default, so possibly you didn’t wait long enough to see it change back. Or possibly there’s a bug in there… You can tune the re-probe interval with the --adaptive-range-rescan-delay option (unfortunately sdcard installs have no way of configuring this, you’d need a package install)