FlightAware Discussions

Stratux for 1090 and 978/UAT tracking?

Hello all. I am brand new to PiAware and flight tracking. I’m also new to the Raspberry PI world, so I don’t understand really any of what has been said about typing in programming code. So, I’ll explain what I am trying to do and where I am and hopefully someone can help me go from there.

I just purchased a Stratux setup and built it yesterday. By built, I mean that I put the parts together and downloaded an SD card image and flashed the card. Then I got to thinking that I could use the same hardware to feed FlightAware, so I reflashed the SD card with PiAware. That works great as well (once I figured out the wifi access).

So, this brings me to what I am trying to do. I would like to be able to utilize my Stratux hardware to see 1090 and 978/UAT aircraft. The helicopter I fly at work is UAT only and so it doesn’t show up on FlightAware or FlightRadar24. Ideally I’d like to configure my setup to feed 1090 and UAT to both FlightAware and FlightRadar24. I don’t want to change my hardware, because I want to swap out SD cards when I do recreational flying, so I can use the Stratux with my iPad for traffic and weather in the aircraft.

I have seen many topics with instructions for programming in commands, but I have no idea where to even access a screen to input edits.


For Beginners - How-to SSH to RPi - Setup Putty in Windows

Use the newest piaware image with this guide:
Piaware SD card image 3.7.1 Quickstart Guide

I think the stratux dongles already have different device serials, you should just use those instead of changing them.

FR24 can’t handle UAT type messages because their software development department seems pretty lethargic on the feeder site.

I’ve just finished a feed client for UAT/978 for adsbexchange if you like to feed your UAT there: https://github.com/wiedehopf/adsb-exchange-978#adsb-exchange-978

@wiedehopf thank you for the quick reply. Please bear with me as I am totally new to any kind of computer programming. I got the SSH to work and was able to login. I started to follow the directions to utilize two dongles, but I remember reading somewhere that Stratux has already serilized their dongles and I don’t want to change that because I want to retain usability of the Stratux for its original purpose. So, I ran the following “rtl_test -t” and it is only showing one dongle. What do I do now?

I think the 978 stratux thingie is not a generic dongle.

Needs some other dump978-fa option to use it.
Not sure, let me check.

If that is the case you can ignore the part about serializing the dongles.

Might not be supported using the piaware sd-card though.

  --stratuxv3 arg           read messages from Stratux v3 UAT dongle on given 
                            serial port

EDIT: It’s implemented in piaware sd card as well:

sudo piaware-config uat-receiver-type stratuxv3

This option should do it.

Yep, if the UAT dongle is a red PCB with components on one side only that says something like “stratux UATradio v1.0 Rev E” then you should use the stratuxv3 mode.

Ok, so if I understand correctly these are my next steps:

  1. Serialize the 1090 dongle
    • Configure UAT 978
sudo piaware-config uat-receiver-type sdr
sudo piaware-config rtlsdr-device-index 00001090
sudo piaware-config uat-receiver-type stratuxv3

# Reboot Pi to implement configuration settings
sudo reboot

No. You don’t need to serialize.
Just don’t use a serial in the following step (or use the one it already has, which is 1)

Just don’t do that. And don’t change the serial of the stick either.

and change the default password… :wink:

I cant get my StratuxV3 dongle to work with PiAware. Not sure where to begin. Both the 1090 SDR and the red StratuxV3 dongle are plugged in.

You got this far and also enabled uat via the piaware config?
I’ve already outlined in this thread that you use the guide provided and then deviate in regards to assigning the serials (which you don’t).

Thanks for your help. I now have the option to view UAT and 1090. I don’t see any traffic at the moment, but it seems to be working.