Starting from scratch

I’m a beginner, I don’t have knowledge in Linux, but I can’t help but accomplish what I want, even more with your help.
I already sent data to FA, FR24, PF, RB, PP and also visualized it in ModeSMixe, I used an image that a person passed me with everything configured, he accessed my network via TeamViewer and made the changes with my credentials, everything worked , but after a lot of reading in the post and after some updates I had the need to perform my own installation, some things are already working, but with an error in the FA that does not show its aircraft on port

Depends on what you’re trying to achieve. With no skills the Piaware Image would be the easiest to set up.
If you want to also improve your skills, i would recommend to use the Raspberry OS image and then use the script package from Piaware

It is no rocket science at all
Adding more feeders like FR24, Planefinder etc should work on both versions.

I prefer the Raspberry OS installation with package on top, but it’s totally up to you

1 Like

Then. I don’t just want piaware.
I need to feed the FR24 the PF the RB these I know how to configure well.

What I’m having trouble with is the FA that doesn’t show the aircraft on the map so as I had a friend trying to help me and it ended up being tiring for him I decided to take it alone, he even used the forum impersonating me to get help, but it was frustrating because he couldn’t fix a recurring error in the beast-splitter installation.
So I want to start myself from scratch, when I see that FA and PP are working I will proceed to install FR24, RB and PF.
I’m a concert let me break my head pass me the trick that will require more effort from me and also bring me more knowledge.

So I want to work with Raspberry OS.
Tell me the version to download and I’ll be here bothering you until you see my FA and PP running smooth

The easiest way for you is to use piAware image. This will work out of the box.

Then I’ll make sure you try the image Share your data - ADS-B Exchange
In this image, you need to specify in the settings that you are using the beast receiver.

Where did the OP mentioned that he is using Beast Receiver?


You have missed to give most important information: The receiver you are using.

Is it DVB-T receiver or something else?
If you dont clearly mention what your receiver is, then everyone thinks that you are using DVT-T RTL based receiver.

If you are using Beast Receiver, It can connect directly to FR24 feeder if you configure the FR24 feeder properly, and I think you have already done taht as your FR24 is working OK

To feed multiple sites, you will need to install beast-splitter. I can see from other post that beast splitter has been installed, but you face configuration problem, particularly port 30104.

Please read this:



Look at the picture, it is a Pi and a beast receiver : )

Edit: it is a old FA Flightfeeder with a Beast receiver, I think

1 Like

The author demonstrates the configuration of his receiver with the cover removed. But with cables connected.

Well, I have never seen a Beast, open or fully enclosed, neither in real nor in photo, so cannot make out.

Why the OP assumes that by looking at photo, people will know what it is. Why not explicitly say “I am using a Beast Recriver”

1 Like

Because the author does not know about his receiver:

By the way, it was Flightaware Feeder

1 Like

The above command is for manual start of beast-splitter.

If in beast-splitter config file, ENABLED=yes, then beast-splitter will automatically start at boot. Then above parameters should also be set in config file:

beast-splitter config file:



You mean to say it is Flightaware feeder, the older model which used Beast receiver. FA current models use RPi+ProStick receivers.

Well in this case @obj or @eric1tran may help


Você precisa instalar o dump1090-fa para permitir que o mlat-results se conecte à sua porta 30104.

Instalar dump1090-fa

sudo apt install dump1090-fa

set dump1090-fa to --net-only



You have to install dump1090-fa to enable mlat-results to connect to its port 30104.

Install dump1090-fa

sudo apt install dump1090-fa

In file:

(a) Change:

(b) Change


After all above, Reboot RPi


FlightFeeder version 6 looks like this inside:

so I think it’s a version 7:

If author use the piAware image, then everything will work right away. It remains only to install and configure ModeSMixer2 and install FR24, PF, RB, PP (FA already installed).
For the ADSBX image I had to compile. Therefore, I recommend using piAware.

git clone

cd  beast-splitter

sudo dpkg-buildpackage -b

cd ..

sudo dpkg -i beast-splitter_*.deb

sudo nano /etc/default/beast-splitter

# Configuration for beast-splitter.
# This is a shell-script fragment.
# Lines beginning with "#" are ignored.

# Set to "yes" to allow starting beast-splitter with this configuration.

# Input options for beast-splitter.
# This tells beast-splitter where to read data from.
# You should provide one of --net or --serial here
INPUT_OPTIONS="--serial /dev/ttyUSB0"
#INPUT_OPTIONS="--net remotehost:remoteport"

# Output options for beast-splitter.
# This tells beast-splitter where to send output to,
# either by establishing an outgoing connection (--connect)
# or by accepting inbound connections (--listen)
sudo systemctl status beast-splitter
● beast-splitter.service - Mode S Beast data forwarder
Loaded: loaded (/lib/systemd/system/beast-splitter.service; enabled; vendor preset: enabled)
Active: active (running) since Wed 2021-12-01 16:43:39 UTC; 3s ago
Docs: GitHub - flightaware/beast-splitter: Utility that distributes Mode-S Beast output to multiple clients
Main PID: 3564 (beast-splitter)
Tasks: 2 (limit: 2059)
CGroup: /system.slice/beast-splitter.service
└─3564 /usr/bin/beast-splitter --serial /dev/ttyUSB0 --listen 40005:R --connect localhost:40104:R --status-file /run/beast-splitter/status.json

Dec 01 16:43:39 adsbexchange systemd[1]: Started Mode S Beast data forwarder.
Dec 01 16:43:39 adsbexchange beast-splitter[3564]: Listening on
Dec 01 16:43:39 adsbexchange beast-splitter[3564]: Could not listen on [::]:40005: open: Address family not supported by protocol
Dec 01 16:43:39 adsbexchange beast-splitter[3564]: serial(/dev/ttyUSB0): opening port at 3000000bps
Dec 01 16:43:39 adsbexchange beast-splitter[3564]: serial(/dev/ttyUSB0): configured with settings: BCDfgHIjk
Dec 01 16:43:39 adsbexchange beast-splitter[3564]: localhost:40104: connection to failed: Connection refused
Dec 01 16:43:39 adsbexchange beast-splitter[3564]: localhost:40104: connection to failed: Connection refused
Dec 01 16:43:39 adsbexchange beast-splitter[3564]: localhost:40104: reconnecting in 60 seconds
Dec 01 16:43:39 adsbexchange beast-splitter[3564]: serial(/dev/ttyUSB0): autobaud selected 3000000 bps
1 Like


(1) Download & write to microSD card the Piaware SD card image:


(2) Configure piaware feeder id:
(Replace xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx by actual feeder-id)

sudo piaware-config feeder-id xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx  

sudo systemctl restart piaware  


(3) Connect Beast Receiver to RPi by a USB cable


(4) Configure piaware to use Beast receiver:

sudo piaware-config receiver-type beast  


(5) REBOOT RPi to implement config change made above:

sudo reboot  



Com essa imagem eu tenho acesso a tela ou só via SSH?

Ontem perdi a noite sem sucesso. Consegui rodar tudo com um dongle rtl. Rodando até o momento. Realmente o problema está na comunicação da RPI com a placa Beast-splitter.

Which screen? If you mean, then yes, at

Qual tela? Se você quer dizer, então sim, em

A Tela ao qual eu se refiro é um monitor ou tv ligado via HDMI

Amanhã vou instalar pra saber, estou gostando de quebrar a cabeça com isso. Depois vou pedir ajuda pra instalar o PP que acho que é mais difícil ainda.