Replaced flightaware pro with pro plus. Problem


#1

So I changed out my orange FlightAware Pro stick for a new FlightAware Pro Stick Plus.

Now I don’t have a signal and I felt an error “problem fetching data from dump 1090”

What did I do wrong?

I unplugged it and plugged it back in and still no luck


#2

Just put the Pro Stick back in and it works…

Could the Pro Stick Plus be bad?


#3

Check your power supply.


#4

It worked before and after I changed the stick.

Can’t be that. I checked when the plus stick was installed and the wireless was working


#5

No, seriously, check your power supply. The prostick plus is a little more power hungry and there have been perhaps half a dozen reports of “bad” prosticks recently that were fixed by replacing the power supply. Failing to talk to the dongle entirely is a symptom of this.


#6

Hmmmm. How do I do that? The light on the raspberry comes on.

What do I have to do to check the power supply?


#7

If you have another power supply, preferably higher in capacity than the current one, try it and see if the problem goes away.


#8

You already restarted the Pi and waited a few minutes, right? The new stick won’t automatically be recognized and start feeding data by just hot plug-replacing it with another unit. A reboot is the best way to restart all the dependent services and get it to use the new hardware.


#9

Hmmm. I was building a new Pi and I got the new stick for it and i was going to see if the new stick was better than the old stick hence the change.

Well it works on the new Pi… Guess I could change the power supply and put it on the old pi…

Yes I unplugged the Pi when I changed it.

Thanks!