Remove Dump1090 for Dump1090-FA


#1

Now I have my MLAT issue sorted, my mind is turning to changing the DUMP1090 interface, I would like to have the all singing and dancing FA version but if i remove the DUMP 1090 service and install dump1090-fa (says it is already installed) the system still wont work properly.

Is there a setting or config file I have to change to tell the system to look at the new program rather than dump1090?

Sorry for the newbie question, still getting to grips with Raspbian and its ways of working.

On a side issue I am still getting these errors:-

[2017-08-01 07:33 BST] 77165 msgs recv’d from dump1090 (1821 in last 5m); 77165 msgs sent to FlightAware
[2017-08-01 07:33 BST] mlat-client(3470): Beast-format results connection with ::1:30104: [Errno 111] Connection refused
[2017-08-01 07:34 BST] mlat-client(3470): Beast-format results connection with 127.0.0.1:30104: [Errno 111] Connection refused
[2017-08-01 07:34 BST] mlat-client(3470): Beast-format results connection with ::1:30104: [Errno 111] Connection refused

I have search but still cant find a definitive guide to sorting it, any ideas please?

Thanks in advance

Rich


#2

(1) What image you have written to your microSDcard:

Raspbian image downloaded from
raspberrypi.org/downloads

OR

Piaware image downloaded from
flightaware.com/adsb/piaware/build

(2) Please run following 3 commands and post the 3 outputs

apt-cache policy dump1090

apt-cache policy dump1090-mutabilty

apt-cache policy dump1090-fa


#3

The Raspbian Image is from the official Pi server

Results of each command

apt-cache policy dump1090

dump1090:
Installed: 3.5.0
Candidate: 3.5.1
Version table:
3.5.1 0
500 flightaware.com/adsb/piaware/files/packages/ jessie/piaware armhf Packages
*** 3.5.0 0
100 /var/lib/dpkg/status

apt-cache policy dump1090-mutabilty

N: Unable to locate package dump1090-mutabilty

apt-cache policy dump1090-fa

dump1090-fa:
Installed: 3.5.0
Candidate: 3.5.1
Version table:
3.5.1 0
500 flightaware.com/adsb/piaware/files/packages/ jessie/piaware armhf Packages
*** 3.5.0 0
100 /var/lib/dpkg/status

Thanks in advance for the assistance


#4

Did you originally install dump1090 (Malcom Robson), and then subsequently installed dump1090-fa without removing dump1090 (Malcom Robson)?


#5

Yes I think that might have been the case, is there any way round this?


#6

Type this address in your browser
/dump1090-fa/
If this does not bring the FA’s Skyview map, clear your browser’s cache and reload browser.


#7

Not Found

The requested URL /dump1090-fa/ was not found on this server.

Apache/2.4.10 (Raspbian) Server at 192.168.0.109 Port 80

Sadly nothing comes up


#8

Please run following command and post the output


sudo systemctl status lighttpd -l


#9

● lighttpd.service - Lighttpd Daemon
Loaded: loaded (/lib/systemd/system/lighttpd.service; enabled)
Active: failed (Result: exit-code) since Mon 2017-07-31 19:36:12 BST; 1 day 22h ago
Main PID: 718 (code=exited, status=255)

Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.

Thanks again


#10

Seems your folder /var/log/ which contains the lighttpd.log file gets deleted on reboot. The lighttpd crashes when it does not find its log file.

This usually happens if your folder /var/log/ is associated with tmpfs in fstab.
Please give the following command and post the output generated:
Note: Please delete all the three stars * from code below. I am forced to insert these to allow the system to post me the command :cry: :angry: :frowning:



cat  /*etc*/*fstab



#11

proc /proc proc defaults 0 0
PARTUUID=94bce6bb-01 /boot vfat defaults 0 2
PARTUUID=94bce6bb-02 / ext4 defaults,noatime 0 1

a swapfile is not a swap partition, no line here

use dphys-swapfile swap[on|off] for that

Thanks

Rich


#12

Well it is not as I expected. I cannot make out what is causing this. Those members who are Linux Guru, and Oliver (obj) may likely debug it.

If this was my Pi, I will take following course of action:

First I will try to uninstall dump1090 and lighttpd, then reinstall both.
This most likely fix the problem, but there is a risk of things getting worst.

UNINSTALL



sudo dpkg --remove dump1090
sudo dpkg --purge dump1090
sudo rm -rf /usr/share/dump1090

sudo dpkg --remove dump1090-fa
sudo dpkg --purge dump1090-fa
sudo rm -rf /usr/share/dump1090-fa

sudo dpkg --remove lighttpd
sudo dpkg --purge lighttpd


REINSTALL



wget http://flightaware.com/adsb/piaware/files/packages/pool/piaware/p/piaware-support/piaware-repository_3.5.1_all.deb
sudo dpkg -i piaware-repository_3.5.1_all.deb
sudo apt-get update

sudo apt-get install piaware

sudo piaware-config allow-auto-updates yes
sudo piaware-config allow-manual-updates yes

sudo apt-get install dump1090-fa

sudo reboot


If things worstend, I will go for a fresh install as follows:
(1) Format microSD card
(2) Download either Piaware 3.5.0 image or Raspbian Jessie image.
(3) Write the downloaded image to microSD card.
(4) If it was a Piaware SD card image, boot and that is all. The dump1090-fa and piaware data feeder are integral part of the piaware image. If it was a Raspbian Jessie image, boot and install dump1090-fa and Piaware data feeder.

A large number of hobbyist will not agree to my approach. Well, everyone is free to think and do whatever he/she considers right.

EDIT on Aug 04, 2017, 16:27 UTC:
In the uninstall steps, following commands were missed out. Have added these now in the uninstall step.
sudo rm -rf /usr/share/dump1090
sudo rm -rf /usr/share/dump1090-fa


#13

Thanks for the advice, I think i will try the reinstall method first and if all else fails I have another unit all set up (only a test rig) with a difference feeder station ID.

Which is the config file I need to sudo nano to amend the feeder ID and then I could just swap the cards!


#14

First find and save the “Unique Identifiers” of two Stations.

The Unique Identifier is in the format “xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx”. You can find it from any of these three places:

Easiest method, from your stats page: flightaware.com/adsb/stats/user/yourusername
From Pi: cat /var/log/piaware.log
From Pi: cat /var/cache/piaware/feeder_id

Copy-past Unique Identifiers “A” and “B” for two stations in a text file, and save the file. Now use the following method:

For station A



#Delete the current Unique Identifier "A" in cache 
sudo rm /var/cache/piaware/feeder_id

#Assign Unique Identifier "B" by piaware-config command below
#Replace “xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx” by Unique Identifier "B".

sudo piaware-config feeder-id xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx 

#Restart piaware 
sudo systemctl restart piaware


#Now confirm that feeder-id has been set correctly
sudo piaware-config -show feeder-id
#Above command will output feeder id as shown below
xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx

cat /var/cache/piaware/feeder_id  
#Above command will output feeder id as shown below                             
xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx



For station B
Use similar procedre as above.


#15

Thanks for the extra info, friends dropped in last night so didnt want to try it by the time they had gone and the wine had flowed!!

Will give it a go after work tonight, will give me a few hours to refix or use second method if all goes wrong with the first!!

Ill post results later

Cheers

Rich


#16

Just tried the reinstall method and all is working again but exactly as it was, with dump1090 still being the page it sends to rather than the fa style dump1090

Tried to post the output but it says I am not allowed to post code!!


#17

Delete folder dump1090 along with its contents, by following command:
sudo rm -rf /usr/share/dump1090

Now clear browser cache and reload map page.


#18

You sir are a legend!! All working fine now, thank you so much for you help

On a side note, looking at my stats, would you say they are doing ok? New aerial seems to have boosted my input in a big way