Really confused here


#1

I’m running dump1090-mutability 1.15~dev abd piaware 2.1.3.

I’ve tried all the fixes on the previous discussions i.e.

Edit /etc/default/dump1090-mutability

Port to listen on for Beast-format input connections. 0 disables.

BEAST_INPUT_PORT=“30104”

And I am STILL getting
Beast-format results connection with localhost:30104: [Errno 111] Connection refused

I’ve done this
$ sudo piaware-config -mlatResultsFormat “beast,connect,localhost:30104 basestation,listen,31003” && sudo service piaware restart

and nothing changes. I’m beginning to pull out what little hair i’ve got left :cry:

Does anyone have any help please?


#2

Did you restart dump1090-mutability after the config change?


#3

yes.

I shutdown the RPi2 and did a clean reboot


#4

Check which ports dump1090-mutability is actually listening on: sudo netstat -ntap | grep dump1090

and/or check /var/log/dump1090-mutability.log for errors.


#5

sure it´s 30104? or 30004?


#6

30104 is the current piaware default. But it doesn’t matter what you choose so long as you configure it the same on both sides (piaware and dump1090)


#7

I configured both to be 30104 and they worked for about 4 hours then the next day stopped working. I them re-configured them both to 30004 and it hasn’t thrown any more errors as of yet. Not sure if why 30104 stopped working or why it wont work now.


#8

I would guess that you have another dump1090 version running (with a different configuration) that’s competing for the dongle. This will be obvious if you look at the logs as I suggested.


#9

It would be obvious if it were in fact true, which its not!


#10

If it is happening, it will be obvious from the logs. What do the logs say at the time when you saw problems? I mean, dump1090 doesn’t randomly change its port configuration for no reason so obviously something is going on there.