Problems with &auth (Invalid argument)


#1

Hello FlightAware!

I am having problems with the &auth end of a FlightXML API call.

I am attempting to call the following url into a Google Spreadsheet:
http://flightxml.flightaware.com/json/FlightXML3/AirportBoards?airport_code=KOMA&type=enroute&howMany=15&offset=0&auth=(user, api key)

I get the following error:
{“error”:“Error Parsing Arguments – Invalid argument ‘auth’ supplied”}

I dropped the &auth off the URL and tried the call directly in my browser - supplying my credentials manually - and it worked fine. It’s just the &auth I’m having problems with. I searched these forums for the problem. One post suggested that the &auth user, key string needs to be encoded to base64. I tried several variants - with parenthesis, without, etc. - all encoded. Nothing worked.

I am not a programmer in the least, only a hobbyist. So, your patience and assistance are greatly appreciated!

P.S. Please note, I am generating the URL manually and not using script to make the call.


#2

Credentials should be supplied via the HTTP Basic Authorization standard of using the HTTP header “Authorization”, not as a GET argument. There is no such “auth” variable supported by FlightXML.

You can find some more information here: https://en.wikipedia.org/wiki/Basic_access_authentication#Client_side