Pro Stick Plus not receiving any signal

Just curious, are you using a PC power supply to run a Pi? How is it connected? If it is not connected to a PC Mainboard, maybe you are only getting the 2.5A from the 5v standby power that is there to boot it via lan?

I use the 350W power supply from an old PC on a bench. nothing else connected to it
but the 5V to Rpi and 12V to power a radio scanner.
I connected some cables to one of the plugs that powers a hard disk.
(had to sort couple of pins in the socket that normally plugs to M/B, to start it).

It does sound like it. Perhaps FlightAware staff can say if they’ve seen Pro Sticks die.

Lovely bit of kit, you’ll like it!

Ok, normally you have the case with an on/off switch, if it is atx. I am pretty sure that if you just plug it in, it is in standby mode, and only delivers the 2.5A 5VSB, SB meaning standby, until it is switched on.

This was meant to have the network card always on enabling wake on lan. Interesting that shorting pins worked.

I still would think about buying a quality 2.5A Pwer supply for the Pi, might be a more efficient way to power it. :grinning:

does the stick still work in windows? if it does try it in a powered usb hub connected to the pi.

If its drawing to much current (for your pi) the usb will shut down. A powered hub normally can supply a bit more current.

Windows machines have ample power at 5V available at USB ports to feed the Dongle properly.

Testing dongle directly plugged into Windows Desktop/Laptop eliminates power supply issues.

.
Is My DVB-T / Pro Stick / RTL SDR Dongle OK?

:point_down: Scroll down to:

OPTION-2: Dongle plugged into Windows Computer.

  • current observation -
    so I cannibalized and cut a usb cable and soldered it on top of prostick’s usb connector. I also added a small computer fan (was sitting on top of an old 486 cpu :wink:
    upon starting RPi was working for 15’’ and then could not be found by lsusb.
    did several reboot.
    after every reboot worked for about 15’’ and died.
    I removed dump1090-mutability 2.6.2 and installed the dump-fa without using Joe’s scripts, just FA.
    It is now working for 5 minutes (site 70297) so will see how it goes… :crossed_fingers:

an few hours later died again…

Blockquote
Mon Apr 23 09:26:28 2018 EEST dump1090-fa 3.5.3 starting up.
rtlsdr: using device #0: Generic RTL2832U (Realtek, RTL2832U, SN 00000002)
Found Rafael Micro R820T tuner
rtlsdr: tuner gain set to 49.6 dB
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1
rtlsdr_demod_write_reg failed with -1
rtlsdr_demod_read_reg failed with -1
rtlsdr_write_reg failed with -1
rtlsdr_write_reg failed with -1
weirdness: rtlsdr gave us a block with an unusual size (got 0 bytes, expected 262144 bytes)
weirdness: rtlsdr gave us a block with an unusual size (got 0 bytes, expected 262144 bytes)
.
.
.
weirdness: rtlsdr gave us a block with an unusual size (got 0 bytes, expected 262144 bytes)
Mon Apr 23 09:26:30 2018 EEST No data received from the SDR for a long time, it may have wedged

so after removing the usb connector from the pcb, I soldered a short usb cable.
in the process though managed to ‘loose’ C9 capacitor (near V+) connector.
started the RPi and then inserted the modified (!) prostickplus, after drilling
some extra holes on the top side for better ventilation. immediately and surprisingly
skyview came to life with ca 20 aircraft ! amazing considering…let’s see how long will last this time…:crossed_fingers:

so far ok after 20 minutes - no MLAT though. maybe related to the loss of C9.

@ support

can you please advise what is the value of capacitor C9 in ProstickPlus (blue) ?
and what is its function ?
thanks

Evangel

Sounds like you’ve inadvertently reflowed a dry/broken joint.

yeah probably. now mlat is back too.

if it was that close to to the USB connector it was probably some smoothing cap or part of a filter network, chances are you’ll be fine with out it.

Capacitor C9: Is it the SMD at top right corner in this Photo (just above Electrolytic Capacitor near USB connector)?

yes, that’s the one !

Any idea what this might mean?

Here’s what comes up with the first command

The only thing I can figure is that I may have damaged the cable when I installed a new security camera and had its cable go through the same 2" pipe the PIaware coax cable goes through (plus I accidentally yanked on it too)

I found the problem: The 1090MHz filter stopped working for some reason. Removed it, and started getting all the aircraft again. Did get the FlightAware Prostick (the yellow one). My old receiver was the NooElec R820T2 SDR & DVB-T NESDR Mini 2

That capacitor is between the + and - of the 5V supply via the USB connector, in parallel with the electrolytic capacitor… as you saw, it is not essential.

essential probably not, but maybe contributing to noise attenuation ? support never bothered to answer.

It is filtering the noise generated by the USB cord, required by FCC on all devices. Not affecting your reception.

1 Like

thanks, that is comforting.