Pro Stick Plus not receiving any signal


#1

I recently purchased a Pro Stick Plus along with the FlightAware 1090MHz ADS-B Antenna - 66cm / 26in and a uxcell N Type Male to SMA Male Test Antenna Coaxial RG58 Cable Connector Adapter all from Amazon.

I was hoping this would be an upgrade from my generic NooElec R820T SDR & DBP-T which would only pick up aircraft within ~50 miles. Unfortunately, I’m not receiving ANY signal from my new setup. According to the status page, piAware is connected successfully to the radio, but not receiving any signals.

What I’ve done so far: verified all connections, including using a multimeter to test connectivity all the way from the antenna end of the coax to the inside solder joint of the center pin in the Pro Stick Plus.

Any other thoughts or ideas?


#3

I have not changed any defaults from the standard piAware image for gain as of yet.

The coax is 2m long.


#5

I’ve tried a couple of those values but no luck. I’m guessing even if RG58 is not optimal, it would be good enough for getting local aircraft signal (I’m right down the street from an airport). Looks like LMR240 would be optimal?

It’s still baffling me that I’m getting ZERO received transmissions with this current setup.


#7

My rtlsdr-gain is at 20.7 right now. Still not seeing anything over the course of a half hour or so. For reference, this is the cable I’m using: http://a.co/1KLVZoq


#8

plz check the rafael 820t tuner is detected or not by
$ sudo systemctl status dump1090-fa -l

It may be a problem.


#9

Here is what I got:

pi@piaware:~$ sudo systemctl status dump1090-fa -l
dump1090-fa.service - dump1090 ADS-B receiver (FlightAware customization)
Loaded: loaded (/lib/systemd/system/dump1090-fa.service; enabled)
Active: active (running) since Sat 2018-04-21 11:09:34 CDT; 6s ago
Docs: https://flightaware.com/adsb/piaware/
Main PID: 987 (dump1090-fa)
CGroup: /system.slice/dump1090-fa.service
└─987 /usr/bin/dump1090-fa --net-bo-port 30005 --fix --device-index 0 --gain -10 --ppm 0 --max-range 360 --net --net-heartbeat 60 --net-ro-size 1000 --net-ro-interval 1 --net-http-port 0 --net-ri-port 0 --net-ro-port 30002 --net-sbs-port 30003 --net-bi-port 30004,30104 --json-location-accuracy 2 --lat 45.20536 --lon -93.19003 --write-json /run/dump1090-fa --quiet

Apr 21 11:09:34 piaware systemd[1]: Started dump1090 ADS-B receiver (FlightAware customization).
Apr 21 11:09:34 piaware dump1090-fa[987]: Sat Apr 21 11:09:34 2018 CDT dump1090-fa 3.5.3 starting up.
Apr 21 11:09:34 piaware dump1090-fa[987]: rtlsdr: using device #0: Generic RTL2832U (Realtek, RTL2832U, SN 00001000)
Apr 21 11:09:34 piaware dump1090-fa[987]: No supported tuner found
Apr 21 11:09:34 piaware dump1090-fa[987]: Enabled direct sampling mode, input 1
Apr 21 11:09:34 piaware dump1090-fa[987]: rtlsdr: enabling tuner AGC


#10

Yes…as i suspected…“no supported tuner found”…I have this same problem with a prostick, you have to reboot it several times or wait start it after 30 minutes.


#11

Are you just restarting dump1090-fa or the whole pi? Have you figured out any way around it, or every time it takes that long? Just seems a little crazy that it would work like that.


#12

the whole pi…it seems to be a power issue…mine starts at beginning but if somehow shuts down then hardly the tuner has a chance to be found…so i wait 30 min. and then again start…it works in mine. Your dongle is fine,it’s detected by pi…the problem is in the tuner chip. My that dongle worked once 19hrs continuously…make sure to avoid sudden shut down of pi when you see it’s working.


#13

Very strange. Well I will wait the half hour and see what happens.


#14

This time you first check the dump1090 status whether the tuner is detected or not…then start the skyview …adjust the antenna,tighten the connector…but never ever shut down the pi.


#15

same problem here
tuner recognition on/off mostly off.
probably end of life for my prostick plus only after 10 months continuous labor :angry:

10 days still awaiting support response !

try also rtl_test -t see what it says…


#16

I thought this is my problem only…now I see many of you’re having this. Please follow the steps as I said. It works in mine, hope it’ll work in yours too. It’s not a software problem.


#17

well it seems it all started after trying it in Windoze 7 with Zadig and HDSDR.
if i leave it unplugged for couple of days comes to life briefly then ‘hangs’
followed your steps and more but no joy. FYI I used a PC power supply to power
the RPi 5 VDC / 21 A , good cable, still nothing.
I am still not clear though if the second (steady LED) should be ‘off’, ‘green’ or ‘red’
in the RPi. Trying to find a software means to detect under/over voltage.

Blockquote
root@rpiSDsan8:/home/pi# Sun Apr 22 13:10:54 2018 EEST dump1090-mutability v1.15~dev starting up.
Using sample converter: UC8, integer/table path
Found 1 device(s):
0: Realtek, RTL2832U, SN: 00000002 (currently selected)
No supported tuner found
Enabled direct sampling mode, input 1
Closest available gain: 0.00 dB
Setting gain to: 0.00 dB
Gain reported by device: 0.00 dB
Sun Apr 22 13:10:57 2018 EEST No data received from the dongle for a long time, it may have wedged

Evangel


#18

@nncs20
@evangelyul

May be over heating is the cause.
Try:

  1. Move dongle to a colder location

  2. Remove plastic cover of the dongle to improve cooling

  3. Use a small fan to blow air on the dongle


#19

thanks abcd, will try that, it does get hot, can’t say if was always like that.
other issue is that the usb connector appears to have slack.


#20

@abcd567 I am still searching the exact cause for this, well my that feeder is running currently, detecting planes.


#21

“No supported tuner found” implies one of:

  • The PSU for the RPi is not sufficient to relaibly drive the Pro Stick Plus. It needs to be a 2.5A PSU such as the official RPi PSU. It looks like you’ve already ruled that out by testing with a 21A PSU (assuming that wasn’t a typo for a 2.1A PSU)
  • The connection to the RPi is problematic. Make sure the dongle is physically supported so it’s not levering the USB port. Try the other USB ports in the RPi. Try a decent short USB extension cable so you can try all the ports. Test other USB devices in the same ports and see if they have problems, suggesting a RPi problem.
  • The Pro Stick Plus is faulty. Perhaps pick up a cheap DVT-B dongle off Ebay or Amazon and see what you get with that.
  • The RPi is faulty. Can you try your setup in a different RPi? Or perhaps it’s an excuse to treat yourself to a 3B+ anyway.

#22

hi chrislfa
a. no typo, pc power supply has markings +5V/21A, +5VSB/2.5A, +12,-12, +3.3 etc.
(dont know or where is 5vsb/2.5a - I used red/black for HDD power plug)
checked with multimeetr ok.
b. tried all ports with/without long/short ext… same result
c. suspecting faulty Prostick as was working fine for the last 10 months.
I have 2 RPi 3 B, where both my v3+FA filter, and nooelec work fine.
d. as © above… probably next treat a uputronics saw/lna. :smile:

both rpi running Joe’s mutability.


#23

Just curious, are you using a PC power supply to run a Pi? How is it connected? If it is not connected to a PC Mainboard, maybe you are only getting the 2.5A from the 5v standby power that is there to boot it via lan?