PiAware SD Card 3.5.0 ModeAC switch


#1

Looking to enable Mode AC messages on a PiAware SD card 3.5 install.

Looking in the forums, I see the switch for allow-modeac yes and using that with piaware-config, it writes the key to the piaware-config.txt file but I am not seeing it show up in the dump1090-fa config file after restarting. Is this switch still an option in 3.5?


#2

allow-modeac yes is the default (both for the config file and in terms of what dump1090-fa does), you’ll only see the dump1090-fa command line options change if you set it to ‘no’.

Note that the default config has A/C turned off until a client explicitly asks for A/C data via a Beast command. If you are trying to receive A/C with a client that does not request it, you’ll need to force it on by hand by adding --modeac to the dump1090-fa command line.


#3

I am viewing the positions via view1090 on port 30005 and adding the --modeac switch to it’s command line, but still do not see and mode A/C reports. I am able to view Mode A/C reports from a different non-SD card PiAware installation.

Below are outputs of both config files


sudo cat /etc/default/dump1090-fa                                 # Generated automatically by fa_config_generator
# This file will be overwritten on reboot.
DECODER_OPTIONS="--max-range 360"
NET_OPTIONS="--net --net-heartbeat 60 --net-ro-size 1000 --net-ro-interval 1 --net-http-port 0 --net-ri-port 0 --net-ro-port 30002 --net-sbs-port 30003 --net-bi-port 30004,30104"
JSON_OPTIONS="--json-location-accuracy 2"
RECEIVER_OPTIONS="--net-bo-port 30005 --fix --device-index 0 --gain 33 --ppm 47"

pi@piaware:~$ sudo piaware-config -show
allow-auto-updates             yes                            # value set at /boot/piaware-config.txt:110
allow-dhcp-duid                no                             # value set at /boot/piaware-config.txt:124
allow-manual-updates           yes                            # value set at /boot/piaware-config.txt:114
allow-modeac                   yes                            # value set at /boot/piaware-config.txt:125
flightaware-password           <hidden>                       # value set at /boot/piaware-config.txt:123
flightaware-user               <hidden>                       # value set at /boot/piaware-config.txt:122
image-type                     piaware                        # value set at /usr/share/piaware-support/piaware-image-config.txt:5
manage-config                  yes                            # value set at /usr/share/piaware-support/piaware-image-config.txt:4
radarcape-host                 your-radarcape-hostname        # value set at /boot/piaware-config.txt:97
receiver-host                  your-receiver-hostname         # value set at /boot/piaware-config.txt:101
receiver-port                  30005                          # value set at /boot/piaware-config.txt:102
receiver-type                  rtlsdr                         # value set at /boot/piaware-config.txt:88
rfkill                         no                             # value set at /boot/piaware-config.txt:121
rtlsdr-device-index            0                              # value set at /boot/piaware-config.txt:91
rtlsdr-gain                    33                             # value set at /boot/piaware-config.txt:92
rtlsdr-ppm                     47                             # value set at /boot/piaware-config.txt:93




#4

“view1090-fa --modeac” should enable A/C for you. Non-FA variants probably won’t as the code to explicitly request A/C only got added recently.


#5

Understood. Thanks