where to config dump1090-fa manually (piaware sd-card 3.5.0)


#1

… hmmm - where to config dump1090-fa manually (piaware sd-card 3.5.0) - any ideas welcome :slight_smile:


#2

In Piaware 3.5.0 SD Card image, dont edit the file " / etc / default / dump1090-fa", as it will be overwritten on reboot by piaware-config, and all changes will be lost.

Method (1): Edit file “piaware-config.txt”:
sudo /boot/piaware-config.txt
#After edit, restart dump1090-fa
sudo systemctl restart dump1090-fa

Method (2): Use following command:
sudo piaware-config [property] [value]
sudo systemctl restart dump1090-fa

Example below:
sudo piaware-config rtlsdr-gain 30
sudo systemctl restart dump1090-fa

Please see details in “Advanced Cobfiguration” page
http://flightaware.com/adsb/piaware/advanced_configuration

To set location (latitude, longitude), go to settings on your stats page:
http://flightaware.com/adsb/stats/user/TomMuc
.


#3

thanx abcd,

these files were the first i tried - now tried again on your advice - but it still does not work :slight_smile:
/etc/default/dump1090-fa gets overwritten even if i disable piaware in systemd
and i found no way to set dump1090-fa to --net-only mode via piaware-config.txt

found the piaware sd image handy - and want to run dump in net-only mode as aggregator for my home network without running piaware …

any new ideas welcome :slight_smile:
tom

p.s. what are the exact differences between dump1090-fa and dump1090-mutability on github at the moment?


#4

Raspbian Jessie Lite image + dump1090-mutability will give you full control on dump1090.

If you like the GUI SkyView, you can change skin only, keeping dump1090-mutability v 1.15~dev. See the Tweak #2 (a) in the thread TWEAKS


#5

hi abcd,

i gave up trying to config dump1090-fa without running piaware in piaware sd-card-image :frowning:
instead i built a new jessie from scratch with mutability and followed your advice just to copy the dump-fa skyview map.
along your tweak #2 instruction this was done within 2 minutes.
thanks for sharing!

kind regards
tom


#6

If you have installed dump1090-mutability using JProchazka’s automated installed script from “Adsb Receiver Project Scripts”, it will have a small bug, which will display on map, the data and range circles in metric units, even if you have set units as Imperial.

If you want to use Metric units, this bug will not bother you, but if you want nautical miles, you will have to remove this bug.
The method to remove this bug is given as NOTE in item “Tweek-1 (1) INCREASING NUMBER OF RANGE CIRCLES” of thread TWEAKS.


#7

haha - thanx - no - i prefer to install just what i want/need - that’s why i installed it fresh from github on my own :slight_smile: